aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/p5-GnuPG-Interface/Makefile25
-rw-r--r--security/p5-GnuPG-Interface/distinfo2
-rw-r--r--security/p5-GnuPG-Interface/pkg-plist1
3 files changed, 16 insertions, 12 deletions
diff --git a/security/p5-GnuPG-Interface/Makefile b/security/p5-GnuPG-Interface/Makefile
index 6c9dc6813031..3349e898ce2f 100644
--- a/security/p5-GnuPG-Interface/Makefile
+++ b/security/p5-GnuPG-Interface/Makefile
@@ -6,29 +6,32 @@
#
PORTNAME= GnuPG-Interface
-PORTVERSION= 0.11
+PORTVERSION= 0.31
CATEGORIES= security perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= GnuPG
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= GnuPG gnupg-interface
PKGNAMEPREFIX= p5-
MAINTAINER= trevor@FreeBSD.org
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
+ ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= GnuPG::Handles.3 \
- GnuPG::SecretKey.3 \
+MAN3= GnuPG::Fingerprint.3 \
+ GnuPG::Handles.3 \
GnuPG::Interface.3 \
+ GnuPG::Key.3 \
+ GnuPG::Options.3 \
+ GnuPG::PrimaryKey.3 \
+ GnuPG::PublicKey.3 \
+ GnuPG::SecretKey.3 \
GnuPG::Signature.3 \
GnuPG::SubKey.3 \
- GnuPG::Fingerprint.3 \
- GnuPG::PublicKey.3 \
- GnuPG::Key.3 \
- GnuPG::UserId.3 \
- GnuPG::Options.3
+ GnuPG::UserId.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>
diff --git a/security/p5-GnuPG-Interface/distinfo b/security/p5-GnuPG-Interface/distinfo
index 627df95b5104..9b20db32cb7c 100644
--- a/security/p5-GnuPG-Interface/distinfo
+++ b/security/p5-GnuPG-Interface/distinfo
@@ -1 +1 @@
-MD5 (GnuPG-Interface-0.11.tar.gz) = b392f3a644e15d489ea5da8dac2168c1
+MD5 (GnuPG-Interface-0.31.tar.gz) = 657baf421c8b2cbe0560a66a9fe7ef02
diff --git a/security/p5-GnuPG-Interface/pkg-plist b/security/p5-GnuPG-Interface/pkg-plist
index 71133c76cdfe..491791a8ee5f 100644
--- a/security/p5-GnuPG-Interface/pkg-plist
+++ b/security/p5-GnuPG-Interface/pkg-plist
@@ -3,6 +3,7 @@ lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Handles.pm
lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Interface.pm
lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Key.pm
lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Options.pm
+lib/perl5/site_perl/%%PERL_VER%%/GnuPG/PrimaryKey.pm
lib/perl5/site_perl/%%PERL_VER%%/GnuPG/PublicKey.pm
lib/perl5/site_perl/%%PERL_VER%%/GnuPG/SecretKey.pm
lib/perl5/site_perl/%%PERL_VER%%/GnuPG/Signature.pm