aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/p5-Games-Tournament-RoundRobin/Makefile29
-rw-r--r--games/p5-Games-Tournament-RoundRobin/distinfo3
-rw-r--r--games/p5-Games-Tournament-RoundRobin/pkg-descr11
-rw-r--r--games/p5-Games-Tournament-RoundRobin/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 524adf07b36c..0a5bc993dcfc 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -439,6 +439,7 @@
SUBDIR += p5-Games-Bingo-Bot
SUBDIR += p5-Games-Bingo-Print
SUBDIR += p5-Games-Dice
+ SUBDIR += p5-Games-Tournament-RoundRobin
SUBDIR += pachi
SUBDIR += pathological
SUBDIR += pcgen
diff --git a/games/p5-Games-Tournament-RoundRobin/Makefile b/games/p5-Games-Tournament-RoundRobin/Makefile
new file mode 100644
index 000000000000..520d23e57350
--- /dev/null
+++ b/games/p5-Games-Tournament-RoundRobin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Games-Tournament-RoundRobin
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Tournament-RoundRobin
+PORTVERSION= 0.01
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Round-Robin Tournament Schedule Pairings
+
+MAN3= Games::Tournament::RoundRobin.3 \
+ Games::League::Member.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/p5-Games-Tournament-RoundRobin/distinfo b/games/p5-Games-Tournament-RoundRobin/distinfo
new file mode 100644
index 000000000000..15265af7c45d
--- /dev/null
+++ b/games/p5-Games-Tournament-RoundRobin/distinfo
@@ -0,0 +1,3 @@
+MD5 (Games-Tournament-RoundRobin-0.01.tar.gz) = 97648c1360d592e3baf22bcba4effc3a
+SHA256 (Games-Tournament-RoundRobin-0.01.tar.gz) = ad7fd08fe2df6b1c65bd0ff090202a0b9489ca3cb8105a36227690897ed47d0c
+SIZE (Games-Tournament-RoundRobin-0.01.tar.gz) = 9799
diff --git a/games/p5-Games-Tournament-RoundRobin/pkg-descr b/games/p5-Games-Tournament-RoundRobin/pkg-descr
new file mode 100644
index 000000000000..6f7b784a076d
--- /dev/null
+++ b/games/p5-Games-Tournament-RoundRobin/pkg-descr
@@ -0,0 +1,11 @@
+Every member of a league of 2n players can be paired with every other
+member in 2n-1 rounds.
+
+If the league members are (Inf, 1 .. 2n-1), then in round i, i can be
+paired with Inf, and a can meet b, where a+b = 2i (mod 2n-1).
+
+WWW: http://search.cpan.org/dist/Games-Tournament-RoundRobin
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/games/p5-Games-Tournament-RoundRobin/pkg-plist b/games/p5-Games-Tournament-RoundRobin/pkg-plist
new file mode 100644
index 000000000000..ffe1750526fb
--- /dev/null
+++ b/games/p5-Games-Tournament-RoundRobin/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Games/League/Member.pm
+%%SITE_PERL%%/Games/Tournament/RoundRobin.pm
+@dirrm %%SITE_PERL%%/Games/Tournament
+@dirrm %%SITE_PERL%%/Games/League
+@dirrmtry %%SITE_PERL%%/Games