aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/monkeybubble/Makefile8
-rw-r--r--graphics/multivideo/files/patch-my_thread_process.hh11
2 files changed, 18 insertions, 1 deletions
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index 49fd22d9c2b7..ac1b95cf69a8 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -29,4 +29,10 @@ GCONF_SCHEMAS= monkey-bubble.schemas
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/src/net/Makefile.in \
+ ${WRKSRC}/src/ui/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/graphics/multivideo/files/patch-my_thread_process.hh b/graphics/multivideo/files/patch-my_thread_process.hh
new file mode 100644
index 000000000000..8c7911164163
--- /dev/null
+++ b/graphics/multivideo/files/patch-my_thread_process.hh
@@ -0,0 +1,11 @@
+--- my_thread_process.hh.orig Fri Dec 22 16:09:57 2006
++++ my_thread_process.hh Fri Dec 22 16:10:18 2006
+@@ -32,7 +32,7 @@
+ sequence* my_sequence;
+ unsigned char * data;
+ unsigned char** data_images;
+- bool my_thread_process::conditions_for_break(int i,type_of_current_reading cr);
++ bool conditions_for_break(int i,type_of_current_reading cr);
+ public:
+ bool should_continue;
+ my_thread_process(my_frame& frame,buffer& buf,sequence& seq);