aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/poweradmin/Makefile18
-rw-r--r--dns/poweradmin/distinfo6
-rw-r--r--dns/poweradmin/files/patch-poweradmin-mysql-db-structure.sql62
-rw-r--r--dns/poweradmin/files/patch-poweradmin-pqsql-db-structure.sql23
-rw-r--r--dns/poweradmin/files/patch-templates.inc.php11
5 files changed, 109 insertions, 11 deletions
diff --git a/dns/poweradmin/Makefile b/dns/poweradmin/Makefile
index 9355d91f2b30..1f4b171892ff 100644
--- a/dns/poweradmin/Makefile
+++ b/dns/poweradmin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= poweradmin
-PORTVERSION= 2.1.3
-PORTREVISION= 1
+PORTVERSION= 2.1.4
CATEGORIES= dns www
MASTER_SITES= https://www.poweradmin.org/download/
EXTRACT_SUFX= .tgz
@@ -15,12 +14,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= eg@fbsd.lt
COMMENT= A set of PHP-scripts to manage PowerDNS over the web
-USE_PHP= gettext
+USE_PHP= gettext session
WANT_PHP_WEB= yes
NO_BUILD= yes
PEARDIR= ${PREFIX}/share/pear
-OPTIONS= POSTGRESQL "Use PostgreSQL database instead of MySQL" off
+OPTIONS= MYSQL "Use Mysql database support" on \
+ PGSQL "Use Pgsql database support" off
SUB_FILES= pkg-message
@@ -31,12 +31,14 @@ PLIST= ${WRKDIR}/plist
.include <bsd.port.pre.mk>
-.if defined(WITH_POSTGRESQL)
-RUN_DEPENDS+= ${PEARDIR}/MDB2/Driver/pgsql.php:${PORTSDIR}/databases/pear-MDB2_Driver_pgsql
-.else
+.if defined(WITH_MYSQL)
RUN_DEPENDS+= ${PEARDIR}/MDB2/Driver/mysql.php:${PORTSDIR}/databases/pear-MDB2_Driver_mysql
.endif
+.if defined(WITH_PGSQL)
+RUN_DEPENDS+= ${PEARDIR}/MDB2/Driver/pgsql.php:${PORTSDIR}/databases/pear-MDB2_Driver_pgsql
+.endif
+
post-extract:
@cd ${WRKSRC} && ${RM} -rf "install"
@@ -65,7 +67,7 @@ install-app:
install-conf: install-app
cd ${WWWDIR}/${CFGDIR} ; \
- ${CHMOD} 0640 config-me.inc.php ; \
+ ${CHMOD} 0644 config-me.inc.php ; \
if ${TEST} ! -f ${CFGFILE} ; then \
${CP} -p config-me.inc.php ${CFGFILE} ; \
fi
diff --git a/dns/poweradmin/distinfo b/dns/poweradmin/distinfo
index e8f086e7b159..d7f1ececc7fb 100644
--- a/dns/poweradmin/distinfo
+++ b/dns/poweradmin/distinfo
@@ -1,3 +1,3 @@
-MD5 (poweradmin-2.1.3.tgz) = 3647703a40d6d8109f86f6b3cce0d310
-SHA256 (poweradmin-2.1.3.tgz) = 3cc545d0a8979ca6a60f3b41368f1bea827243b94ae7311c0c502f74ef25b2ac
-SIZE (poweradmin-2.1.3.tgz) = 93541
+MD5 (poweradmin-2.1.4.tgz) = 55b762bebc290bd1be061cb3363f976a
+SHA256 (poweradmin-2.1.4.tgz) = 46a13d4ce34444896ed95d265935fc7605aadc489f81214d545f8ee8a47137a1
+SIZE (poweradmin-2.1.4.tgz) = 121052
diff --git a/dns/poweradmin/files/patch-poweradmin-mysql-db-structure.sql b/dns/poweradmin/files/patch-poweradmin-mysql-db-structure.sql
new file mode 100644
index 000000000000..0323e7921d8b
--- /dev/null
+++ b/dns/poweradmin/files/patch-poweradmin-mysql-db-structure.sql
@@ -0,0 +1,62 @@
+--- docs/poweradmin-mysql-db-structure.sql.orig 2008-03-27 22:38:03.000000000 +0200
++++ docs/poweradmin-mysql-db-structure.sql 2010-03-14 17:07:14.000000000 +0200
+@@ -1,4 +1,3 @@
+-DROP TABLE IF EXISTS `users`;
+ CREATE TABLE `users` (
+ `id` int(11) NOT NULL auto_increment,
+ `username` varchar(16) NOT NULL default '',
+@@ -15,7 +14,6 @@
+ INSERT INTO `users` VALUES (1,'admin','21232f297a57a5a743894a0e4a801fc3','Administrator','admin@example.net','Administrator with full rights.',1,1);
+ UNLOCK TABLES;
+
+-DROP TABLE IF EXISTS `perm_items`;
+ CREATE TABLE `perm_items` (
+ `id` int(11) NOT NULL auto_increment,
+ `name` varchar(64) NOT NULL,
+@@ -27,7 +25,6 @@
+ INSERT INTO `perm_items` VALUES (41,'zone_master_add','User is allowed to add new master zones.'),(42,'zone_slave_add','User is allowed to add new slave zones.'),(43,'zone_content_view_own','User is allowed to see the content and meta data of zones he owns.'),(44,'zone_content_edit_own','User is allowed to edit the content of zones he owns.'),(45,'zone_meta_edit_own','User is allowed to edit the meta data of zones he owns.'),(46,'zone_content_view_others','User is allowed to see the content and meta data of zones he does not own.'),(47,'zone_content_edit_others','User is allowed to edit the content of zones he does not own.'),(48,'zone_meta_edit_others','User is allowed to edit the meta data of zones he does not own.'),(49,'search','User is allowed to perform searches.'),(50,'supermaster_view','User is allowed to view supermasters.'),(51,'supermaster_add','User is allowed to add new supermasters.'),(52,'supermaster_edit','User is allowed to edit supermasters.'),(53,'user_is_ueberuser','User has full access. God-like. Redeemer.'),(54,'user_view_others','User is allowed to see other users and their details.'),(55,'user_add_new','User is allowed to add new users.'),(56,'user_edit_own','User is allowed to edit their own details.'),(57,'user_edit_others','User is allowed to edit other users.'),(58,'user_passwd_edit_others','User is allowed to edit the password of other users.'),(59,'user_edit_templ_perm','User is allowed to change the permission template that is assigned to a us er.'),(60,'templ_perm_add','User is allowed to add new permission templates.'),(61,'templ_perm_edit','User is allowed to edit existing permission templates.');
+ UNLOCK TABLES;
+
+-DROP TABLE IF EXISTS `perm_templ`;
+ CREATE TABLE `perm_templ` (
+ `id` int(11) NOT NULL auto_increment,
+ `name` varchar(128) NOT NULL,
+@@ -39,7 +36,6 @@
+ INSERT INTO `perm_templ` VALUES (1,'Administrator','Administrator template with full rights.');
+ UNLOCK TABLES;
+
+-DROP TABLE IF EXISTS `perm_templ_items`;
+ CREATE TABLE `perm_templ_items` (
+ `id` int(11) NOT NULL auto_increment,
+ `templ_id` int(11) NOT NULL,
+@@ -51,7 +47,6 @@
+ INSERT INTO `perm_templ_items` VALUES (249,1,53);
+ UNLOCK TABLES;
+
+-DROP TABLE IF EXISTS `zones`;
+ CREATE TABLE `zones` (
+ `id` int(11) NOT NULL auto_increment,
+ `domain_id` int(11) NOT NULL default '0',
+@@ -60,3 +55,22 @@
+ PRIMARY KEY (`id`),
+ KEY `owner` (`owner`)
+ ) ENGINE=MyISAM AUTO_INCREMENT=22001 DEFAULT CHARSET=latin1;
++
++CREATE TABLE IF NOT EXISTS `zone_templ` (
++ `id` int(11) NOT NULL auto_increment,
++ `name` varchar(128) NOT NULL,
++ `descr` varchar(1024) NOT NULL,
++ `owner` int(11) NOT NULL,
++ PRIMARY KEY (`id`)
++) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=latin1;
++
++CREATE TABLE IF NOT EXISTS `zone_templ_records` (
++ `id` int(11) NOT NULL auto_increment,
++ `zone_templ_id` int(11) NOT NULL,
++ `name` varchar(255) NOT NULL,
++ `type` varchar(6) NOT NULL,
++ `content` varchar(255) NOT NULL,
++ `ttl` int(11) NOT NULL,
++ `prio` int(11) NOT NULL,
++ PRIMARY KEY (`id`)
++) ENGINE=MyISAM AUTO_INCREMENT=1 DEFAULT CHARSET=latin1;
diff --git a/dns/poweradmin/files/patch-poweradmin-pqsql-db-structure.sql b/dns/poweradmin/files/patch-poweradmin-pqsql-db-structure.sql
new file mode 100644
index 000000000000..6b8136a13173
--- /dev/null
+++ b/dns/poweradmin/files/patch-poweradmin-pqsql-db-structure.sql
@@ -0,0 +1,23 @@
+--- docs/poweradmin-pgsql-db-structure.sql.orig 2010-03-14 17:18:54.000000000 +0200
++++ docs/poweradmin-pgsql-db-structure.sql 2010-03-14 17:28:38.000000000 +0200
+@@ -63,3 +63,20 @@
+ );
+
+ CREATE INDEX zone_domain_owner ON zones(domain_id, owner);
++
++CREATE TABLE zone_templ (
++ id SERIAL PRIMARY KEY,
++ name varchar(128) NOT NULL,
++ descr text NOT NULL,
++ owner integer default 0
++);
++
++CREATE TABLE zone_templ_records (
++ id SERIAL PRIMARY KEY,
++ zone_templ_id integer NOT NULL,
++ name varchar(255) NOT NULL,
++ type varchar(6) NOT NULL,
++ content varchar(255) NOT NULL,
++ ttl integer default NULL,
++ prio integer default NULL
++);
diff --git a/dns/poweradmin/files/patch-templates.inc.php b/dns/poweradmin/files/patch-templates.inc.php
new file mode 100644
index 000000000000..895e8e7c6d8e
--- /dev/null
+++ b/dns/poweradmin/files/patch-templates.inc.php
@@ -0,0 +1,11 @@
+--- inc/templates.inc.php.orig 2010-03-14 16:47:47.000000000 +0200
++++ inc/templates.inc.php 2010-03-14 16:48:00.000000000 +0200
+@@ -193,7 +193,7 @@
+ while($r = $result->fetchRow()) {
+ // Call get_record_from_id for each row.
+ $ret[$retcount] = get_zone_templ_record_from_id($r["id"]);
+- $retcount;
++ $retcount++;
+ }
+ return $ret;
+ }