aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-gon-rails4/Makefile23
-rw-r--r--www/rubygem-gon-rails4/distinfo2
-rw-r--r--www/rubygem-gon-rails4/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b770722de85e..04ffd000bba8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1775,6 +1775,7 @@
SUBDIR += rubygem-gitlab-grack
SUBDIR += rubygem-gollum-lib
SUBDIR += rubygem-gon
+ SUBDIR += rubygem-gon-rails4
SUBDIR += rubygem-haml
SUBDIR += rubygem-haml-coderay
SUBDIR += rubygem-haml-contrib
diff --git a/www/rubygem-gon-rails4/Makefile b/www/rubygem-gon-rails4/Makefile
new file mode 100644
index 000000000000..557957ec07ff
--- /dev/null
+++ b/www/rubygem-gon-rails4/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= gon
+PORTVERSION= 5.2.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails4
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Framework to pass data to JS easily
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-actionpack4>=4.1.6:${PORTSDIR}/www/rubygem-actionpack4 \
+ rubygem-json>=0:${PORTSDIR}/devel/rubygem-json \
+ rubygem-multi_json>=0:${PORTSDIR}/devel/rubygem-multi_json \
+ rubygem-request_store>=1.0.5:${PORTSDIR}/devel/rubygem-request_store
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-gon-rails4/distinfo b/www/rubygem-gon-rails4/distinfo
new file mode 100644
index 000000000000..502ca2762e48
--- /dev/null
+++ b/www/rubygem-gon-rails4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/gon-5.2.0.gem) = ec88be002243232b3f0e5d08242e3b5e90b340481dc460329f2dab4aa4203859
+SIZE (rubygem/gon-5.2.0.gem) = 157184
diff --git a/www/rubygem-gon-rails4/pkg-descr b/www/rubygem-gon-rails4/pkg-descr
new file mode 100644
index 000000000000..4b875fedb583
--- /dev/null
+++ b/www/rubygem-gon-rails4/pkg-descr
@@ -0,0 +1,4 @@
+If you need to send some data to your js files and you don't want to do this
+with long way trough views and parsing - use this force!
+
+WWW: https://github.com/gazay/gon