aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/pear-HTML_AJAX/Makefile9
-rw-r--r--www/pear-HTML_TagCloud/Makefile9
-rw-r--r--www/pear-HTTP/Makefile9
-rw-r--r--www/pear-HTTP_Client/Makefile6
-rw-r--r--www/pear-HTTP_Download/Makefile6
-rw-r--r--www/pear-HTTP_FloodControl/Makefile21
-rw-r--r--www/pear-HTTP_Header/Makefile6
-rw-r--r--www/pear-HTTP_Request/Makefile6
-rw-r--r--www/pear-HTTP_Request2/Makefile19
-rw-r--r--www/pear-HTTP_Server/Makefile6
-rw-r--r--www/pear-HTTP_Session2/Makefile10
-rw-r--r--www/pear-HTTP_Upload/Makefile9
-rw-r--r--www/pear-HTTP_WebDAV_Client/Makefile5
-rw-r--r--www/pear-HTTP_WebDAV_Server/Makefile6
-rw-r--r--www/pear-Services_Amazon/Makefile12
-rw-r--r--www/pear-Services_Amazon_S3/Makefile12
-rw-r--r--www/pear-Services_Blogging/Makefile12
-rw-r--r--www/pear-Services_Compete/Makefile6
-rw-r--r--www/pear-Services_Delicious/Makefile13
-rw-r--r--www/pear-Services_Digg/Makefile9
-rw-r--r--www/pear-Services_Facebook/Makefile6
-rw-r--r--www/pear-Services_GeoNames/Makefile12
-rw-r--r--www/pear-Services_Google/Makefile6
-rw-r--r--www/pear-Services_OpenSearch/Makefile7
-rw-r--r--www/pear-Services_SharedBook/Makefile6
-rw-r--r--www/pear-Services_ShortURL/Makefile10
-rw-r--r--www/pear-Services_TinyURL/Makefile9
-rw-r--r--www/pear-Services_TwitPic/Makefile9
-rw-r--r--www/pear-Services_W3C_CSSValidator/Makefile6
-rw-r--r--www/pear-Services_W3C_HTMLValidator/Makefile12
-rw-r--r--www/pear-Services_Yadis/Makefile9
-rw-r--r--www/pear-Services_Yahoo/Makefile9
-rw-r--r--www/pear-Services_urlTea/Makefile9
-rw-r--r--www/pear-Structures_DataGrid_Renderer_Flexy/Makefile7
-rw-r--r--www/pear-Structures_DataGrid_Renderer_Pager/Makefile7
-rw-r--r--www/pear-Structures_DataGrid_Renderer_Smarty/Makefile7
-rw-r--r--www/pear-Text_Wiki/Makefile9
-rw-r--r--www/pear-UDDI/Makefile6
-rw-r--r--www/pear-XML_GRDDL/Makefile12
-rw-r--r--www/pear-twig/Makefile6
40 files changed, 99 insertions, 256 deletions
diff --git a/www/pear-HTML_AJAX/Makefile b/www/pear-HTML_AJAX/Makefile
index ca524a2b8142..79240e00566d 100644
--- a/www/pear-HTML_AJAX/Makefile
+++ b/www/pear-HTML_AJAX/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= www devel pear
MAINTAINER= numisemis@yahoo.com
COMMENT= PHP and JavaScript AJAX library
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTML_TagCloud/Makefile b/www/pear-HTML_TagCloud/Makefile
index 73886ff1abba..a2b259855f3a 100644
--- a/www/pear-HTML_TagCloud/Makefile
+++ b/www/pear-HTML_TagCloud/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= www devel pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Generate TagCloud in HTML And Visualize Tags
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP/Makefile b/www/pear-HTTP/Makefile
index c4cfa7a6be07..bc0a60cd10c4 100644
--- a/www/pear-HTTP/Makefile
+++ b/www/pear-HTTP/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= www devel pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR miscellaneous HTTP utilities
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_Client/Makefile b/www/pear-HTTP_Client/Makefile
index 60dc80e45ac5..cc7524784eae 100644
--- a/www/pear-HTTP_Client/Makefile
+++ b/www/pear-HTTP_Client/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP \
RUN_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_Download/Makefile b/www/pear-HTTP_Download/Makefile
index 61ecd37c56f4..283fad3ac919 100644
--- a/www/pear-HTTP_Download/Makefile
+++ b/www/pear-HTTP_Download/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR class to send HTTP downloads
BUILD_DEPENDS= ${PEARDIR}/HTTP/Header.php:${PORTSDIR}/www/pear-HTTP_Header
RUN_DEPENDS= ${PEARDIR}/HTTP/Header.php:${PORTSDIR}/www/pear-HTTP_Header
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_FloodControl/Makefile b/www/pear-HTTP_FloodControl/Makefile
index 135afb351c53..58ed206e829b 100644
--- a/www/pear-HTTP_FloodControl/Makefile
+++ b/www/pear-HTTP_FloodControl/Makefile
@@ -18,26 +18,15 @@ PEAR_DB_DESC= PEAR::DB support
PEAR_MDB_DESC= PEAR::MDB support
PEAR_MDB2_DESC= PEAR::MDB2 support
-PEAR_AUTOINSTALL= yes
+USES= pear
+
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
post-extract:
${MKDIR} ${WRKSRC}/docs
${MV} ${WRKSRC}/README ${WRKSRC}/LICENSE ${WRKSRC}/docs
${MV} ${WRKDIR}/package2.xml ${WRKDIR}/package.xml
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPEAR_DB}
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB}
-RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/www/pear-HTTP_Header/Makefile b/www/pear-HTTP_Header/Makefile
index 650c08cf8f0a..1c7451b84e8f 100644
--- a/www/pear-HTTP_Header/Makefile
+++ b/www/pear-HTTP_Header/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR OO interface to modify and handle HTTP headers and status codes
BUILD_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP
RUN_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_Request/Makefile b/www/pear-HTTP_Request/Makefile
index c236afb3c49d..dae6dafb7993 100644
--- a/www/pear-HTTP_Request/Makefile
+++ b/www/pear-HTTP_Request/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/Net/URL.php:${PORTSDIR}/net/pear-Net_URL \
RUN_DEPENDS= ${PEARDIR}/Net/URL.php:${PORTSDIR}/net/pear-Net_URL \
${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_Request2/Makefile b/www/pear-HTTP_Request2/Makefile
index b4b1536ef896..248cf5eb44d9 100644
--- a/www/pear-HTTP_Request2/Makefile
+++ b/www/pear-HTTP_Request2/Makefile
@@ -17,21 +17,10 @@ CURL_DESC= PHP CURL extension support
FILEINF_DESC= PHP FILEINFO extension support
ZLI_DESC= PECL ZLIB support
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.options.mk>
+CURL_USE= PHP=curl
+FILEINFO_USE= PHP=fileinfo
+ZLIB_USE= PHP=zlib
-.if ${PORT_OPTIONS:MCURL}
-USE_PHP+= curl
-.endif
-
-.if ${PORT_OPTIONS:MFILEINFO}
-USE_PHP+= fileinfo
-.endif
-
-.if ${PORT_OPTIONS:MZLIB}
-USE_PHP+= zlib
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/www/pear-HTTP_Server/Makefile b/www/pear-HTTP_Server/Makefile
index fb3ff03075bc..2c20b33152ca 100644
--- a/www/pear-HTTP_Server/Makefile
+++ b/www/pear-HTTP_Server/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP \
RUN_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP \
${PEARDIR}/Net/Server.php:${PORTSDIR}/net/pear-Net_Server
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_Session2/Makefile b/www/pear-HTTP_Session2/Makefile
index 59dc53953847..3d687bff7cc2 100644
--- a/www/pear-HTTP_Session2/Makefile
+++ b/www/pear-HTTP_Session2/Makefile
@@ -10,12 +10,6 @@ COMMENT= PHP5 Session Handler
LICENSE= BSD
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= dos2unix pear
-USES= dos2unix
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_Upload/Makefile b/www/pear-HTTP_Upload/Makefile
index 3f5b640c39c1..5fdb0e62ffc3 100644
--- a/www/pear-HTTP_Upload/Makefile
+++ b/www/pear-HTTP_Upload/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= www devel pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Easy and secure management of files submitted via HTML Forms
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_WebDAV_Client/Makefile b/www/pear-HTTP_WebDAV_Client/Makefile
index 5ac3bacf83e9..13213535e695 100644
--- a/www/pear-HTTP_WebDAV_Client/Makefile
+++ b/www/pear-HTTP_WebDAV_Client/Makefile
@@ -11,8 +11,7 @@ COMMENT= WebDAV Stream Wrapper Class
BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
RUN_DEPENDS:= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+USES= pear
PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-HTTP_WebDAV_Server/Makefile b/www/pear-HTTP_WebDAV_Server/Makefile
index f1ef5336b2fb..59dbde6225a7 100644
--- a/www/pear-HTTP_WebDAV_Server/Makefile
+++ b/www/pear-HTTP_WebDAV_Server/Makefile
@@ -9,8 +9,6 @@ DISTNAME= ${PORTNAME}-1.0.0RC4
MAINTAINER= miwi@FreeBSD.org
COMMENT= WebDAV Server Baseclass
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Amazon/Makefile b/www/pear-Services_Amazon/Makefile
index a9a5d2cda73c..4112736f24b5 100644
--- a/www/pear-Services_Amazon/Makefile
+++ b/www/pear-Services_Amazon/Makefile
@@ -8,15 +8,11 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to Amazon Product Advertising API
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Amazon_S3/Makefile b/www/pear-Services_Amazon_S3/Makefile
index 2a9e7954367a..0989c8218fc7 100644
--- a/www/pear-Services_Amazon_S3/Makefile
+++ b/www/pear-Services_Amazon_S3/Makefile
@@ -8,16 +8,12 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP API for Amazon S3 (Simple Storage Service)
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2 \
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2 \
${PEARDIR}/Crypt/HMAC2.php:${PORTSDIR}/security/pear-Crypt_HMAC2
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2 \
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2 \
${PEARDIR}/Crypt/HMAC2.php:${PORTSDIR}/security/pear-Crypt_HMAC2
USE_PHP= spl
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Blogging/Makefile b/www/pear-Services_Blogging/Makefile
index fd8aefbf5704..afef1e149c9f 100644
--- a/www/pear-Services_Blogging/Makefile
+++ b/www/pear-Services_Blogging/Makefile
@@ -8,13 +8,9 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to Blog
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/XML/RPC.php:${PORTSDIR}/net/pear-XML_RPC
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/XML/RPC.php:${PORTSDIR}/net/pear-XML_RPC
+BUILD_DEPENDS= ${PEARDIR}/XML/RPC.php:${PORTSDIR}/net/pear-XML_RPC
+RUN_DEPENDS= ${PEARDIR}/XML/RPC.php:${PORTSDIR}/net/pear-XML_RPC
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Compete/Makefile b/www/pear-Services_Compete/Makefile
index 218e74d87569..6dd78fbc8270 100644
--- a/www/pear-Services_Compete/Makefile
+++ b/www/pear-Services_Compete/Makefile
@@ -11,8 +11,6 @@ COMMENT= PHP interface to Compete SnapShop API
BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Delicious/Makefile b/www/pear-Services_Delicious/Makefile
index bf11f64e7014..92b8bb4514a1 100644
--- a/www/pear-Services_Delicious/Makefile
+++ b/www/pear-Services_Delicious/Makefile
@@ -8,17 +8,12 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR Client for the del.icio.us web service
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
+BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
+RUN_DEPENDS= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-USES= dos2unix
+USES= dos2unix pear
USE_PHP= openssl
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Digg/Makefile b/www/pear-Services_Digg/Makefile
index 3163e67fb169..83229446a779 100644
--- a/www/pear-Services_Digg/Makefile
+++ b/www/pear-Services_Digg/Makefile
@@ -9,12 +9,7 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to Digg's API
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
+USES= pear
USE_PHP= curl
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Facebook/Makefile b/www/pear-Services_Facebook/Makefile
index 53a6205d8f84..542f0bd9a203 100644
--- a/www/pear-Services_Facebook/Makefile
+++ b/www/pear-Services_Facebook/Makefile
@@ -11,9 +11,7 @@ COMMENT= PHP interface to Facebook's API
BUILD_DEPENDS= ${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
RUN_DEPENDS= ${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
+USES= pear
USE_PHP= curl
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_GeoNames/Makefile b/www/pear-Services_GeoNames/Makefile
index 75ac58d019c3..a7523d48bbcb 100644
--- a/www/pear-Services_GeoNames/Makefile
+++ b/www/pear-Services_GeoNames/Makefile
@@ -8,13 +8,9 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP5 Interface to the GeoNames Public API
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Google/Makefile b/www/pear-Services_Google/Makefile
index 0ddc4b40c596..590d6b12e3ea 100644
--- a/www/pear-Services_Google/Makefile
+++ b/www/pear-Services_Google/Makefile
@@ -8,9 +8,7 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to access the Google SOAP Web APIs
+USES= pear
USE_PHP= soap
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_OpenSearch/Makefile b/www/pear-Services_OpenSearch/Makefile
index 389c37bf239e..3ba8a4beafd1 100644
--- a/www/pear-Services_OpenSearch/Makefile
+++ b/www/pear-Services_OpenSearch/Makefile
@@ -10,10 +10,7 @@ COMMENT= Search A9 OpenSearch compatible engines
BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
${PEARDIR}/XML/RSS.php:${PORTSDIR}/devel/pear-XML_RSS
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_SharedBook/Makefile b/www/pear-Services_SharedBook/Makefile
index 675da8c99bbc..ab2b1428c79f 100644
--- a/www/pear-Services_SharedBook/Makefile
+++ b/www/pear-Services_SharedBook/Makefile
@@ -11,8 +11,6 @@ COMMENT= PHP wrapper for SharedBook Open API
BUILD_DEPENDS= ${PEARDIR}/HTTP/Client.php:${PORTSDIR}/www/pear-HTTP_Client
RUN_DEPENDS= ${PEARDIR}/HTTP/Client.php:${PORTSDIR}/www/pear-HTTP_Client
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_ShortURL/Makefile b/www/pear-Services_ShortURL/Makefile
index 389f8ad929c7..1351850d9bcd 100644
--- a/www/pear-Services_ShortURL/Makefile
+++ b/www/pear-Services_ShortURL/Makefile
@@ -8,13 +8,9 @@ CATEGORIES= www pear
MAINTAINER= wen@FreeBSD.org
COMMENT= Abstract PHP5 interface for shortening and expanding short URLs
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+USES= pear
USE_PHP= simplexml pcre spl
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_TinyURL/Makefile b/www/pear-Services_TinyURL/Makefile
index c0ae8822220d..788876a75b76 100644
--- a/www/pear-Services_TinyURL/Makefile
+++ b/www/pear-Services_TinyURL/Makefile
@@ -8,12 +8,7 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to TinyURL's API
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
+USES= pear
USE_PHP= curl
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_TwitPic/Makefile b/www/pear-Services_TwitPic/Makefile
index 1a73d5b5a3f7..eea519f312ce 100644
--- a/www/pear-Services_TwitPic/Makefile
+++ b/www/pear-Services_TwitPic/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP Interface to TwitPic's API
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_W3C_CSSValidator/Makefile b/www/pear-Services_W3C_CSSValidator/Makefile
index 0459a097b29d..1022051f820b 100644
--- a/www/pear-Services_W3C_CSSValidator/Makefile
+++ b/www/pear-Services_W3C_CSSValidator/Makefile
@@ -11,8 +11,6 @@ COMMENT= PHP interface to W3C CSS Validator API
BUILD_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-PEAR_AUTOINSTALL= YES
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_W3C_HTMLValidator/Makefile b/www/pear-Services_W3C_HTMLValidator/Makefile
index c08976c21eaa..250785261262 100644
--- a/www/pear-Services_W3C_HTMLValidator/Makefile
+++ b/www/pear-Services_W3C_HTMLValidator/Makefile
@@ -9,13 +9,7 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Object Oriented Interface to the W3C HTML Validator service
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Yadis/Makefile b/www/pear-Services_Yadis/Makefile
index 99d7765664d6..b4aab06e2d45 100644
--- a/www/pear-Services_Yadis/Makefile
+++ b/www/pear-Services_Yadis/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Implementation of the Yadis Specification 1.0 protocol for PHP5
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_Yahoo/Makefile b/www/pear-Services_Yahoo/Makefile
index d47821bc0985..cffa26e1987b 100644
--- a/www/pear-Services_Yahoo/Makefile
+++ b/www/pear-Services_Yahoo/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Provides access to the Yahoo! Web Services
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Services_urlTea/Makefile b/www/pear-Services_urlTea/Makefile
index 9788f3a30342..2b6604c52fed 100644
--- a/www/pear-Services_urlTea/Makefile
+++ b/www/pear-Services_urlTea/Makefile
@@ -8,12 +8,7 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to urlTea's API
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
+USES= pear
USE_PHP= curl
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Structures_DataGrid_Renderer_Flexy/Makefile b/www/pear-Structures_DataGrid_Renderer_Flexy/Makefile
index 8da0d329e342..3d5d65b5eb93 100644
--- a/www/pear-Structures_DataGrid_Renderer_Flexy/Makefile
+++ b/www/pear-Structures_DataGrid_Renderer_Flexy/Makefile
@@ -8,13 +8,10 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Renderer for pear-Structures_DataGrid using HTML_Template_Flexy
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
${PEARDIR}/HTML/Template/Flexy.php:${PORTSDIR}/devel/pear-HTML_Template_Flexy \
${PEARDIR}/Structures/DataGrid/Renderer/Pager.php:${PORTSDIR}/www/pear-Structures_DataGrid_Renderer_Pager
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Structures_DataGrid_Renderer_Pager/Makefile b/www/pear-Structures_DataGrid_Renderer_Pager/Makefile
index b712b2afb6d7..956ef423f3e7 100644
--- a/www/pear-Structures_DataGrid_Renderer_Pager/Makefile
+++ b/www/pear-Structures_DataGrid_Renderer_Pager/Makefile
@@ -8,12 +8,9 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Pager Renderer for pear-Structures_DataGrid
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
${PEARDIR}/Pager/Pager.php:${PORTSDIR}/devel/pear-Pager
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Structures_DataGrid_Renderer_Smarty/Makefile b/www/pear-Structures_DataGrid_Renderer_Smarty/Makefile
index e79c68a70297..2b37af7c8157 100644
--- a/www/pear-Structures_DataGrid_Renderer_Smarty/Makefile
+++ b/www/pear-Structures_DataGrid_Renderer_Smarty/Makefile
@@ -8,13 +8,10 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Smarty Renderer for pear-Structures_DataGrid
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
${LOCALBASE}/share/smarty/Smarty.class.php:${PORTSDIR}/www/smarty2 \
${PEARDIR}/Structures/DataGrid/Renderer/Pager.php:${PORTSDIR}/www/pear-Structures_DataGrid_Renderer_Pager
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-Text_Wiki/Makefile b/www/pear-Text_Wiki/Makefile
index f2ab405cd6a8..400b4d1d8c9e 100644
--- a/www/pear-Text_Wiki/Makefile
+++ b/www/pear-Text_Wiki/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Abstracts parsing and rendering rules for Wiki markup
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-UDDI/Makefile b/www/pear-UDDI/Makefile
index 89338464ab92..4844f4efb856 100644
--- a/www/pear-UDDI/Makefile
+++ b/www/pear-UDDI/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
${PEARDIR}/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-XML_GRDDL/Makefile b/www/pear-XML_GRDDL/Makefile
index a931e844801a..f9ebd30399a6 100644
--- a/www/pear-XML_GRDDL/Makefile
+++ b/www/pear-XML_GRDDL/Makefile
@@ -8,20 +8,16 @@ CATEGORIES= www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP library for dealing with GRDDL
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
${PEARDIR}/Net/URL.php:${PORTSDIR}/net/pear-Net_URL \
${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
${PEARDIR}/Net/URL.php:${PORTSDIR}/net/pear-Net_URL \
${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
+USES= pear
USE_PHP+= xsl tidy
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/pear-twig/Makefile b/www/pear-twig/Makefile
index 5a1bc4121eab..3b084c8fab8b 100644
--- a/www/pear-twig/Makefile
+++ b/www/pear-twig/Makefile
@@ -15,12 +15,10 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PEARDIR}/.channels/pear.twig-project.org.reg:${PORTSDIR}/devel/pear-channel-twig
RUN_DEPENDS= ${PEARDIR}/.channels/pear.twig-project.org.reg:${PORTSDIR}/devel/pear-channel-twig
+USES= pear
PEAR_CHANNEL= twig
-PEAR_AUTOINSTALL= yes
USE_PHP= ctype hash
WANT_PHP_CLI= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>