aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/akpop3d/Makefile4
-rw-r--r--net-p2p/gnunet/Makefile4
-rw-r--r--net/gnunet/Makefile4
-rw-r--r--security/tinc/Makefile4
4 files changed, 8 insertions, 8 deletions
diff --git a/mail/akpop3d/Makefile b/mail/akpop3d/Makefile
index c199189942ea..5ae90d72a322 100644
--- a/mail/akpop3d/Makefile
+++ b/mail/akpop3d/Makefile
@@ -23,8 +23,8 @@ GNU_CONFIGURE= yes
.if defined(WITH_SSL)
USE_OPENSSL= YES
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-CONFIGURE_ENV= CPPFLAGS="-I${OPENSSLBASE}/include" \
- LDFLAGS="-L${OPENSSLBASE}/lib -lssl -lcrypto"
+CONFIGURE_ENV= CPPFLAGS="-I${OPENSSLBASE}/include"
+LDFLAGS+= -L${OPENSSLBASE}/lib -lssl -lcrypto
.endif
do-install:
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index 0261543359c3..4a23075ba739 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -30,8 +30,8 @@ USE_GNOME= gtk12
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index 0261543359c3..4a23075ba739 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -30,8 +30,8 @@ USE_GNOME= gtk12
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
diff --git a/security/tinc/Makefile b/security/tinc/Makefile
index b47879876f6c..d96189e9b486 100644
--- a/security/tinc/Makefile
+++ b/security/tinc/Makefile
@@ -23,8 +23,8 @@ USE_OPENSSL= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+LDFLAGS+= -L${LOCALBASE}/lib"
MAN5= tinc.conf.5
MAN8= tincd.8