aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/musepack/Makefile1
-rw-r--r--mail/imaputils/Makefile1
-rw-r--r--math/wfmath/Makefile3
-rw-r--r--multimedia/assimp/Makefile1
-rw-r--r--multimedia/libbluray/Makefile1
-rw-r--r--print/tex-ptexenc/Makefile1
-rw-r--r--science/elmer-eio/Makefile1
-rw-r--r--science/liboglappth/Makefile1
-rw-r--r--x11-toolkits/libxaw3dxft/Makefile1
9 files changed, 1 insertions, 10 deletions
diff --git a/audio/musepack/Makefile b/audio/musepack/Makefile
index 6155c9749038..abccb7ad4dd0 100644
--- a/audio/musepack/Makefile
+++ b/audio/musepack/Makefile
@@ -12,7 +12,6 @@ MAINTAINER= shoesoft@gmx.net
COMMENT= Decoder, encoder, and replaygain for musepack (mpc)
USE_LDCONFIG= yes
-NO_STAGE= yes
USE_AUTOTOOLS= aclocal autoheader libtoolize automake autoconf libtool
ACLOCAL_ARGS= -I. -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
diff --git a/mail/imaputils/Makefile b/mail/imaputils/Makefile
index ae83062a94f7..6a78f25910ce 100644
--- a/mail/imaputils/Makefile
+++ b/mail/imaputils/Makefile
@@ -19,7 +19,6 @@ SHEBANG_FILES= bin/*
OPTIONS_DEFINE= SSL UNICODE
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
diff --git a/math/wfmath/Makefile b/math/wfmath/Makefile
index 8ae9e2ed3a66..f6a1417ac094 100644
--- a/math/wfmath/Makefile
+++ b/math/wfmath/Makefile
@@ -10,11 +10,10 @@ MASTER_SITES= SF/worldforge/${PORTNAME}%20%28math%20lib%29/${PORTVERSION}
MAINTAINER= oliver@FreeBSD.org
COMMENT= Worldforge math library
-USE_GMAKE= yes
+USES= gmake
USES= pathfix pkgconfig
USE_LDCONFIG= yes
USE_GCC= yes
GNU_CONFIGURE= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/multimedia/assimp/Makefile b/multimedia/assimp/Makefile
index 7e756c87a951..88c939e3670e 100644
--- a/multimedia/assimp/Makefile
+++ b/multimedia/assimp/Makefile
@@ -24,7 +24,6 @@ USE_LDCONFIG= yes
# CMAKE_ARGS instructs cmake to skip runtime path removal during install
CMAKE_ARGS+= "-DCMAKE_SKIP_RPATH=ON"
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} 's|$${LIB_INSTALL_DIR}/pkgconfig|libdata/pkgconfig|' \
${WRKSRC}/CMakeLists.txt
diff --git a/multimedia/libbluray/Makefile b/multimedia/libbluray/Makefile
index 9e87edb72343..807e1c4aaad0 100644
--- a/multimedia/libbluray/Makefile
+++ b/multimedia/libbluray/Makefile
@@ -30,7 +30,6 @@ CONFIGURE_ARGS= --prefix="${PREFIX}" \
OPTIONS_DEFINE= JAVA
JAVA_DESC= Enable Blu-Ray Java support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJAVA}
diff --git a/print/tex-ptexenc/Makefile b/print/tex-ptexenc/Makefile
index 3d5bc2360023..203db8dd81ba 100644
--- a/print/tex-ptexenc/Makefile
+++ b/print/tex-ptexenc/Makefile
@@ -25,5 +25,4 @@ CONFIGURE_ARGS= --with-system-kpathsea \
--with-kpathsea-includes=${LOCALBASE}/include \
--with-kpathsea-libdir=${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/science/elmer-eio/Makefile b/science/elmer-eio/Makefile
index 4be37df852d0..75eb8b9a99a3 100644
--- a/science/elmer-eio/Makefile
+++ b/science/elmer-eio/Makefile
@@ -18,7 +18,6 @@ ALL_TARGET=
PLIST_FILES= include/eio_api.h lib/libeioc.a lib/libeiof.a
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
diff --git a/science/liboglappth/Makefile b/science/liboglappth/Makefile
index 6a708fb6f7f8..fac79e751833 100644
--- a/science/liboglappth/Makefile
+++ b/science/liboglappth/Makefile
@@ -20,5 +20,4 @@ LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11-toolkits/libxaw3dxft/Makefile b/x11-toolkits/libxaw3dxft/Makefile
index 3d20635e0eb0..46461168d5c5 100644
--- a/x11-toolkits/libxaw3dxft/Makefile
+++ b/x11-toolkits/libxaw3dxft/Makefile
@@ -23,7 +23,6 @@ CPPFLAGS+= -I${LOCALBASE}/include/freetype2
DOCSDIR= ${LOCALBASE}/share/doc/libXaw3dXft
PORTDOCS= *
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} '/^pkgconfigdir/s:=.*:= ${PREFIX}/libdata/pkgconfig:'\
${WRKSRC}/Makefile.in