aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/py-rrdpipe/Makefile26
-rw-r--r--databases/py-rrdpipe/distinfo1
-rw-r--r--databases/py-rrdpipe/pkg-comment1
-rw-r--r--databases/py-rrdpipe/pkg-descr3
-rw-r--r--databases/py-rrdpipe/pkg-plist1
-rw-r--r--net/Makefile1
-rw-r--r--net/py-rrdpipe/Makefile26
-rw-r--r--net/py-rrdpipe/distinfo1
-rw-r--r--net/py-rrdpipe/pkg-comment1
-rw-r--r--net/py-rrdpipe/pkg-descr3
-rw-r--r--net/py-rrdpipe/pkg-plist1
11 files changed, 65 insertions, 0 deletions
diff --git a/databases/py-rrdpipe/Makefile b/databases/py-rrdpipe/Makefile
new file mode 100644
index 000000000000..6fe4e8885060
--- /dev/null
+++ b/databases/py-rrdpipe/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: py-rrdpipe
+# Date created: May 31, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rrdpipe
+PORTVERSION= 0.1
+CATEGORIES= net python
+MASTER_SITES= http://download.extreme-ware.com/open-projects/PyRRDpipe/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyRRDpipe-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= rrd:${PORTSDIR}/net/rrdtool
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/RRDpipe.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/databases/py-rrdpipe/distinfo b/databases/py-rrdpipe/distinfo
new file mode 100644
index 000000000000..af595e694901
--- /dev/null
+++ b/databases/py-rrdpipe/distinfo
@@ -0,0 +1 @@
+MD5 (PyRRDpipe-0.1.tar.gz) = 4ad257c8bfdab3ba62e4a957e3d3124d
diff --git a/databases/py-rrdpipe/pkg-comment b/databases/py-rrdpipe/pkg-comment
new file mode 100644
index 000000000000..d38a1092076b
--- /dev/null
+++ b/databases/py-rrdpipe/pkg-comment
@@ -0,0 +1 @@
+Portable Python module to access RRDTool files via pipes
diff --git a/databases/py-rrdpipe/pkg-descr b/databases/py-rrdpipe/pkg-descr
new file mode 100644
index 000000000000..f80c1bac17a3
--- /dev/null
+++ b/databases/py-rrdpipe/pkg-descr
@@ -0,0 +1,3 @@
+Portable Python module to access RRDTool files via pipes
+
+WWW: http://download.extreme-ware.com/
diff --git a/databases/py-rrdpipe/pkg-plist b/databases/py-rrdpipe/pkg-plist
new file mode 100644
index 000000000000..7bfe68f2d0af
--- /dev/null
+++ b/databases/py-rrdpipe/pkg-plist
@@ -0,0 +1 @@
+lib/%%PYTHON_VERSION%%/site-packages/RRDpipe.py
diff --git a/net/Makefile b/net/Makefile
index 0dff77f8c4db..7df993ed7212 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -405,6 +405,7 @@
SUBDIR += py-libnet
SUBDIR += py-medusa
SUBDIR += py-pcap
+ SUBDIR += py-rrdpipe
SUBDIR += py-rrdtool
SUBDIR += py-smb
SUBDIR += py-snmp
diff --git a/net/py-rrdpipe/Makefile b/net/py-rrdpipe/Makefile
new file mode 100644
index 000000000000..6fe4e8885060
--- /dev/null
+++ b/net/py-rrdpipe/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: py-rrdpipe
+# Date created: May 31, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rrdpipe
+PORTVERSION= 0.1
+CATEGORIES= net python
+MASTER_SITES= http://download.extreme-ware.com/open-projects/PyRRDpipe/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyRRDpipe-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= rrd:${PORTSDIR}/net/rrdtool
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/RRDpipe.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/net/py-rrdpipe/distinfo b/net/py-rrdpipe/distinfo
new file mode 100644
index 000000000000..af595e694901
--- /dev/null
+++ b/net/py-rrdpipe/distinfo
@@ -0,0 +1 @@
+MD5 (PyRRDpipe-0.1.tar.gz) = 4ad257c8bfdab3ba62e4a957e3d3124d
diff --git a/net/py-rrdpipe/pkg-comment b/net/py-rrdpipe/pkg-comment
new file mode 100644
index 000000000000..d38a1092076b
--- /dev/null
+++ b/net/py-rrdpipe/pkg-comment
@@ -0,0 +1 @@
+Portable Python module to access RRDTool files via pipes
diff --git a/net/py-rrdpipe/pkg-descr b/net/py-rrdpipe/pkg-descr
new file mode 100644
index 000000000000..f80c1bac17a3
--- /dev/null
+++ b/net/py-rrdpipe/pkg-descr
@@ -0,0 +1,3 @@
+Portable Python module to access RRDTool files via pipes
+
+WWW: http://download.extreme-ware.com/
diff --git a/net/py-rrdpipe/pkg-plist b/net/py-rrdpipe/pkg-plist
new file mode 100644
index 000000000000..7bfe68f2d0af
--- /dev/null
+++ b/net/py-rrdpipe/pkg-plist
@@ -0,0 +1 @@
+lib/%%PYTHON_VERSION%%/site-packages/RRDpipe.py