aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/avalon-framework/Makefile49
-rw-r--r--devel/avalon-framework/distinfo2
-rw-r--r--devel/avalon-framework/pkg-descr20
4 files changed, 72 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 820f5aa74d61..33c0660935e0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -67,6 +67,7 @@
SUBDIR += automake14
SUBDIR += automake17
SUBDIR += automake18
+ SUBDIR += avalon-framework
SUBDIR += avarice
SUBDIR += avltree
SUBDIR += avr-binutils
diff --git a/devel/avalon-framework/Makefile b/devel/avalon-framework/Makefile
new file mode 100644
index 000000000000..8c07740d98cb
--- /dev/null
+++ b/devel/avalon-framework/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: avalon-framework
+# Date created: 2004-03-31
+# Whom: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= avalon-framework
+PORTVERSION= 4.1.5
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= avalon/avalon-framework/binaries/
+
+MAINTAINER= herve.quiroz@esil.univ-mrs.fr
+COMMENT= Apache Avalon core framework for component programming
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= api basics.html changelog-report.html cop cvs-usage.html \
+ dependencies.html developer-activity-report.html \
+ file-activity-report.html images index.html \
+ issue-tracking.html license.html mail-lists.html \
+ maven-reports.html principals project-info.html style \
+ team-list.html
+.endif
+JARFILE= ${DISTNAME}.jar
+DESTJARFILE= ${PORTNAME}.jar
+PLIST_FILES+= ${JAVAJARDIR:S,^${PREFIX}/,,}/${DESTJARFILE}
+
+do-install:
+ @${ECHO_CMD} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
+ @${CP} ${WRKSRC}/${JARFILE} ${JAVAJARDIR}/${DESTJARFILE}
+ @${ECHO_CMD} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+.for DOCFILE in ${PORTDOCS}
+ @${CP} -r ${WRKSRC}/docs/${DOCFILE} ${DOCSDIR}/
+ @${ECHO_CMD} -n " ${DOCFILE}"
+.endfor
+ @${ECHO_CMD} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/avalon-framework/distinfo b/devel/avalon-framework/distinfo
new file mode 100644
index 000000000000..5a6bd7c3b9ba
--- /dev/null
+++ b/devel/avalon-framework/distinfo
@@ -0,0 +1,2 @@
+MD5 (avalon-framework-4.1.5.tar.gz) = 2111d1c9dcce5beecef04d8bb66b8b65
+SIZE (avalon-framework-4.1.5.tar.gz) = 394814
diff --git a/devel/avalon-framework/pkg-descr b/devel/avalon-framework/pkg-descr
new file mode 100644
index 000000000000..8ecd4fe68e01
--- /dev/null
+++ b/devel/avalon-framework/pkg-descr
@@ -0,0 +1,20 @@
+Apache Avalon provides a complete platform for component programming including
+a core framework, utilities, tools, components and containers. By using key
+design patterns such as Inversion of Control (IoC) and Seperation of Concerns
+(SoC), Avalon achieves a number of advantages over traditional object oriented
+programming frameworks:
+
+ * No implementation lock
+ * Low coupling between components
+ * Component lifecycle management
+ * Configuration management and easy to use API
+ * Component meta-data framework and tools
+ * Service dependecy management
+ * Embeddable containers for standalone, J2EE and web environments
+
+The Avalon Framework API and Implementation consists of interfaces that define
+relationships between commonly used application components, best-of-practice
+pattern enforcements, and several lightweight convenience implementations of
+the generic components.
+
+WWW: http://avalon.apache.org/framework/