aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-BaseCalc/Makefile22
-rw-r--r--math/p5-Math-BaseCalc/distinfo1
-rw-r--r--math/p5-Math-BaseCalc/pkg-comment1
-rw-r--r--math/p5-Math-BaseCalc/pkg-descr7
-rw-r--r--math/p5-Math-BaseCalc/pkg-plist5
6 files changed, 37 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 08527940cfbc..c3d6f680346c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -79,6 +79,7 @@
SUBDIR += p5-Date-Handler
SUBDIR += p5-Graph
SUBDIR += p5-Math-Base85
+ SUBDIR += p5-Math-BaseCalc
SUBDIR += p5-Math-Bezier
SUBDIR += p5-Math-BigInt
SUBDIR += p5-Math-BigIntFast
diff --git a/math/p5-Math-BaseCalc/Makefile b/math/p5-Math-BaseCalc/Makefile
new file mode 100644
index 000000000000..1c5de9f0749c
--- /dev/null
+++ b/math/p5-Math-BaseCalc/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Math::BaseCalc
+# Date created: 25 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-BaseCalc
+PORTVERSION= 1.011
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::BaseCalc.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-BaseCalc/distinfo b/math/p5-Math-BaseCalc/distinfo
new file mode 100644
index 000000000000..e25b659173b0
--- /dev/null
+++ b/math/p5-Math-BaseCalc/distinfo
@@ -0,0 +1 @@
+MD5 (Math-BaseCalc-1.011.tar.gz) = 0e539a438ff8717f22ab83f9dd113686
diff --git a/math/p5-Math-BaseCalc/pkg-comment b/math/p5-Math-BaseCalc/pkg-comment
new file mode 100644
index 000000000000..9750a30721a4
--- /dev/null
+++ b/math/p5-Math-BaseCalc/pkg-comment
@@ -0,0 +1 @@
+Convert numbers between various bases
diff --git a/math/p5-Math-BaseCalc/pkg-descr b/math/p5-Math-BaseCalc/pkg-descr
new file mode 100644
index 000000000000..cf84bc79d4f2
--- /dev/null
+++ b/math/p5-Math-BaseCalc/pkg-descr
@@ -0,0 +1,7 @@
+This module facilitates the conversion of numbers between various number
+bases. You may define your own digit sets, or use any of several
+predefined digit sets.
+
+WWW: http://search.cpan.org/search?dist=Math-BaseCalc
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/math/p5-Math-BaseCalc/pkg-plist b/math/p5-Math-BaseCalc/pkg-plist
new file mode 100644
index 000000000000..4e834213f436
--- /dev/null
+++ b/math/p5-Math-BaseCalc/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/BaseCalc/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Math/BaseCalc.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Math 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/BaseCalc 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true