aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/gqrx/Makefile2
-rw-r--r--devel/simgear/Makefile3
-rw-r--r--emulators/dolphin-emu/Makefile4
-rw-r--r--emulators/pcsxr/Makefile4
-rw-r--r--games/blobby/Makefile3
-rw-r--r--games/briquolo/Makefile2
-rw-r--r--games/flightgear/Makefile4
-rw-r--r--games/jfsw/Makefile2
-rw-r--r--games/openalchemist/Makefile3
-rw-r--r--games/trackballs/Makefile2
-rw-r--r--graphics/pencil/Makefile2
11 files changed, 17 insertions, 14 deletions
diff --git a/comms/gqrx/Makefile b/comms/gqrx/Makefile
index 42114fa81362..043d6e62fe6c 100644
--- a/comms/gqrx/Makefile
+++ b/comms/gqrx/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= libgnuradio-runtime.so:comms/gnuradio \
libboost_program_options.so:devel/boost-libs \
liblog4cpp.so:devel/log4cpp
-USES= pkgconfig qmake qt:5
+USES= gl pkgconfig qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= csete
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 27acbe363965..cc188e8392d8 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libosg.so:graphics/osg
-USES= alias cmake compiler:c++11-lib cpe jpeg openal:al,alut tar:bzip2
+USES= alias cmake compiler:c++11-lib cpe gl jpeg openal:al,alut \
+ tar:bzip2
USE_XORG= ice sm x11 xext xi xmu xt
USE_GL= gl glu glut
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index a6021eab16df..a37e7daa02dc 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -42,8 +42,8 @@ LIB_DEPENDS= libpulse.so:audio/pulseaudio \
libcurl.so:ftp/curl \
libhidapi.so:comms/hidapi
-USES= cmake compiler:c++17-lang desktop-file-utils iconv pkgconfig \
- qmake qt:5
+USES= cmake compiler:c++17-lang desktop-file-utils gl iconv \
+ pkgconfig qmake qt:5
USE_GITHUB= yes
GH_PROJECT= dolphin
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index adf6f13301fb..6a4740cd0fed 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= libvorbis.so:audio/libvorbis \
WRKSRC_SUBDIR= ${PORTNAME}
-USES= cmake desktop-file-utils dos2unix gettext gnome iconv libarchive \
- libtool pkgconfig tar:bzip2
+USES= cmake desktop-file-utils dos2unix gettext gl gnome iconv \
+ libarchive libtool pkgconfig tar:bzip2
USE_GITHUB= yes
GH_ACCOUNT= martymac
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index ceec14a5b164..ac1f12f7e7ac 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -22,7 +22,8 @@ LIB_DEPENDS= libphysfs.so:devel/physfs
BUILD_DEPENDS= zip:archivers/zip \
${LOCALBASE}/include/boost/crc.hpp:devel/boost-libs
-USES= cmake compiler:c++11-lang dos2unix localbase:ldflags pkgconfig
+USES= cmake compiler:c++11-lang dos2unix gl localbase:ldflags \
+ pkgconfig
DOS2UNIX_REGEX= .*\.(c|h|cpp)
CMAKE_ARGS= -DDATADIR:PATH="${DATADIR}"
WRKSRC= ${WRKDIR}/blobby-${PORTVERSION}
diff --git a/games/briquolo/Makefile b/games/briquolo/Makefile
index 56060342ae8a..720b2d6d8979 100644
--- a/games/briquolo/Makefile
+++ b/games/briquolo/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
-USES= tar:bzip2 gmake iconv desktop-file-utils
+USES= tar:bzip2 gl gmake iconv desktop-file-utils
USE_GL= gl
USE_SDL= mixer sdl ttf
USE_XORG= x11
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index f5f7cef5e64f..368903703303 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -28,8 +28,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
${LOCALBASE}/share/flightgear/version:games/flightgear-data
LLD_UNSAFE= yes
-USES= alias cmake compiler cpe dos2unix jpeg openal:al,alut sqlite \
- tar:bzip2
+USES= alias cmake compiler cpe dos2unix gl jpeg openal:al,alut \
+ sqlite tar:bzip2
USE_XORG= ice sm x11 xext xft xi xinerama xmu xt
USE_GL= gl glew glu glut
diff --git a/games/jfsw/Makefile b/games/jfsw/Makefile
index 48048c7c29a5..1a308b685571 100644
--- a/games/jfsw/Makefile
+++ b/games/jfsw/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS_BuildLic= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-acc
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
-USES= alias dos2unix gmake gnome pkgconfig:build
+USES= alias dos2unix gl gmake gnome pkgconfig:build
DOS2UNIX_REGEX= .*(\.(c|h)|Makefile)(\.deps)?
USE_GITHUB= yes
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index 7718848da013..427816bd1a06 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -23,7 +23,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-USES= autoreconf gmake gnome iconv jpeg pkgconfig python:2.7,run shebangfix
+USES= autoreconf gl gmake gnome iconv jpeg pkgconfig python:2.7,run \
+ shebangfix
SHEBANG_FILES= openalchemist-config
USE_GNOME= pygtk2
diff --git a/games/trackballs/Makefile b/games/trackballs/Makefile
index a15a163fa3a4..d13c6e6e7141 100644
--- a/games/trackballs/Makefile
+++ b/games/trackballs/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libguile-2.0.so:lang/guile2 \
libgc.so:devel/boehm-gc
-USES= cmake desktop-file-utils gettext-runtime gnome pkgconfig
+USES= cmake desktop-file-utils gettext-runtime gl gnome pkgconfig
USE_GITHUB= yes
diff --git a/graphics/pencil/Makefile b/graphics/pencil/Makefile
index decd14933b27..b03054eb821d 100644
--- a/graphics/pencil/Makefile
+++ b/graphics/pencil/Makefile
@@ -19,7 +19,7 @@ BROKEN_armv7= fails to compile: no matching function for call to 'qMax'
LIB_DEPENDS= libming.so:graphics/ming \
libpng.so:graphics/png
-USES= qmake qt:4 zip
+USES= gl qmake qt:4 zip
USE_QT= gui opengl xml moc_build rcc_build
USE_GL= gl
QMAKE_ARGS= INCLUDEPATH+=${LOCALBASE}/include/ming