aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-DataCash/Makefile32
-rw-r--r--misc/p5-DataCash/distinfo1
-rw-r--r--misc/p5-DataCash/files/patch-CCCheck::CCCheck.pm11
-rw-r--r--misc/p5-DataCash/files/patch-File::KGlob.pm31
-rw-r--r--misc/p5-DataCash/files/patch-File::KGlob2RE.pm11
-rw-r--r--misc/p5-DataCash/files/patch-Makefile.PL20
-rw-r--r--misc/p5-DataCash/pkg-descr3
-rw-r--r--misc/p5-DataCash/pkg-plist12
9 files changed, 0 insertions, 122 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d4e556662bc6..3d92713caa4e 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -255,7 +255,6 @@
SUBDIR += p5-Business-UPS
SUBDIR += p5-Chatbot-Eliza
SUBDIR += p5-Data-Buffer
- SUBDIR += p5-DataCash
SUBDIR += p5-File-CounterFile
SUBDIR += p5-File-Sort
SUBDIR += p5-Finance-Currency-Convert
diff --git a/misc/p5-DataCash/Makefile b/misc/p5-DataCash/Makefile
deleted file mode 100644
index 315190cd1797..000000000000
--- a/misc/p5-DataCash/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-# New ports collection makefile for: DataCash-External
-# Date created: 10 August 2001
-# Whom: Mark Murray <markm@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= DataCash-External
-PORTVERSION= 2.9.0
-CATEGORIES= misc perl5
-MASTER_SITES= http://www.datacash.com/stronghold/perl/
-PKGNAMEPREFIX= p5-
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Online credit card transactions
-
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/CSV.pm:${PORTSDIR}/textproc/p5-Text-CSV
-
-PERL_CONFIGURE= yes
-
-MAN3= CCCheck.3 \
- DataCash::External.3
-
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-
-post-extract:
- ${FIND} ${WRKSRC} -type f -exec ${PERL} -spi -e 's/\r//g' {} ';'
-
-.include <bsd.port.mk>
diff --git a/misc/p5-DataCash/distinfo b/misc/p5-DataCash/distinfo
deleted file mode 100644
index e77b77cd736b..000000000000
--- a/misc/p5-DataCash/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (DataCash-External-2.9.0.tar.gz) = d78c1a8987c31716bf043b55ccc84855
diff --git a/misc/p5-DataCash/files/patch-CCCheck::CCCheck.pm b/misc/p5-DataCash/files/patch-CCCheck::CCCheck.pm
deleted file mode 100644
index 8b36a756ee32..000000000000
--- a/misc/p5-DataCash/files/patch-CCCheck::CCCheck.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- CCCheck/CCCheck.pm.orig Fri Apr 19 18:59:51 2002
-+++ CCCheck/CCCheck.pm Fri Apr 19 19:02:33 2002
-@@ -834,7 +834,7 @@
- my $iin=substr($card_number, 0, 6);
-
- # If we have an exact match, look up the stuff and return it
-- if ($prefixes->{$iin} ne "") {
-+ if ($prefixes->{$iin} && $prefixes->{$iin} ne "") {
- return $iin;
- } else {
- # We'll look for ranges. First of all, try the wide and narrow
diff --git a/misc/p5-DataCash/files/patch-File::KGlob.pm b/misc/p5-DataCash/files/patch-File::KGlob.pm
deleted file mode 100644
index 471fe3b2176b..000000000000
--- a/misc/p5-DataCash/files/patch-File::KGlob.pm
+++ /dev/null
@@ -1,31 +0,0 @@
---- File/KGlob.pm.orig Wed Apr 17 13:05:33 2002
-+++ File/KGlob.pm Wed Apr 17 13:06:10 2002
-@@ -79,7 +79,7 @@
- if( m#(^|[^\\])(\\\\)*[\[\?\*]# ) { # Some kind of wildcard:
- push( @return, &pglob($_) ); # Find matching files.
- } else { # Just a string, perhaps with \-quoting:
-- s/\\(.)/\1/g; # Remove the \'s used for quoting.
-+ s/\\(.)/$1/g; # Remove the \'s used for quoting.
- push( @return, $_ );
- }
- }
-@@ -106,8 +106,8 @@
- $mid= substr( $temp, 0, $pos ); # Part between "{" and "}" #{
- $aft= substr( $temp, 1 + $pos ); # Part after "}"
- if( $mid =~ m#(^|[^\\])(\\\\)*$# ) { #{ The "}" is unquoted:
-- $mid =~ s/((^|[^\\])(\\\\))*,/\1\0/g; # Most unquoted ","s
-- $mid =~ s/((^|[^\\])(\\\\))*,/\1\0/g; # Remaining ones
-+ $mid =~ s/((^|[^\\])(\\\\))*,/$1$0/g; # Most unquoted ","s
-+ $mid =~ s/((^|[^\\])(\\\\))*,/$1$0/g; # Remaining ones
- return &mcat( $bef, $aft, split(/\0/,$mid) ); # Done!
- } # &mcat builds all of the resulting strings.
- } # &mcat also "unbrac"s $bef and $aft.
-@@ -228,7 +228,7 @@
- $nodots= "." ne substr($glob,0,1); # Skip all .*'s unless explicit
- chop $glob if $onlydirs= "/" eq substr($glob,-1,1);
- # File::KGlob2RE uses "%" for "any subdir(s)" but we don't so...
-- $glob =~ s#((^|[^\\])(\\\\)*)\%#\1\\%#g; # quote any unquoted "%"s.
-+ $glob =~ s#((^|[^\\])(\\\\)*)\%#$1\\%#g; # quote any unquoted "%"s.
- $re= &File::KGlob2RE::kglob2re( $glob ); # Change glob to regexp.
- $dir= "." if "" eq $dir;
- if( ! opendir( $hndl, $dir ) ) {
diff --git a/misc/p5-DataCash/files/patch-File::KGlob2RE.pm b/misc/p5-DataCash/files/patch-File::KGlob2RE.pm
deleted file mode 100644
index 9c7a754c60c0..000000000000
--- a/misc/p5-DataCash/files/patch-File::KGlob2RE.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- File/KGlob2RE.pm.orig Wed Apr 17 13:05:33 2002
-+++ File/KGlob2RE.pm Wed Apr 17 13:06:10 2002
-@@ -110,7 +110,7 @@
- warn "Unexpected end of file glob pattern: $glob\n";
- return undef;
- }
-- if( $re !~ s-$NOQT/\(\|,\.\*/\)$-\1/- ) { # X/%* -> ^X/
-+ if( $re !~ s-$NOQT/\(\|,\.\*/\)$-$1/- ) { # X/%* -> ^X/
- $re .= '$';
- } elsif( "" eq $re ) { # Since m// means something else:
- $re= "^"; # %/* -> anything
diff --git a/misc/p5-DataCash/files/patch-Makefile.PL b/misc/p5-DataCash/files/patch-Makefile.PL
deleted file mode 100644
index d9485a671f22..000000000000
--- a/misc/p5-DataCash/files/patch-Makefile.PL
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.PL.orig Mon Aug 13 15:03:10 2001
-+++ Makefile.PL Mon Aug 13 15:07:05 2001
-@@ -52,12 +52,12 @@
- }
-
- WriteMakefile(
-- 'NAME' => 'DataCash::External',
-+ 'NAME' => 'External',
- 'VERSION_FROM' => 'DataCash/External.pm',
- 'PREREQ_PM' => $deps,
-- 'dist' => {
-- COMPRESS => 'gzip',
-- SUFFIX => 'gz',
-- },
-+ 'PM' => { 'DataCash/External.pm' => '$(INST_LIBDIR)/DataCash/External.pm',
-+ 'datacash.pl' => '$(INST_LIBDIR)/DataCash/datacash.pl',
-+ 'File/KGlob.pm' => '$(INST_LIBDIR)/File/KGlob.pm',
-+ 'File/KGlob2RE.pm' => '$(INST_LIBDIR)/File/KGlob2RE.pm' }
- );
-
diff --git a/misc/p5-DataCash/pkg-descr b/misc/p5-DataCash/pkg-descr
deleted file mode 100644
index dc73d839b572..000000000000
--- a/misc/p5-DataCash/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Online credit card transactions
-
-WWW: http://www.datacash.com/
diff --git a/misc/p5-DataCash/pkg-plist b/misc/p5-DataCash/pkg-plist
deleted file mode 100644
index 473df0c42baa..000000000000
--- a/misc/p5-DataCash/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/External/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/CCCheck.pm
-lib/perl5/site_perl/%%PERL_VER%%/CCCheck/visa.db
-lib/perl5/site_perl/%%PERL_VER%%/CCCheck/mastercard.db
-lib/perl5/site_perl/%%PERL_VER%%/DataCash/External.pm
-lib/perl5/site_perl/%%PERL_VER%%/DataCash/datacash.pl
-lib/perl5/site_perl/%%PERL_VER%%/File/KGlob.pm
-lib/perl5/site_perl/%%PERL_VER%%/File/KGlob2RE.pm
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/External
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/CCCheck
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/DataCash
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/File