aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/cooledit/Makefile6
-rw-r--r--editors/cooledit/pkg-plist3
-rw-r--r--editors/pico-alpine/Makefile3
-rw-r--r--editors/pico-alpine/pkg-plist2
-rw-r--r--games/gnugo/Makefile7
-rw-r--r--math/cln/Makefile2
-rw-r--r--math/cln/pkg-plist1
7 files changed, 10 insertions, 14 deletions
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 5aeaf7f4c7f2..1a4d451affe5 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -13,14 +13,11 @@ COMMENT= Suite of utilities, including a GUI editor
USE_AUTOTOOLS= libtool
USE_PYTHON= yes
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
GNU_CONFIGURE= yes
USE_XORG= x11 xt
USE_LDCONFIG= yes
-MAN1= cooledit.1 coolman.1 smalledit.1
-
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CFLAGS+= -DHAVE_MBRTOWC
@@ -29,7 +26,6 @@ CFLAGS+= -DHAVE_MBRTOWC
CONFIGURE_ARGS+= --enable-NeXT-look
.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|po pixmap man|po man|g' ${WRKSRC}/Makefile.in
diff --git a/editors/cooledit/pkg-plist b/editors/cooledit/pkg-plist
index bfdac7962a0e..67d3f8d19371 100644
--- a/editors/cooledit/pkg-plist
+++ b/editors/cooledit/pkg-plist
@@ -59,5 +59,8 @@ share/locale/pt/LC_MESSAGES/cooledit.mo
share/locale/ru/LC_MESSAGES/cooledit.mo
share/locale/sl/LC_MESSAGES/cooledit.mo
share/locale/sv/LC_MESSAGES/cooledit.mo
+man/man1/cooledit.1.gz
+man/man1/coolman.1.gz
+man/man1/smalledit.1.gz
@dirrm %%DATADIR%%/syntax
@dirrm %%DATADIR%%
diff --git a/editors/pico-alpine/Makefile b/editors/pico-alpine/Makefile
index 2e8b0643db44..be8e637e1d7b 100644
--- a/editors/pico-alpine/Makefile
+++ b/editors/pico-alpine/Makefile
@@ -18,9 +18,6 @@ PKGINSTALL= /nonexistent # To void equivalent in master port
PICO_ALPINE_SLAVE= yes
-MAN1= pico.1 pilot.1
-
-NO_STAGE= yes
post-patch:
@${CP} ${WRKSRC}/imap/Makefile ${WRKSRC}/imap/Makefile.presed
@${SED} -e "s#^\(all:.*\) bundled\$$#\1#" \
diff --git a/editors/pico-alpine/pkg-plist b/editors/pico-alpine/pkg-plist
index 46fee040c4d7..ef8bc41edcb8 100644
--- a/editors/pico-alpine/pkg-plist
+++ b/editors/pico-alpine/pkg-plist
@@ -1,2 +1,4 @@
bin/pico
bin/pilot
+man/man1/pico.1.gz
+man/man1/pilot.1.gz
diff --git a/games/gnugo/Makefile b/games/gnugo/Makefile
index eb53c792cf08..8fc242ed236e 100644
--- a/games/gnugo/Makefile
+++ b/games/gnugo/Makefile
@@ -11,13 +11,12 @@ MAINTAINER= spcoltri@omcl.org
COMMENT= The game of Go
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
INFO= gnugo
-MAN6= gnugo.6
-PLIST_FILES= bin/gnugo
+PLIST_FILES= bin/gnugo \
+ man/man6/gnugo.6.gz
-NO_STAGE= yes
post-extract:
${RM} -f ${WRKSRC}/doc/gnugo.info*
diff --git a/math/cln/Makefile b/math/cln/Makefile
index 1361c919657b..29608a96608e 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -21,7 +21,6 @@ CONFIGURE_ARGS= --with-gmp
USE_LDCONFIG= yes
INFO= cln
-MAN1= pi.1
STRIP= # none
@@ -29,7 +28,6 @@ CFLAGS+= -fPIC
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
diff --git a/math/cln/pkg-plist b/math/cln/pkg-plist
index 6ccfef5b4cd5..429e510450d8 100644
--- a/math/cln/pkg-plist
+++ b/math/cln/pkg-plist
@@ -82,4 +82,5 @@ lib/libcln.la
lib/libcln.so
lib/libcln.so.6
libdata/pkgconfig/cln.pc
+man/man1/pi.1.gz
@dirrm include/cln