aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/silence/Makefile3
-rw-r--r--editors/calligra/Makefile7
-rw-r--r--editors/kile-kde4/Makefile4
-rw-r--r--editors/kile-kde4/pkg-plist2
-rw-r--r--editors/klat4/Makefile4
-rw-r--r--editors/koffice-kde4/Makefile7
-rw-r--r--finance/kmymoney-kde4/Makefile2
-rw-r--r--finance/kmymoney-kde4/pkg-plist2
-rw-r--r--finance/skrooge/Makefile1
-rw-r--r--finance/skrooge/pkg-plist2
-rw-r--r--graphics/digikam-kde4/Makefile7
-rw-r--r--graphics/kipi-plugins-kde4/Makefile6
-rw-r--r--graphics/kphotoalbum-kde4/Makefile4
-rw-r--r--graphics/skanlite/Makefile3
-rw-r--r--math/rkward-kde4/Makefile5
-rw-r--r--misc/tellico-kde4/Makefile14
-rw-r--r--net-p2p/ktorrent/Makefile1
-rw-r--r--net-p2p/ktorrent/pkg-plist2
-rw-r--r--net-p2p/libktorrent/Makefile1
-rw-r--r--net-p2p/libktorrent/pkg-plist2
-rw-r--r--net/knemo-kde4/Makefile1
-rw-r--r--net/knemo-kde4/pkg-plist2
22 files changed, 47 insertions, 35 deletions
diff --git a/deskutils/silence/Makefile b/deskutils/silence/Makefile
index b9b7545cad96..e25c40b97a20 100644
--- a/deskutils/silence/Makefile
+++ b/deskutils/silence/Makefile
@@ -7,6 +7,7 @@
PORTNAME= silence
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= deskutils kde
MASTER_SITES= http://kde-apps.org/CONTENT/content-files/
DISTNAME= 124776-${PORTNAME}-${PORTVERSION}
@@ -14,6 +15,8 @@ DISTNAME= 124776-${PORTNAME}-${PORTVERSION}
MAINTAINER= syncer@gmail.com
COMMENT= An information management tool
+RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/katepart.so:${PORTSDIR}/editors/kate
+
USE_CMAKE= yes
USE_KDE4= kdelibs kdehier kdeprefix automoc4
USE_QT_VER= 4
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 1a988f565036..45ce20baa3d9 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -7,7 +7,7 @@
PORTNAME= koffice
PORTVERSION= 2.3.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KOFFICE2_BRANCH}/${PORTNAME}-${PORTVERSION}/
@@ -26,7 +26,7 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
exiv2.10:${PORTSDIR}/graphics/exiv2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- kdcraw.9:${PORTSDIR}/graphics/kdegraphics4 \
+ kdcraw.20:${PORTSDIR}/graphics/libkdcraw-kde4 \
lcms2.2:${PORTSDIR}/graphics/lcms2 \
wpg-0.2:${PORTSDIR}/graphics/libwpg \
png.6:${PORTSDIR}/graphics/png \
@@ -37,7 +37,8 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
fftw3.5:${PORTSDIR}/math/fftw3 \
- dcmdata.3:${PORTSDIR}/devel/dcmtk
+ dcmdata.3:${PORTSDIR}/devel/dcmtk \
+ okularcore.1:${PORTSDIR}/graphics/okular
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx30
CONFLICTS= calligra-[0-9]*
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index 683434aa3643..4f3de66fca61 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kile
DISTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= editors kde
MASTER_SITES= SF/${PORTNAME}/stable/${PORTNAME}-${DISTVERSION}
@@ -14,7 +15,8 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= A LaTeX source editor for KDE
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
- identify:${PORTSDIR}/graphics/ImageMagick
+ identify:${PORTSDIR}/graphics/ImageMagick \
+ ${KDE4_PREFIX}/lib/kde4/katepart.so:${PORTSDIR}/editors/kate
USE_BZIP2= yes
USE_CMAKE= yes
diff --git a/editors/kile-kde4/pkg-plist b/editors/kile-kde4/pkg-plist
index ceba7809e4fd..4bc7e36611c5 100644
--- a/editors/kile-kde4/pkg-plist
+++ b/editors/kile-kde4/pkg-plist
@@ -1627,8 +1627,6 @@ share/mime/packages/kile.xml
share/mime/text/x-kilepr.xml
@dirrmtry share/locale/x-test/LC_MESSAGES
@dirrmtry share/locale/x-test
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
@dirrm share/doc/kile
@dirrm share/doc/HTML/uk/kile
@dirrm share/doc/HTML/sv/kile
diff --git a/editors/klat4/Makefile b/editors/klat4/Makefile
index 0e89f70bcc7b..a87e0228a6c7 100644
--- a/editors/klat4/Makefile
+++ b/editors/klat4/Makefile
@@ -7,13 +7,15 @@
PORTNAME= klat4
PORTVERSION= 0.6.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= editors
MASTER_SITES= http://klat.algebraic.ru/
MAINTAINER= laddassm@gmail.com
COMMENT= A LaTeX source editor for KDE4
+RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/katepart.so:${PORTSDIR}/editors/kate
+
USE_BZIP2= yes
USE_CMAKE= yes
USE_KDE4= kdeprefix kdelibs automoc4
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 1a988f565036..45ce20baa3d9 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= koffice
PORTVERSION= 2.3.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KOFFICE2_BRANCH}/${PORTNAME}-${PORTVERSION}/
@@ -26,7 +26,7 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
exiv2.10:${PORTSDIR}/graphics/exiv2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- kdcraw.9:${PORTSDIR}/graphics/kdegraphics4 \
+ kdcraw.20:${PORTSDIR}/graphics/libkdcraw-kde4 \
lcms2.2:${PORTSDIR}/graphics/lcms2 \
wpg-0.2:${PORTSDIR}/graphics/libwpg \
png.6:${PORTSDIR}/graphics/png \
@@ -37,7 +37,8 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
fftw3.5:${PORTSDIR}/math/fftw3 \
- dcmdata.3:${PORTSDIR}/devel/dcmtk
+ dcmdata.3:${PORTSDIR}/devel/dcmtk \
+ okularcore.1:${PORTSDIR}/graphics/okular
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx30
CONFLICTS= calligra-[0-9]*
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index 2df709b1e728..386d5498b6ab 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kmymoney
PORTVERSION= 4.6.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= finance kde
MASTER_SITES= SF/${PORTNAME}2/KMyMoney-KDE4/${PORTVERSION}
DISTFILES= ${PORTNAME}-${PORTVERSION}-2${EXTRACT_SUFX}
diff --git a/finance/kmymoney-kde4/pkg-plist b/finance/kmymoney-kde4/pkg-plist
index 67d12befbd27..0a7cf859e68d 100644
--- a/finance/kmymoney-kde4/pkg-plist
+++ b/finance/kmymoney-kde4/pkg-plist
@@ -1130,8 +1130,6 @@ share/locale/zh_CN/LC_MESSAGES/kmymoney.mo
share/locale/zh_TW/LC_MESSAGES/kmymoney.mo
share/mime/application/x-kmymoney.xml
share/mime/packages/x-kmymoney.xml
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
@dirrmtry share/icons/locolor/32x32/apps
@dirrmtry share/icons/locolor/32x32
@dirrmtry share/icons/locolor/16x16/apps
diff --git a/finance/skrooge/Makefile b/finance/skrooge/Makefile
index d5d67cfc933d..bb57a65b77c9 100644
--- a/finance/skrooge/Makefile
+++ b/finance/skrooge/Makefile
@@ -7,6 +7,7 @@
PORTNAME= skrooge
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= finance kde
MASTER_SITES= http://skrooge.org/files/
diff --git a/finance/skrooge/pkg-plist b/finance/skrooge/pkg-plist
index 6f21a502415e..6bd46f352191 100644
--- a/finance/skrooge/pkg-plist
+++ b/finance/skrooge/pkg-plist
@@ -458,8 +458,6 @@ share/locale/zh_TW/LC_MESSAGES/skrooge.mo
share/mime/application/x-skg.xml
share/mime/application/x-skgc.xml
share/mime/packages/x-skg.xml
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
@dirrm share/doc/HTML/en/skrooge
@dirrm share/apps/skrooge_unit
@dirrm share/apps/skrooge_tracker
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index 44386546a242..16c692fa692d 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= digikam
DISTVERSION= 1.9.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics kde
MASTER_SITES= SF
@@ -19,7 +20,9 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.6:${PORTSDIR}/graphics/png \
jasper.4:${PORTSDIR}/graphics/jasper \
lqr-1.3:${PORTSDIR}/graphics/liblqr-1 \
- kipi.8:${PORTSDIR}/graphics/kdegraphics4
+ kipi.8:${PORTSDIR}/graphics/libkipi-kde4 \
+ kexiv2.10:${PORTSDIR}/graphics/libkexiv2-kde4 \
+ kdcraw.20:${PORTSDIR}/graphics/libkdcraw-kde4
LATEST_LINK= ${PORTNAME}-kde4
@@ -57,7 +60,7 @@ CMAKE_ARGS+= -DWITH_LensFun:BOOL=OFF
.endif
#.if defined(WITH_MARBLE)
-#LIB_DEPENDS+= marblewidget.11:${PORTSDIR}/astro/marble
+#LIB_DEPENDS+= marblewidget.12:${PORTSDIR}/astro/marble
#PLIST_SUB+= MARBLE=""
#.else
CMAKE_ARGS+= -DWITH_MarbleWidget:BOOL=OFF
diff --git a/graphics/kipi-plugins-kde4/Makefile b/graphics/kipi-plugins-kde4/Makefile
index a7e46a84d90a..cc910acf5b41 100644
--- a/graphics/kipi-plugins-kde4/Makefile
+++ b/graphics/kipi-plugins-kde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kipi-plugins
PORTVERSION= 1.9.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics kde
MASTER_SITES= SF/kipi/${PORTNAME}/${PORTVERSION}
@@ -15,7 +16,10 @@ MAINTAINER= kris@pcbsd.org
COMMENT= KDE4 kipi graphics plugins
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- kipi.8:${PORTSDIR}/graphics/kdegraphics4 \
+ kipi.8:${PORTSDIR}/graphics/libkipi-kde4 \
+ kexiv2.10:${PORTSDIR}/graphics/libkexiv2-kde4 \
+ kdcraw.20:${PORTSDIR}/graphics/libkdcraw-kde4 \
+ ksane.0:${PORTSDIR}/graphics/libksane \
qjson.0:${PORTSDIR}/devel/qjson
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
diff --git a/graphics/kphotoalbum-kde4/Makefile b/graphics/kphotoalbum-kde4/Makefile
index 13911d793186..d1fb5674adf8 100644
--- a/graphics/kphotoalbum-kde4/Makefile
+++ b/graphics/kphotoalbum-kde4/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kphotoalbum
PORTVERSION= ${APP_VER}.${EXTRA_VER}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/extragear
@@ -18,7 +18,7 @@ COMMENT= Image viewer and organizer for KDE
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
exiv2.10:${PORTSDIR}/graphics/exiv2 \
- kipi.8:${PORTSDIR}/graphics/kdegraphics4
+ kipi.8:${PORTSDIR}/graphics/libkipi-kde4
USE_BZIP2= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
diff --git a/graphics/skanlite/Makefile b/graphics/skanlite/Makefile
index 89a488f4c97a..6d6945ff947a 100644
--- a/graphics/skanlite/Makefile
+++ b/graphics/skanlite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= skanlite
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= SF/sanewidget/Skanlite/
DIST_SUBDIR= KDE/extragear
@@ -14,7 +15,7 @@ DIST_SUBDIR= KDE/extragear
MAINTAINER= kde@FreeBSD.org
COMMENT= Simple image scanning application for KDE
-LIB_DEPENDS= ksane.0:${PORTSDIR}/graphics/kdegraphics4
+LIB_DEPENDS= ksane.0:${PORTSDIR}/graphics/libksane
USE_BZIP2= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
diff --git a/math/rkward-kde4/Makefile b/math/rkward-kde4/Makefile
index a3f4f8257d54..92b97b94c8da 100644
--- a/math/rkward-kde4/Makefile
+++ b/math/rkward-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rkward
PORTVERSION= 0.5.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/Current_Stable_Releases
PKGNAMESUFFIX= -kde4
@@ -16,7 +16,8 @@ MAINTAINER= thierry@FreeBSD.org
COMMENT= IDE/GUI for the R-project
BUILD_DEPENDS= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R
-RUN_DEPENDS= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R
+RUN_DEPENDS= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R \
+ ${KDE4_PREFIX}/lib/kde4/katepart.so:${PORTSDIR}/editors/kate
LICENSE= GPLv2
diff --git a/misc/tellico-kde4/Makefile b/misc/tellico-kde4/Makefile
index 766ceb5eaa00..ab264b8a5ab0 100644
--- a/misc/tellico-kde4/Makefile
+++ b/misc/tellico-kde4/Makefile
@@ -7,18 +7,20 @@
PORTNAME= tellico
PORTVERSION= 2.3.3
+PORTREVISION= 1
CATEGORIES= misc kde
MASTER_SITES= http://tellico-project.org/files/
MAINTAINER= kde@FreeBSD.org
COMMENT= Collection manager for KDE
-LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib \
- poppler-qt4:${PORTSDIR}/graphics/poppler-qt4 \
- yaz:${PORTSDIR}/net/yaz \
- exempi:${PORTSDIR}/textproc/exempi \
- kcddb:${PORTSDIR}/multimedia/kdemultimedia4 \
- ksane:${PORTSDIR}/graphics/kdegraphics4
+LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib \
+ poppler-qt4.3:${PORTSDIR}/graphics/poppler-qt4 \
+ yaz.4:${PORTSDIR}/net/yaz \
+ exempi.3:${PORTSDIR}/textproc/exempi \
+ kcddb.5:${PORTSDIR}/multimedia/kdemultimedia4 \
+ ksane.0:${PORTSDIR}/graphics/libksane \
+ qimageblitz.4:${PORTSDIR}/x11/qimageblitz
LICENSE= GPLv2
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 1566b9e5d267..11142d09205d 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ktorrent
DISTVERSION= 4.1.2
+PORTREVISION= 1
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION}/
diff --git a/net-p2p/ktorrent/pkg-plist b/net-p2p/ktorrent/pkg-plist
index ca3e1ef6868b..8d84dd44c005 100644
--- a/net-p2p/ktorrent/pkg-plist
+++ b/net-p2p/ktorrent/pkg-plist
@@ -274,8 +274,6 @@ share/locale/ug/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
share/locale/zh_CN/LC_MESSAGES/ktorrent.mo
share/locale/zh_TW/LC_MESSAGES/ktorrent.mo
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrm share/doc/HTML/en/ktorrent
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 89c041c490f1..bc8e6dc86b69 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libktorrent
DISTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION:S,^1,4,}/
diff --git a/net-p2p/libktorrent/pkg-plist b/net-p2p/libktorrent/pkg-plist
index 5f34f5b68968..92306016a985 100644
--- a/net-p2p/libktorrent/pkg-plist
+++ b/net-p2p/libktorrent/pkg-plist
@@ -225,8 +225,6 @@ share/locale/ug/LC_MESSAGES/libktorrent.mo
share/locale/uk/LC_MESSAGES/libktorrent.mo
share/locale/zh_CN/LC_MESSAGES/libktorrent.mo
share/locale/zh_TW/LC_MESSAGES/libktorrent.mo
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrm include/libktorrent/utp
diff --git a/net/knemo-kde4/Makefile b/net/knemo-kde4/Makefile
index 5c61eeb39e3d..23fe8f1dbcef 100644
--- a/net/knemo-kde4/Makefile
+++ b/net/knemo-kde4/Makefile
@@ -6,6 +6,7 @@
PORTNAME= knemo
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= net kde
MASTER_SITES= http://kde-apps.org/CONTENT/content-files/
DISTNAME= 12956-${PORTNAME}-${PORTVERSION}
diff --git a/net/knemo-kde4/pkg-plist b/net/knemo-kde4/pkg-plist
index 554882201b3f..523880bd3f5d 100644
--- a/net/knemo-kde4/pkg-plist
+++ b/net/knemo-kde4/pkg-plist
@@ -136,8 +136,6 @@ share/locale/zh_CN/LC_MESSAGES/kcm_knemo.mo
share/locale/zh_CN/LC_MESSAGES/knemo.mo
share/locale/zh_TW/LC_MESSAGES/kcm_knemo.mo
share/locale/zh_TW/LC_MESSAGES/knemo.mo
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrm share/apps/knemo/themes