aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/fpc-gdb/Makefile4
-rw-r--r--devel/gdb52/Makefile4
-rw-r--r--devel/gdb53/Makefile4
-rw-r--r--devel/gdb6/Makefile4
-rw-r--r--devel/gdb66/Makefile4
5 files changed, 20 insertions, 0 deletions
diff --git a/devel/fpc-gdb/Makefile b/devel/fpc-gdb/Makefile
index 65f219f36753..5485c107c149 100644
--- a/devel/fpc-gdb/Makefile
+++ b/devel/fpc-gdb/Makefile
@@ -28,6 +28,10 @@ COMMENT= GNU GDB 5.2.1 modified for Free Pascal
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
NO_LATEST_LINK= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/devel/gdb52/Makefile b/devel/gdb52/Makefile
index baaa50aef117..f00def16d5ef 100644
--- a/devel/gdb52/Makefile
+++ b/devel/gdb52/Makefile
@@ -22,6 +22,10 @@ COMMENT= GNU GDB 5.2.1 debugger
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
.if ${ARCH} == "amd64"
BROKEN= "Configure fails on amd64"
.endif
diff --git a/devel/gdb53/Makefile b/devel/gdb53/Makefile
index 492e23ee68ed..e1c4a292fff3 100644
--- a/devel/gdb53/Makefile
+++ b/devel/gdb53/Makefile
@@ -25,6 +25,10 @@ CONFIGURE_ARGS= --program-suffix=53
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
.if ${ARCH} == "amd64"
BROKEN= "Configure fails on amd64"
.endif
diff --git a/devel/gdb6/Makefile b/devel/gdb6/Makefile
index e61cfc7c2496..660de0342409 100644
--- a/devel/gdb6/Makefile
+++ b/devel/gdb6/Makefile
@@ -31,6 +31,10 @@ CFLAGS+= -DRL_NO_COMPAT
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index e61cfc7c2496..660de0342409 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -31,6 +31,10 @@ CFLAGS+= -DRL_NO_COMPAT
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif