aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--finance/ledgersmb/Makefile3
-rw-r--r--www/WebMagick/Makefile3
-rw-r--r--www/bkmrkconv/Makefile2
-rw-r--r--www/cgi-lib.pl/Makefile8
-rw-r--r--www/decss/Makefile8
-rw-r--r--www/foswiki/Makefile2
-rw-r--r--www/goose/Makefile9
-rw-r--r--www/harvest/Makefile14
-rw-r--r--www/html2wml/Makefile8
-rw-r--r--www/htmlpp/Makefile8
-rw-r--r--www/ljdeps/Makefile2
-rw-r--r--www/llgal/Makefile8
-rw-r--r--www/mknmz-wwwoffle/Makefile8
-rw-r--r--www/reportmagic/Makefile2
-rw-r--r--www/ruboard/Makefile8
-rw-r--r--www/swish++/Makefile9
-rw-r--r--www/syndigator/Makefile2
-rw-r--r--www/w3mir/Makefile8
-rw-r--r--www/webinject/Makefile8
-rw-r--r--www/wwwoffle/Makefile2
-rw-r--r--www/wwwstat/Makefile2
21 files changed, 36 insertions, 88 deletions
diff --git a/finance/ledgersmb/Makefile b/finance/ledgersmb/Makefile
index 0c38f8e4a8bf..717dcbcf1518 100644
--- a/finance/ledgersmb/Makefile
+++ b/finance/ledgersmb/Makefile
@@ -14,10 +14,9 @@ BUILD_DEPENDS= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_BUILD= yes
-USE_PERL5= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PKGMESSAGE= ${WRKDIR}/pkg-message
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= *.pl locale/*/*.pl bin/*/*.pl utils/*/*.pl
SUB_FILES= ${PORTNAME}-httpd.conf pkg-message
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index 849ca8fe4b82..2df0c82959ab 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -16,8 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS= p5-Sort-Naturally>=0:${PORTSDIR}/textproc/p5-Sort-Naturally
-USES= shebangfix
-USE_PERL5= yes
+USES= shebangfix perl5
USE_AUTOTOOLS= autoconf aclocal automake
AUTOMAKE_ARGS+= --add-missing
INFO= webmagick
diff --git a/www/bkmrkconv/Makefile b/www/bkmrkconv/Makefile
index ee11a51ec751..87226e30dc87 100644
--- a/www/bkmrkconv/Makefile
+++ b/www/bkmrkconv/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.bleb.org/software/bkmrkconv/
MAINTAINER= ports@FreeBSD.org
COMMENT= Netscape bookmarks.html converter
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
post-patch:
diff --git a/www/cgi-lib.pl/Makefile b/www/cgi-lib.pl/Makefile
index 74465b6b03d0..6166f59ad6e4 100644
--- a/www/cgi-lib.pl/Makefile
+++ b/www/cgi-lib.pl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cgi-lib.pl
-# Date created: 23 June 2002
-# Whom: sada
-#
+# Created by: sada
# $FreeBSD$
-#
PORTNAME= cgi-lib_pl
PORTVERSION= 2.18
@@ -16,7 +12,7 @@ EXTRACT_SUFX= .gz
MAINTAINER= ports@FreeBSD.org
COMMENT= De facto standard library for creating CGI in perl
-USE_PERL5= YES
+USES= perl5
NO_BUILD= YES
NO_WRKSUBDIR= YES
PLIST_FILES= %%SITE_PERL%%/cgi-lib.pl
diff --git a/www/decss/Makefile b/www/decss/Makefile
index c083a5af676e..19d52c2d0f82 100644
--- a/www/decss/Makefile
+++ b/www/decss/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: decss
-# Date Created: 20 Feb 2000
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
+# Created by: Kris Kennaway <kris@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= decss
PORTVERSION= 1.0
@@ -17,7 +13,7 @@ COMMENT= Strip cascading style sheets from webpages
WRKSRC= ${WRKDIR}/source
NO_BUILD= YES
-USE_PERL5= YES
+USES= perl5
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/DeCSS ${PREFIX}/bin/decss
diff --git a/www/foswiki/Makefile b/www/foswiki/Makefile
index 575ddf6a7a8a..165be21c2b99 100644
--- a/www/foswiki/Makefile
+++ b/www/foswiki/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= p5-Error>=0.15:${PORTSDIR}/lang/p5-Error \
LICENSE= GPLv2
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
OPTIONS_DEFINE= OPTINT OPTOTH APACHE
diff --git a/www/goose/Makefile b/www/goose/Makefile
index 85a9e028bb1e..ba0d231d160e 100644
--- a/www/goose/Makefile
+++ b/www/goose/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection Makefile for: goose
-# Date created: Dec 30, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= goose
PORTVERSION= 0.5
@@ -23,7 +18,7 @@ RUN_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite \
p5-Curses>=0:${PORTSDIR}/devel/p5-Curses \
urlview:${PORTSDIR}/textproc/urlview
-USE_PERL5= yes
+USES= perl5
WRKSRC= ${WRKDIR}/${PORTNAME}
POD2MAN?= pod2man
diff --git a/www/harvest/Makefile b/www/harvest/Makefile
index ddbb545e6d0c..5a88c51f947e 100644
--- a/www/harvest/Makefile
+++ b/www/harvest/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: harvest
-# Date created: Fri Mar 1 19:43:52 MET 1996
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
-#
+# Created by: Andreas Klemm <andreas@klemm.gtn.com>
# $FreeBSD$
-#
PORTNAME= harvest
PORTVERSION= 1.9.14
@@ -13,14 +9,14 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20devel/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Collect information from all over the Internet
-USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
+USE_BZIP2= yes
USE_AUTOTOOLS= libtool
LIBTOOLFILES= configure src/gatherer/curl/configure
USE_LDCONFIG= yes
-NO_MTREE= yes
+NO_MTREE= yes
CONFIGURE_ARGS?= --prefix=${PREFIX}/${PORTNAME} --without-wish
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_UNSAFE=yes
STRIP= # none
diff --git a/www/html2wml/Makefile b/www/html2wml/Makefile
index 373304323d0a..b491c1aee43e 100644
--- a/www/html2wml/Makefile
+++ b/www/html2wml/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: html2wml
-# Date created: 15 January 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
+# Created by: George Reid <greid@ukug.uk.freebsd.org>
# $FreeBSD$
-#
PORTNAME= html2wml
PORTVERSION= 0.4.11
@@ -17,7 +13,7 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Text-Template>=0:${PORTSDIR}/textproc/p5-Text-Template \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-USE_PERL5= yes
+USES= perl5
MAKE_ARGS= PREFIX=${PREFIX} DOCDIR=${DOCDIR}
PLIST_FILES= bin/html2wml
diff --git a/www/htmlpp/Makefile b/www/htmlpp/Makefile
index 9912492607f5..560aea587ba7 100644
--- a/www/htmlpp/Makefile
+++ b/www/htmlpp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: htmlpp
-# Date created: 9 Nov 1997
-# Whom: Donald Burr <dburr@FreeBSD.org>
-#
+# Created by: Donald Burr <dburr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= htmlpp
PORTVERSION= 4.2a
@@ -15,7 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A Perl script to allow easy creation of HTML from template files
-USE_PERL5= YES
+USES= perl5
NO_WRKSUBDIR= yes
diff --git a/www/ljdeps/Makefile b/www/ljdeps/Makefile
index 383336a58d6b..f9f824687d92 100644
--- a/www/ljdeps/Makefile
+++ b/www/ljdeps/Makefile
@@ -31,7 +31,7 @@ RUN_DEPENDS= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet \
EXTRACT_ONLY= # Empty
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
do-install: # Empty
diff --git a/www/llgal/Makefile b/www/llgal/Makefile
index 2491281dfc76..f9c45ac7f635 100644
--- a/www/llgal/Makefile
+++ b/www/llgal/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: llgal
-# Date created: 2007-01-25
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= llgal
@@ -27,8 +24,7 @@ RUN_DEPENDS= p5-Image-Size>=0:${PORTSDIR}/graphics/p5-Image-Size \
convert:${PORTSDIR}/graphics/ImageMagick
USE_BZIP2= yes
-USE_PERL5= yes
-USES= gettext
+USES= gettext perl5
USE_GMAKE= yes
MAN1= llgal.1
diff --git a/www/mknmz-wwwoffle/Makefile b/www/mknmz-wwwoffle/Makefile
index 095c816acb7a..19f323b24b95 100644
--- a/www/mknmz-wwwoffle/Makefile
+++ b/www/mknmz-wwwoffle/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mknmz-wwwoffle
-# Date created: 2 May 2004
-# Whom: Andrey Slusar <anray@FreeBSD.org>
-#
+# Created by: Andrey Slusar <anray@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mknmz-wwwoffle
PORTVERSION= 0.7.2
@@ -17,7 +13,7 @@ COMMENT= WWWOFFLE cache indexer for full-text search system Namazu
RUN_DEPENDS= ${LOCALBASE}/bin/wwwoffle:${PORTSDIR}/www/wwwoffle
BUILD_DEPENDS= ${LOCALBASE}/bin/mknmz:${PORTSDIR}/databases/namazu2
-USE_PERL5= yes
+USES= perl5
HAS_CONFIGURE= yes
MAN1= mknmz-wwwoffle.1
diff --git a/www/reportmagic/Makefile b/www/reportmagic/Makefile
index c147d1258cf9..f84e0c9476c4 100644
--- a/www/reportmagic/Makefile
+++ b/www/reportmagic/Makefile
@@ -18,7 +18,7 @@ DISTNAME= rmagic-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A web site statistics post-processor for Analog
-USE_PERL5= yes
+USES= perl5
RUN_DEPENDS= analog:${PORTSDIR}/www/analog \
p5-GD-Graph3d>=0:${PORTSDIR}/graphics/p5-GD-Graph3d \
diff --git a/www/ruboard/Makefile b/www/ruboard/Makefile
index d6cf874a5d35..4841ab842f04 100644
--- a/www/ruboard/Makefile
+++ b/www/ruboard/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ruboard
-# Date created: 5 October 1998
-# Whom: Andrew Maltsev <am@amsoft.ru>
-#
+# Created by: Andrew Maltsev <am@amsoft.ru>
# $FreeBSD$
-#
PORTNAME= ruboard
PORTVERSION= 1.2.2
@@ -13,6 +9,6 @@ MASTER_SITES= http://amsoft.ru/pub/ruboard/
MAINTAINER= ports@FreeBSD.org
COMMENT= A web based discussion board
-USE_PERL5= yes
+USES= perl5
.include <bsd.port.mk>
diff --git a/www/swish++/Makefile b/www/swish++/Makefile
index f952603da001..58f1c50f1f83 100644
--- a/www/swish++/Makefile
+++ b/www/swish++/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: swish++
-# Date created: Jan 13, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= swish++
PORTVERSION= 6.1.5
@@ -17,7 +12,7 @@ COMMENT= Simple Web Indexing System for Humans: C++ version
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
-USE_PERL5= yes
+USES= perl5
USE_GMAKE= yes
MAKEFILE= GNUmakefile
MAKE_ENV= PERL=${PERL} PERL_VER=${PERL_VERSION}
diff --git a/www/syndigator/Makefile b/www/syndigator/Makefile
index f1e745335bd6..0cdeafe7b10b 100644
--- a/www/syndigator/Makefile
+++ b/www/syndigator/Makefile
@@ -20,8 +20,8 @@ RUN_DEPENDS= p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv \
p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
p5-Gtk2-Html2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2-Html2
+USES= perl5
USE_GNOME= gnomehier
-USE_PERL5= yes
NO_BUILD= yes
GNOMEDIR= ${PREFIX}/share
diff --git a/www/w3mir/Makefile b/www/w3mir/Makefile
index 7bdaad125c06..7be339686984 100644
--- a/www/w3mir/Makefile
+++ b/www/w3mir/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: w3mir
-# Date created: 9 May 1998
-# Whom: ache
-#
+# Created by: ache
# $FreeBSD$
-#
PORTNAME= w3mir
PORTVERSION= 1.0.10
@@ -17,7 +13,7 @@ COMMENT= All-purpose HTTP copying and mirroring tool
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= yes
+USES= perl5
MAN1= w3mir.1 w3mfix.1
diff --git a/www/webinject/Makefile b/www/webinject/Makefile
index ed134b8ee604..00141a91115a 100644
--- a/www/webinject/Makefile
+++ b/www/webinject/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: webinject
-# Date created: August 22nd 2006
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-#
PORTNAME= webinject
PORTVERSION= 1.41
@@ -25,7 +21,7 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
#RUN_DEPENDS+= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
.endif
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/www/wwwoffle/Makefile b/www/wwwoffle/Makefile
index f963bc560b29..ccbf6c09bac7 100644
--- a/www/wwwoffle/Makefile
+++ b/www/wwwoffle/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
-USE_PERL5= yes
+USES= perl5
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
diff --git a/www/wwwstat/Makefile b/www/wwwstat/Makefile
index d4a68fd696a2..f770350d3e8e 100644
--- a/www/wwwstat/Makefile
+++ b/www/wwwstat/Makefile
@@ -17,7 +17,7 @@ COMMENT= Webserver logfile analysis package
MAKE_JOBS_SAFE= yes
USE_APACHE_RUN= 22+
-USE_PERL5= yes
+USES= perl5
MAKE_ENV+= PERL5=${PERL5}
MAN1= wwwstat.1 splitlog.1