aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-App-Info/Makefile3
-rw-r--r--textproc/p5-Data-FormValidator/Makefile3
-rw-r--r--textproc/p5-Text-WikiFormat/Makefile3
-rw-r--r--www/p5-CGI-Application-ValidateRM/Makefile3
4 files changed, 4 insertions, 8 deletions
diff --git a/devel/p5-App-Info/Makefile b/devel/p5-App-Info/Makefile
index c158fb227b5c..15948b9cda9c 100644
--- a/devel/p5-App-Info/Makefile
+++ b/devel/p5-App-Info/Makefile
@@ -17,7 +17,7 @@ COMMENT= Interface for providing metadata about installed software packages
BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= YES
+PERL_MODBUILD= YES
MAN3= App::Info::HTTPD.3 App::Info::Lib::Iconv.3 \
App::Info::HTTPD::Apache.3 App::Info::Lib.3 App::Info::RDBMS.3 \
@@ -26,7 +26,6 @@ MAN3= App::Info::HTTPD.3 App::Info::Lib::Iconv.3 \
App::Info::Util.3 App::Info::Handler.3 App::Info.3 \
App::Info::Handler::Prompt.3 App::Info::Handler::Carp.3
-.include "../../devel/p5-Module-Build/inc.build.mk"
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500600
diff --git a/textproc/p5-Data-FormValidator/Makefile b/textproc/p5-Data-FormValidator/Makefile
index 6ca2c91a8e97..5c0ab5923d26 100644
--- a/textproc/p5-Data-FormValidator/Makefile
+++ b/textproc/p5-Data-FormValidator/Makefile
@@ -19,13 +19,12 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-
${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
${SITE_PERL}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic \
- ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common \
${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= Data::FormValidator.3 \
Data::FormValidator::ConstraintsFactory.3 \
diff --git a/textproc/p5-Text-WikiFormat/Makefile b/textproc/p5-Text-WikiFormat/Makefile
index 804dfc936ad7..1ac389c54823 100644
--- a/textproc/p5-Text-WikiFormat/Makefile
+++ b/textproc/p5-Text-WikiFormat/Makefile
@@ -17,10 +17,9 @@ COMMENT= Module for translating Wiki formatted text into other formats
BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= Text::WikiFormat.3
PLIST_FILES= %%SITE_PERL%%/Text/WikiFormat.pm
diff --git a/www/p5-CGI-Application-ValidateRM/Makefile b/www/p5-CGI-Application-ValidateRM/Makefile
index 088c7401cfda..f6c79eca5b49 100644
--- a/www/p5-CGI-Application-ValidateRM/Makefile
+++ b/www/p5-CGI-Application-ValidateRM/Makefile
@@ -16,14 +16,13 @@ DISTNAME= ${PORTNAME:S/eRM/e-RM/}-${PORTVERSION}
MAINTAINER= mig@mig-29.net
COMMENT= Help validate forms with the CGI::Application framework
-BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
RUN_DEPENDS= ${SITE_PERL}/HTML/FillInForm.pm:${PORTSDIR}/www/p5-HTML-FillInForm \
${SITE_PERL}/Data/FormValidator.pm:${PORTSDIR}/textproc/p5-Data-FormValidator \
${SITE_PERL}/CGI/Carp.pm:${PORTSDIR}/www/p5-CGI.pm \
${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= CGI::Application::ValidateRM.3