aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/adocman/Makefile42
-rw-r--r--devel/adocman/distinfo3
-rw-r--r--devel/adocman/files/Makefile.PL11
-rw-r--r--devel/adocman/pkg-descr13
-rw-r--r--devel/adocman/pkg-plist13
6 files changed, 83 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f2381bd8771a..346195c8731b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -22,6 +22,7 @@
SUBDIR += adacurses
SUBDIR += adasdl
SUBDIR += adime
+ SUBDIR += adocman
SUBDIR += agenda-headers
SUBDIR += agenda-libs
SUBDIR += agenda-snow-libs
diff --git a/devel/adocman/Makefile b/devel/adocman/Makefile
new file mode 100644
index 000000000000..429f7545c2d2
--- /dev/null
+++ b/devel/adocman/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: adocman
+# Date created: 4 January 2006
+# Whom: fenner
+#
+# $FreeBSD$
+#
+
+PORTNAME= adocman
+PORTVERSION= 0.13
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sitedocs
+
+MAINTAINER= fenner@FreeBSD.Org
+COMMENT= Automated sourceforge administration tool
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+
+PERL_CONFIGURE= YES
+
+SCRIPTS= adocman atracker xml_export
+DOCS= LICENSE README TODO adocman.html xml_export.html
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile.PL ${WRKSRC}
+
+post-install:
+.for f in ${SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/$f ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/adocman/distinfo b/devel/adocman/distinfo
new file mode 100644
index 000000000000..1febc3a57d71
--- /dev/null
+++ b/devel/adocman/distinfo
@@ -0,0 +1,3 @@
+MD5 (adocman-0.13.tar.gz) = 4f6a90604dd583bd7b9fa287d95feed7
+SHA256 (adocman-0.13.tar.gz) = a87a13bed534e54a0dd225dc1dc24a6d05de6d4be4ba16aa7c85be8f41c4420b
+SIZE (adocman-0.13.tar.gz) = 42966
diff --git a/devel/adocman/files/Makefile.PL b/devel/adocman/files/Makefile.PL
new file mode 100644
index 000000000000..2ccaef53e686
--- /dev/null
+++ b/devel/adocman/files/Makefile.PL
@@ -0,0 +1,11 @@
+#
+# Make it easier to install the perl modules in the
+# adocman project.
+#
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'Alexandria',
+ VERSION_FROM => 'Alexandria/Client.pm'
+);
+
diff --git a/devel/adocman/pkg-descr b/devel/adocman/pkg-descr
new file mode 100644
index 000000000000..062c3b1aad71
--- /dev/null
+++ b/devel/adocman/pkg-descr
@@ -0,0 +1,13 @@
+adocman is a set of perl modules and programs for performing
+operations against the SourceForge.net site, currently including
+basic Client operations (i.e. login/logout) and DocManager operations.
+
+It includes the Alexandria perl module, which provides the back end
+support for operations, the adocman program, which provides the
+means to perform DocManager operations from the command-line or
+scripts (by project developers or admins listed as DocManager
+Editors), and the xml_export program, providing the means to automate
+downloads of data from the XML data export facility on SourceForge.net
+(by project administrators).
+
+WWW: http://sourceforge.net/projects/sitedocs
diff --git a/devel/adocman/pkg-plist b/devel/adocman/pkg-plist
new file mode 100644
index 000000000000..f63434f61d20
--- /dev/null
+++ b/devel/adocman/pkg-plist
@@ -0,0 +1,13 @@
+bin/adocman
+bin/atracker
+bin/xml_export
+%%SITE_PERL%%/Alexandria/Client.pm
+%%SITE_PERL%%/Alexandria/Docman.pm
+%%SITE_PERL%%/Alexandria/Tracker.pm
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/adocman.html
+%%PORTDOCS%%%%DOCSDIR%%/xml_export.html
+@dirrm %%SITE_PERL%%/Alexandria
+%%PORTDOCS%%@dirrm %%DOCSDIR%%