aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/gedit-plugins/Makefile3
-rw-r--r--editors/gedit/Makefile5
-rw-r--r--editors/pluma/Makefile2
-rw-r--r--math/gnome-calculator/Makefile2
-rw-r--r--x11-fm/sushi/Makefile3
-rw-r--r--x11-toolkits/gtksourceview3/Makefile3
-rw-r--r--x11/mate-applets/Makefile4
7 files changed, 14 insertions, 8 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 5a593b6f120e..35acb1522082 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -20,8 +20,9 @@ RUN_DEPENDS= gedit>=0:editors/gedit
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome libtool pathfix pkgconfig \
+USES= compiler:c11 gettext gmake gnome libtool pathfix pkgconfig \
python:3.4+ tar:xz
+USE_CSTD= c11
USE_GNOME= gtk30 gtksourceview3 intlhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 71b4a3311e9b..6d9dd7b25654 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -28,8 +28,9 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake gnome libtool localbase \
- pathfix pkgconfig python:3.2+ shebangfix tar:xz
+USES= compiler:c11 desktop-file-utils gettext gmake gnome libtool \
+ localbase pathfix pkgconfig python:3.2+ shebangfix tar:xz
+USE_CSTD= c11
USE_GNOME= cairo gdkpixbuf2 gtksourceview3 intlhack introspection \
libxml2 pygobject3
SHEBANG_FILES= plugins/externaltools/data/send-to-fpaste.tool.in
diff --git a/editors/pluma/Makefile b/editors/pluma/Makefile
index c3bc3da20d68..3cae9bdc9c95 100644
--- a/editors/pluma/Makefile
+++ b/editors/pluma/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gmake libtool localbase \
+USES= compiler:c11 desktop-file-utils gmake libtool localbase \
pathfix pkgconfig python:3.3+ shebangfix tar:xz
USE_XORG= ice sm x11
USE_GNOME= cairo gdkpixbuf2 gnomeprefix gtk30 gtksourceview3 \
diff --git a/math/gnome-calculator/Makefile b/math/gnome-calculator/Makefile
index 0af9a7cbbf5a..a182a201bb20 100644
--- a/math/gnome-calculator/Makefile
+++ b/math/gnome-calculator/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libmpfr.so:math/mpfr \
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome libtool localbase pkgconfig tar:xz
+USES= compiler:c11 gettext gmake gnome libtool localbase pkgconfig tar:xz
USE_GNOME= cairo gdkpixbuf2 gtk30 gtksourceview3 intltool
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/x11-fm/sushi/Makefile b/x11-fm/sushi/Makefile
index 5432c505d16c..edd9688e91df 100644
--- a/x11-fm/sushi/Makefile
+++ b/x11-fm/sushi/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= nautilus:x11-fm/nautilus
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
+USES= compiler:c11 gettext gmake gnome libtool pathfix pkgconfig tar:xz
+USE_CSTD= c11
INSTALLS_ICONS= yes
USE_GNOME= gnomeprefix gtksourceview3 intlhack introspection:build
USE_LDCONFIG= yes
diff --git a/x11-toolkits/gtksourceview3/Makefile b/x11-toolkits/gtksourceview3/Makefile
index c33768eca4b8..d6d6e1f53553 100644
--- a/x11-toolkits/gtksourceview3/Makefile
+++ b/x11-toolkits/gtksourceview3/Makefile
@@ -19,7 +19,8 @@ PORTSCOUT= limitw:1,even
BUILD_DEPENDS= vala:lang/vala
-USES+= gettext gmake gnome libtool pathfix pkgconfig
+USES+= compiler:c11 gettext gmake gnome libtool pathfix pkgconfig
+USE_CSTD= c11
USE_GNOME= cairo gdkpixbuf2 gnomeprefix gtk30 intlhack \
introspection:build libxml2 referencehack
GNU_CONFIGURE= yes
diff --git a/x11/mate-applets/Makefile b/x11/mate-applets/Makefile
index 498182ea1a15..68ef3a904783 100644
--- a/x11/mate-applets/Makefile
+++ b/x11/mate-applets/Makefile
@@ -26,7 +26,9 @@ PORTSCOUT= limitw:1,even
#USES= autoreconf:build gettext gmake libtool localbase pathfix \
# pkgconfig python shebangfix tar:xz
-USES= gettext gmake libtool localbase pkgconfig python:2.7 shebangfix tar:xz
+USES= compiler:c11 gettext gmake libtool localbase pkgconfig \
+ python:2.7 shebangfix tar:xz
+USE_CSTD= c11
#USE_MATE= desktop icontheme libmateweather panel polkit settingsdaemon
USE_MATE= libmateweather panel
USE_XORG= ice sm x11