aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/dadadodo/Makefile21
-rw-r--r--textproc/dadadodo/distinfo1
-rw-r--r--textproc/dadadodo/pkg-comment1
-rw-r--r--textproc/dadadodo/pkg-descr4
-rw-r--r--textproc/dadadodo/pkg-plist1
6 files changed, 29 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index da4e2357141f..a00d7e2a0995 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -18,6 +18,7 @@
SUBDIR += cole
SUBDIR += cost
SUBDIR += crimson
+ SUBDIR += dadadodo
SUBDIR += dico
SUBDIR += dict
SUBDIR += diff-mode.el
diff --git a/textproc/dadadodo/Makefile b/textproc/dadadodo/Makefile
new file mode 100644
index 000000000000..1a20c5755df7
--- /dev/null
+++ b/textproc/dadadodo/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: dadadodo
+# Date created: May 31, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dadadodo
+PORTVERSION= 1.03
+CATEGORIES= textproc
+MASTER_SITES= http://www.jwz.org/dadadodo/
+
+MAINTAINER= markp@FreeBSD.org
+
+pre-patch:
+ ${PERL} -pi -e "s/^(CC|CFLAGS).+//" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dadadodo ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/dadadodo/distinfo b/textproc/dadadodo/distinfo
new file mode 100644
index 000000000000..f5201c290c19
--- /dev/null
+++ b/textproc/dadadodo/distinfo
@@ -0,0 +1 @@
+MD5 (dadadodo-1.03.tar.gz) = 0c6351a2f9d614b33bfed4cbf11e6044
diff --git a/textproc/dadadodo/pkg-comment b/textproc/dadadodo/pkg-comment
new file mode 100644
index 000000000000..284f1ba02a55
--- /dev/null
+++ b/textproc/dadadodo/pkg-comment
@@ -0,0 +1 @@
+Text processor which analyses text and generates random sentences
diff --git a/textproc/dadadodo/pkg-descr b/textproc/dadadodo/pkg-descr
new file mode 100644
index 000000000000..ae7b0fc98801
--- /dev/null
+++ b/textproc/dadadodo/pkg-descr
@@ -0,0 +1,4 @@
+Dadadodo analyses text files and generates markov chains of word
+frequencies; it can then generate random sentences based on that data.
+
+WWW: http://www.jwz.org/dadadodo/
diff --git a/textproc/dadadodo/pkg-plist b/textproc/dadadodo/pkg-plist
new file mode 100644
index 000000000000..0f77042b7f08
--- /dev/null
+++ b/textproc/dadadodo/pkg-plist
@@ -0,0 +1 @@
+bin/dadadodo