aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/xpi-server_switcher/Makefile38
-rw-r--r--www/xpi-server_switcher/distinfo3
-rw-r--r--www/xpi-server_switcher/pkg-descr10
4 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4464140b0d71..01e74b9edc62 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -978,6 +978,7 @@
SUBDIR += xpi-fasterfox
SUBDIR += xpi-noscript
SUBDIR += xpi-pdf_download
+ SUBDIR += xpi-server_switcher
SUBDIR += xpi-tabmixplus
SUBDIR += xpi-unplug
SUBDIR += xshttpd
diff --git a/www/xpi-server_switcher/Makefile b/www/xpi-server_switcher/Makefile
new file mode 100644
index 000000000000..0b24ade9e6d2
--- /dev/null
+++ b/www/xpi-server_switcher/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: xpi-server_switcher
+# Date created: 2006/05/06
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= server_switcher
+PORTVERSION= 0.1b
+DISTVERSIONSUFFIX= -fx
+CATEGORIES= www
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= An extension to navigational help tool for web developers
+
+XPI_ID= {F7D360DC-B8F8-11DA-86BD-3EC8728786A0}
+XPI_FILES= chrome/switcher/content/about.xul \
+ chrome/switcher/content/common/preferences.js \
+ chrome/switcher/content/common/string.js \
+ chrome/switcher/content/dialogs/resize.js \
+ chrome/switcher/content/dialogs/resize.xul \
+ chrome/switcher/content/switcherOptions.js \
+ chrome/switcher/content/switcherOptions.xul \
+ chrome/switcher/content/switcherOverlay-old.js \
+ chrome/switcher/content/switcherOverlay.js \
+ chrome/switcher/content/switcherOverlay.xul \
+ chrome/switcher/skin/classic/devserver.png \
+ chrome/switcher/skin/classic/hceswitch.css \
+ chrome/switcher/skin/classic/icon.png \
+ chrome/switcher/skin/classic/liveserver.png \
+ chrome.manifest install.rdf license.txt
+XPI_DIRS= chrome/switcher/content/common \
+ chrome/switcher/content/dialogs chrome/switcher/content \
+ chrome/switcher/skin/classic chrome/switcher/skin \
+ chrome/switcher chrome
+
+.include "../xpi-adblock/Makefile.xpi"
+.include <bsd.port.mk>
diff --git a/www/xpi-server_switcher/distinfo b/www/xpi-server_switcher/distinfo
new file mode 100644
index 000000000000..58c7237547b4
--- /dev/null
+++ b/www/xpi-server_switcher/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpi/server_switcher-0.1b-fx.xpi) = b7dfedd3c63febe579fc4d1fbe91d37a
+SHA256 (xpi/server_switcher-0.1b-fx.xpi) = c44685823bfacd1d935854f7ab589c36fecb642d026870e19cbac512f5fad824
+SIZE (xpi/server_switcher-0.1b-fx.xpi) = 22463
diff --git a/www/xpi-server_switcher/pkg-descr b/www/xpi-server_switcher/pkg-descr
new file mode 100644
index 000000000000..58a5ed89d69c
--- /dev/null
+++ b/www/xpi-server_switcher/pkg-descr
@@ -0,0 +1,10 @@
+Server Switcher is a navigational help tool for web developers. It allows
+you to easily switch between sites on your development and live servers, so
+that you can immediately see the differences.
+
+Use case: When you are on http://localhost/page.html (your
+development-server) and click the ServerSwitcher-icon you will instantly be
+redirected to http://www.yoursite.com/page.html (your live-server).
+("localhost" and "www.yoursite.com" are of course configurable)
+
+WWW: https://addons.mozilla.org/firefox/2904/