aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/hk_classes/Makefile5
-rw-r--r--databases/hk_classes/distinfo4
-rw-r--r--databases/hk_classes/files/patch-utilities::Makefile.in31
-rw-r--r--databases/hk_classes/pkg-plist3
-rw-r--r--databases/knoda/Makefile5
-rw-r--r--databases/knoda/distinfo4
-rw-r--r--databases/knoda/files/patch-hk_kdeclasses::hk_kdedbdesigner.cpp11
-rw-r--r--databases/knoda/files/patch-hk_kdeclasses::hk_kdedblistview.cpp11
-rw-r--r--databases/knoda/files/patch-hk_kdeclasses::hk_kdeqbe.cpp11
-rw-r--r--databases/knoda/pkg-plist2
10 files changed, 26 insertions, 61 deletions
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index 2c1ebc9bb1e1..e854530f2efa 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -5,7 +5,8 @@
# $FreeBSD$
PORTNAME= hk_classes
-PORTVERSION= 0.7.2
+PORTVERSION= 0.7.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hk-classes
@@ -25,7 +26,7 @@ CONFIGURE_ENV+= LIBPYTHON="-l${PYTHON_VERSION} ${PTHREAD_LIBS}" \
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER= 15
LDCONFIG_DIRS+= ${PREFIX}/lib/hk_classes/
OPTIONS= MYSQL "Build MySQL driver" on \
diff --git a/databases/hk_classes/distinfo b/databases/hk_classes/distinfo
index 07d56c4a0fc4..1ad1f8638650 100644
--- a/databases/hk_classes/distinfo
+++ b/databases/hk_classes/distinfo
@@ -1,2 +1,2 @@
-MD5 (hk_classes-0.7.2.tar.bz2) = e7a9210791432a2458e7e174d84d5a0a
-SIZE (hk_classes-0.7.2.tar.bz2) = 536903
+MD5 (hk_classes-0.7.3.tar.bz2) = 722ef942d896dce8febe7b949c6c39e1
+SIZE (hk_classes-0.7.3.tar.bz2) = 623251
diff --git a/databases/hk_classes/files/patch-utilities::Makefile.in b/databases/hk_classes/files/patch-utilities::Makefile.in
index 50fd0539519a..76c765c66982 100644
--- a/databases/hk_classes/files/patch-utilities::Makefile.in
+++ b/databases/hk_classes/files/patch-utilities::Makefile.in
@@ -1,35 +1,30 @@
---- utilities/Makefile.in.orig Sun Mar 14 20:49:52 2004
-+++ utilities/Makefile.in Sun Apr 4 01:58:38 2004
-@@ -150,25 +150,25 @@
- hk_importcsv hk_report
-
-
+--- utilities/Makefile.in.orig Sun Mar 13 19:46:30 2005
++++ utilities/Makefile.in Fri Apr 1 20:52:27 2005
+@@ -221,20 +221,20 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ INCLUDES = -I../hk_classes
-hk_report_LDFLAGS = -lhk_classes -ldl -L../hk_classes
-+hk_report_LDFLAGS = -lhk_classes -L../hk_classes
++hk_report_LDFLAGS = -lhk_classes -L../hk_classes -largp ${LIBPTHREAD}
hk_report_SOURCES = hk_reportutility.cpp
-
-#hk_webform_LDFLAGS = -lhk_classes -ldl -L../hk_classes
+#hk_webform_LDFLAGS = -lhk_classes -L../hk_classes
#hk_webform_SOURCES = hk_webformutility.cpp
-hk_actionquery_LDFLAGS = -lhk_classes -ldl -L../hk_classes
-+hk_actionquery_LDFLAGS = -lhk_classes -L../hk_classes
++hk_actionquery_LDFLAGS = -lhk_classes -L../hk_classes -largp ${LIBPTHREAD}
hk_actionquery_SOURCES = hk_actionqueryutility.cpp
-
-hk_exportxml_LDFLAGS = -lhk_classes -ldl -L../hk_classes
-+hk_exportxml_LDFLAGS = -lhk_classes -L../hk_classes
++hk_exportxml_LDFLAGS = -lhk_classes -L../hk_classes -largp ${LIBPTHREAD}
hk_exportxml_SOURCES = hk_exportxmlutility.cpp
-
-hk_exportcsv_LDFLAGS = -lhk_classes -ldl -L../hk_classes
-+hk_exportcsv_LDFLAGS = -lhk_classes -L../hk_classes
++hk_exportcsv_LDFLAGS = -lhk_classes -L../hk_classes -largp ${LIBPTHREAD}
hk_exportcsv_SOURCES = hk_exportcsvutility.cpp
-
-hk_exporthtml_LDFLAGS = -lhk_classes -ldl -L../hk_classes
-+hk_exporthtml_LDFLAGS = -lhk_classes -L../hk_classes
++hk_exporthtml_LDFLAGS = -lhk_classes -L../hk_classes -largp ${LIBPTHREAD}
hk_exporthtml_SOURCES = hk_exporthtmlutility.cpp
-
-hk_importcsv_LDFLAGS = -lhk_classes -ldl -L../hk_classes
-+hk_importcsv_LDFLAGS = -lhk_classes -L../hk_classes
++hk_importcsv_LDFLAGS = -lhk_classes -L../hk_classes -largp ${LIBPTHREAD}
hk_importcsv_SOURCES = hk_importcsvutility.cpp
-
man_MANS = hk_report.1man hk_actionquery.1man hk_exportxml.1man hk_exporthtml.1man hk_exportcsv.1man hk_importcsv.1man
+ EXTRA_DIST = $(man_MANS)
diff --git a/databases/hk_classes/pkg-plist b/databases/hk_classes/pkg-plist
index 2b36590e2587..e04a8e7e1c3a 100644
--- a/databases/hk_classes/pkg-plist
+++ b/databases/hk_classes/pkg-plist
@@ -35,6 +35,7 @@ include/hk_classes/hk_font.h
include/hk_classes/hk_form.h
include/hk_classes/hk_importcsv.h
include/hk_classes/hk_interpreter.h
+include/hk_classes/hk_key.h
include/hk_classes/hk_label.h
include/hk_classes/hk_presentation.h
include/hk_classes/hk_qbe.h
@@ -69,7 +70,7 @@ include/hk_classes/hk_visible.h
%%PYTHON_SITELIBDIR%%/hk_classes.pyc
lib/hk_classes/libhk_classes.la
lib/hk_classes/libhk_classes.so
-lib/hk_classes/libhk_classes.so.6
+lib/hk_classes/libhk_classes.so.7
@dirrm lib/hk_classes/drivers
@dirrm lib/hk_classes
@dirrm include/hk_classes
diff --git a/databases/knoda/Makefile b/databases/knoda/Makefile
index 65906c93503d..18da2b219634 100644
--- a/databases/knoda/Makefile
+++ b/databases/knoda/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= knoda
-PORTVERSION= 0.7.2
-PORTREVISION= 2
+PORTVERSION= 0.7.3
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +14,7 @@ MAINTAINER= sem@FreeBSD.org
COMMENT= Database frontend for KDE
BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
-LIB_DEPENDS= hk_classes.6:${PORTSDIR}/databases/hk_classes
+LIB_DEPENDS= hk_classes.7:${PORTSDIR}/databases/hk_classes
USE_BZIP2= yes
USE_KDELIBS_VER= 3
diff --git a/databases/knoda/distinfo b/databases/knoda/distinfo
index 26281341f055..38a4de7e2268 100644
--- a/databases/knoda/distinfo
+++ b/databases/knoda/distinfo
@@ -1,2 +1,2 @@
-MD5 (knoda-0.7.2.tar.bz2) = a26b02ad9b7abc0a746241f09219c4eb
-SIZE (knoda-0.7.2.tar.bz2) = 803402
+MD5 (knoda-0.7.3.tar.bz2) = 035790b0ff64451cc6ed2ba71aff0c5d
+SIZE (knoda-0.7.3.tar.bz2) = 872183
diff --git a/databases/knoda/files/patch-hk_kdeclasses::hk_kdedbdesigner.cpp b/databases/knoda/files/patch-hk_kdeclasses::hk_kdedbdesigner.cpp
deleted file mode 100644
index 9d268630d6a1..000000000000
--- a/databases/knoda/files/patch-hk_kdeclasses::hk_kdedbdesigner.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- hk_kdeclasses/hk_kdedbdesigner.cpp.orig Thu Jul 15 22:18:12 2004
-+++ hk_kdeclasses/hk_kdedbdesigner.cpp Thu Jul 15 22:21:24 2004
-@@ -238,7 +238,7 @@
- QString n;
- //cerr <<"drag wert="<<index(itemAt(event->pos()))<<endl;
- n.setNum(p_datasourceframe->datasource()->presentationnumber());
-- n="<VUPN>"+n+"</VUPN>\n<VALUE>"+( itemAt(event->pos())?itemAt(event->pos())->text():"") +"</VALUE>\n";
-+ n="<VUPN>"+n+"</VUPN>\n<VALUE>"+( itemAt(event->pos())?itemAt(event->pos())->text():static_cast<QString>("")) +"</VALUE>\n";
- //cerr<<"dragwert"<<n<<endl;
- QCString cstr =n.utf8();
- //cerr<"cstr"<<cstr<<endl;
diff --git a/databases/knoda/files/patch-hk_kdeclasses::hk_kdedblistview.cpp b/databases/knoda/files/patch-hk_kdeclasses::hk_kdedblistview.cpp
deleted file mode 100644
index 452982e84792..000000000000
--- a/databases/knoda/files/patch-hk_kdeclasses::hk_kdedblistview.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- hk_kdeclasses/hk_kdedblistview.cpp.orig Thu Jul 15 23:11:07 2004
-+++ hk_kdeclasses/hk_kdedblistview.cpp Thu Jul 15 23:19:51 2004
-@@ -634,7 +634,7 @@
- if (xtype=="DATABASE"
- && !(database()->connection()&&database()->connection()->server_supports(hk_connection::SUPPORTS_NEW_DATABASE)))
- cancreate=false;
-- return (event->provides("application/x-hk_filecopy")&&event->source()!=this && cancreate);
-+ return (event->provides("application/x-hk_filecopy")&&event->source()!=(QWidget*)this && cancreate);
- }
-
-
diff --git a/databases/knoda/files/patch-hk_kdeclasses::hk_kdeqbe.cpp b/databases/knoda/files/patch-hk_kdeclasses::hk_kdeqbe.cpp
deleted file mode 100644
index 178736d5a51d..000000000000
--- a/databases/knoda/files/patch-hk_kdeclasses::hk_kdeqbe.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- hk_kdeclasses/hk_kdeqbe.cpp.orig Thu Jul 15 22:28:21 2004
-+++ hk_kdeclasses/hk_kdeqbe.cpp Thu Jul 15 23:08:55 2004
-@@ -388,7 +388,7 @@
- for (int i=0;i<p_private->p_table->numCols();++i)
- {
- if ( ((QComboTableItem*)(p_private->p_table->item(1,i)))->currentItem()>0 // field
-- || !(((QComboTableItem*)(p_private->p_table->item(1,i)))->text().isEmpty())
-+ || !(((QComboTableItem*)(p_private->p_table->item(1,i)))->currentText().isEmpty())
- )
- {
-
diff --git a/databases/knoda/pkg-plist b/databases/knoda/pkg-plist
index 398389feb001..5a3173d52290 100644
--- a/databases/knoda/pkg-plist
+++ b/databases/knoda/pkg-plist
@@ -1,4 +1,5 @@
bin/knoda
+bin/knoda-rt
include/hk_kdeboolean.h
include/hk_kdecombobox.h
include/hk_kdegrid.h
@@ -138,6 +139,7 @@ share/icons/hicolor/16x16/apps/knoda.png
share/icons/hicolor/32x32/apps/knoda.png
share/icons/locolor/16x16/apps/knoda.png
share/icons/locolor/32x32/apps/knoda.png
+share/locale/bg/LC_MESSAGES/knoda.mo
share/locale/de/LC_MESSAGES/knoda.mo
share/locale/es/LC_MESSAGES/knoda.mo
share/locale/fr/LC_MESSAGES/knoda.mo