aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-IniRegEx/Makefile23
-rw-r--r--devel/p5-Config-IniRegEx/distinfo3
-rw-r--r--devel/p5-Config-IniRegEx/pkg-descr8
-rw-r--r--devel/p5-Config-IniRegEx/pkg-plist5
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 772bd6c4020f..809a734c3b99 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1102,6 +1102,7 @@
SUBDIR += p5-Config-INI-Simple
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Config-IniHash
+ SUBDIR += p5-Config-IniRegEx
SUBDIR += p5-Config-JSON
SUBDIR += p5-Config-Model
SUBDIR += p5-Config-Objective
diff --git a/devel/p5-Config-IniRegEx/Makefile b/devel/p5-Config-IniRegEx/Makefile
new file mode 100644
index 000000000000..dc812acf7722
--- /dev/null
+++ b/devel/p5-Config-IniRegEx/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Config-IniRegEx
+# Date created: 2009-01-30
+# Whom: Murilo Opsfelder <mopsfelder@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-IniRegEx
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mopsfelder@gmail.com
+COMMENT= Ini workaround, regex search for parameters and sections
+
+RUN_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles
+
+PERL_CONFIGURE= yes
+
+MAN3= Config::IniRegEx.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-IniRegEx/distinfo b/devel/p5-Config-IniRegEx/distinfo
new file mode 100644
index 000000000000..cde4fdca8a82
--- /dev/null
+++ b/devel/p5-Config-IniRegEx/distinfo
@@ -0,0 +1,3 @@
+MD5 (Config-IniRegEx-0.01.tar.gz) = 1d943ba05eae5be9c21f6fc125b2363e
+SHA256 (Config-IniRegEx-0.01.tar.gz) = 1aae55429f59556b8e834101111981a11867dd95c41f9fa7e8f9ec7eea5328f8
+SIZE (Config-IniRegEx-0.01.tar.gz) = 4816
diff --git a/devel/p5-Config-IniRegEx/pkg-descr b/devel/p5-Config-IniRegEx/pkg-descr
new file mode 100644
index 000000000000..96ca9469d580
--- /dev/null
+++ b/devel/p5-Config-IniRegEx/pkg-descr
@@ -0,0 +1,8 @@
+Using this module it does the ini configuration file parsing,
+with an addon facility of regex kind of search. This module
+aims out doing a regex search for Sections, and Parameters
+of the Ini configuration file. It does the Perl regex matching,
+nothing external. So whoever knows the Perl basic regex can
+use this feature.
+
+WWW: http://search.cpan.org/dist/Config-IniRegEx/
diff --git a/devel/p5-Config-IniRegEx/pkg-plist b/devel/p5-Config-IniRegEx/pkg-plist
new file mode 100644
index 000000000000..84876c02d566
--- /dev/null
+++ b/devel/p5-Config-IniRegEx/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Config/IniRegEx.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/IniRegEx/.packlist
+@dirrmtry %%SITE_PERL%%/Config
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/IniRegEx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config