aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/sh-utils/Makefile40
-rw-r--r--misc/sh-utils/distinfo1
-rw-r--r--misc/sh-utils/pkg-comment1
-rw-r--r--misc/sh-utils/pkg-descr19
-rw-r--r--misc/sh-utils/pkg-plist52
6 files changed, 114 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b9d83a0dc344..fb43bfc32b9e 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -123,6 +123,7 @@
SUBDIR += screen
SUBDIR += scriptkit
SUBDIR += seizedesktop
+ SUBDIR += sh-utils
SUBDIR += sls
SUBDIR += sma
SUBDIR += snowflake
diff --git a/misc/sh-utils/Makefile b/misc/sh-utils/Makefile
new file mode 100644
index 000000000000..90e181efc059
--- /dev/null
+++ b/misc/sh-utils/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: sh-utils
+# Date created: 10 October 2000
+# Whom: Cyrille Lefevre <clefevre@citeweb.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sh-utils
+PORTVERSION= 2.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= sh-utils
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+
+Y2K= http://www.gnu.org/software/year2000.html
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --program-prefix=g
+
+USE_GMAKE= yes
+
+MAN1= gbasename.1 gchroot.1 gdate.1 gdirname.1 gecho.1 genv.1 \
+ gexpr.1 gfalse.1 ggroups.1 ghostid.1 ghostname.1 gid.1 \
+ glogname.1 gnice.1 gnohup.1 gpathchk.1 gpinky.1 gprintenv.1 \
+ gprintf.1 gpwd.1 gsleep.1 gstty.1 gsu.1 gtee.1 gtest.1 \
+ gtrue.1 gtty.1 guname.1 gusers.1 gwho.1 gwhoami.1 gyes.1
+
+do-patch:
+.if !defined(WITH_SUID)
+ @${PERL} -pi -e "s/u\+s/u\+w/g" ${WRKSRC}/src/Makefile.in
+.endif
+
+post-install:
+ install-info ${PREFIX}/info/sh-utils.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/misc/sh-utils/distinfo b/misc/sh-utils/distinfo
new file mode 100644
index 000000000000..74221cf044b6
--- /dev/null
+++ b/misc/sh-utils/distinfo
@@ -0,0 +1 @@
+MD5 (sh-utils-2.0.tar.gz) = 5e78d1d48ca563ca77e96b22406c4aaf
diff --git a/misc/sh-utils/pkg-comment b/misc/sh-utils/pkg-comment
new file mode 100644
index 000000000000..ed6c5e4dd57e
--- /dev/null
+++ b/misc/sh-utils/pkg-comment
@@ -0,0 +1 @@
+The FSF's versions of date(1), expr(1), test(1), etc.
diff --git a/misc/sh-utils/pkg-descr b/misc/sh-utils/pkg-descr
new file mode 100644
index 000000000000..f31b2d39fcf4
--- /dev/null
+++ b/misc/sh-utils/pkg-descr
@@ -0,0 +1,19 @@
+The Free Software Foundation's "sh" utilities, including "basename",
+"chroot", "date", "dirname", "echo", "env", "expr", "false",
+"groups", "hostid", "hostname", "id", "logname", "nice", "nohup",
+"pathchk", "pinky", "printenv", "printf", "pwd", "sleep", "stty",
+"su", "tee", "test", "true", "tty", "uname", "users", "who",
+"whoami", and "yes".
+
+Similar utilities to most of these exist in the FreeBSD base system,
+but many of the GNU versions have added functionality that is
+useful.
+
+Note that this port will install these utilities with a `g' prefix,
+for example gdate, gexpr, or gtest, but the texinfo documentation
+will refer to them without the `g' prefix.
+
+GNU su does not support a wheel group. This port installs it
+without the suid bit, unless you define WITH_SUID while building.
+
+Cyrille Lefevre <clefevre@citeweb.net>
diff --git a/misc/sh-utils/pkg-plist b/misc/sh-utils/pkg-plist
new file mode 100644
index 000000000000..e858e6ea1e2d
--- /dev/null
+++ b/misc/sh-utils/pkg-plist
@@ -0,0 +1,52 @@
+bin/gbasename
+bin/gdate
+bin/gdirname
+bin/gecho
+bin/genv
+bin/gexpr
+bin/gfactor
+bin/gfalse
+bin/ghostname
+bin/gid
+bin/glogname
+bin/gpathchk
+bin/gpinky
+bin/gprintenv
+bin/gprintf
+bin/gpwd
+bin/gseq
+bin/gsleep
+bin/gtee
+bin/gtest
+bin/gtrue
+bin/gtty
+bin/gusers
+bin/gwho
+bin/gwhoami
+bin/gyes
+bin/guname
+bin/gchroot
+bin/ghostid
+bin/gnice
+bin/gstty
+bin/ggroups
+bin/gnohup
+bin/gsu
+@unexec install-info --delete %D/info/sh-utils.info %D/info/dir
+info/sh-utils.info
+@exec install-info %D/info/sh-utils.info %D/info/dir
+share/locale/cs/LC_MESSAGES/sh-utils.mo
+share/locale/de/LC_MESSAGES/sh-utils.mo
+share/locale/el/LC_MESSAGES/sh-utils.mo
+share/locale/es/LC_MESSAGES/sh-utils.mo
+share/locale/fr/LC_MESSAGES/sh-utils.mo
+share/locale/it/LC_MESSAGES/sh-utils.mo
+share/locale/nl/LC_MESSAGES/sh-utils.mo
+share/locale/no/LC_MESSAGES/sh-utils.mo
+share/locale/pl/LC_MESSAGES/sh-utils.mo
+share/locale/pt/LC_MESSAGES/sh-utils.mo
+share/locale/pt_BR/LC_MESSAGES/sh-utils.mo
+share/locale/ru/LC_MESSAGES/sh-utils.mo
+share/locale/sk/LC_MESSAGES/sh-utils.mo
+share/locale/sv/LC_MESSAGES/sh-utils.mo
+share/locale/zh/LC_MESSAGES/sh-utils.mo