aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/sleuth/Makefile30
-rw-r--r--dns/sleuth/distinfo1
-rw-r--r--dns/sleuth/pkg-comment1
-rw-r--r--dns/sleuth/pkg-descr2
-rw-r--r--dns/sleuth/pkg-message2
-rw-r--r--dns/sleuth/pkg-plist2
-rw-r--r--net/Makefile1
-rw-r--r--net/sleuth/Makefile30
-rw-r--r--net/sleuth/distinfo1
-rw-r--r--net/sleuth/pkg-comment1
-rw-r--r--net/sleuth/pkg-descr2
-rw-r--r--net/sleuth/pkg-message2
-rw-r--r--net/sleuth/pkg-plist2
13 files changed, 77 insertions, 0 deletions
diff --git a/dns/sleuth/Makefile b/dns/sleuth/Makefile
new file mode 100644
index 000000000000..285126aada1f
--- /dev/null
+++ b/dns/sleuth/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: sleuth
+# Date created: Jun 15, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sleuth
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= ftp://atrey.karlin.mff.cuni.cz/pub/local/mj/net/
+
+MAINTAINER= markp@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+
+USE_PERL5= yes
+
+post-patch:
+ ${PERL} -pi -e "s|/etc/sleuth.conf|${PREFIX}/etc/sleuth.conf|g; \
+ s|#!/usr/bin/perl|#!${PERL}|g;" ${WRKSRC}/sleuth
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sleuth ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/sleuth.conf ${PREFIX}/etc/sleuth.conf.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/dns/sleuth/distinfo b/dns/sleuth/distinfo
new file mode 100644
index 000000000000..308a8908742d
--- /dev/null
+++ b/dns/sleuth/distinfo
@@ -0,0 +1 @@
+MD5 (sleuth-1.2.tar.gz) = c22522576ce3883ec3cfb9b0107b3f3a
diff --git a/dns/sleuth/pkg-comment b/dns/sleuth/pkg-comment
new file mode 100644
index 000000000000..e29ab893d150
--- /dev/null
+++ b/dns/sleuth/pkg-comment
@@ -0,0 +1 @@
+A tool for checking DNS zones
diff --git a/dns/sleuth/pkg-descr b/dns/sleuth/pkg-descr
new file mode 100644
index 000000000000..c974eaa1c6de
--- /dev/null
+++ b/dns/sleuth/pkg-descr
@@ -0,0 +1,2 @@
+Sleuth is a tool designed to check DNS zones for common errors and
+also for processing of secondary name service requests.
diff --git a/dns/sleuth/pkg-message b/dns/sleuth/pkg-message
new file mode 100644
index 000000000000..0c7ea2f4147b
--- /dev/null
+++ b/dns/sleuth/pkg-message
@@ -0,0 +1,2 @@
+Before you can run "sleuth" you will need to copy
+etc/sleuth.conf.sample to etc/sleuth.conf
diff --git a/dns/sleuth/pkg-plist b/dns/sleuth/pkg-plist
new file mode 100644
index 000000000000..bafdeaa7f05d
--- /dev/null
+++ b/dns/sleuth/pkg-plist
@@ -0,0 +1,2 @@
+bin/sleuth
+etc/sleuth.conf.sample
diff --git a/net/Makefile b/net/Makefile
index b29b9832566e..e77b8c5444c6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -335,6 +335,7 @@
SUBDIR += sendip
SUBDIR += sharity-light
SUBDIR += sing
+ SUBDIR += sleuth
SUBDIR += slirp
SUBDIR += smbfs
SUBDIR += smbtcpdump
diff --git a/net/sleuth/Makefile b/net/sleuth/Makefile
new file mode 100644
index 000000000000..285126aada1f
--- /dev/null
+++ b/net/sleuth/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: sleuth
+# Date created: Jun 15, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sleuth
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= ftp://atrey.karlin.mff.cuni.cz/pub/local/mj/net/
+
+MAINTAINER= markp@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+
+USE_PERL5= yes
+
+post-patch:
+ ${PERL} -pi -e "s|/etc/sleuth.conf|${PREFIX}/etc/sleuth.conf|g; \
+ s|#!/usr/bin/perl|#!${PERL}|g;" ${WRKSRC}/sleuth
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sleuth ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/sleuth.conf ${PREFIX}/etc/sleuth.conf.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/sleuth/distinfo b/net/sleuth/distinfo
new file mode 100644
index 000000000000..308a8908742d
--- /dev/null
+++ b/net/sleuth/distinfo
@@ -0,0 +1 @@
+MD5 (sleuth-1.2.tar.gz) = c22522576ce3883ec3cfb9b0107b3f3a
diff --git a/net/sleuth/pkg-comment b/net/sleuth/pkg-comment
new file mode 100644
index 000000000000..e29ab893d150
--- /dev/null
+++ b/net/sleuth/pkg-comment
@@ -0,0 +1 @@
+A tool for checking DNS zones
diff --git a/net/sleuth/pkg-descr b/net/sleuth/pkg-descr
new file mode 100644
index 000000000000..c974eaa1c6de
--- /dev/null
+++ b/net/sleuth/pkg-descr
@@ -0,0 +1,2 @@
+Sleuth is a tool designed to check DNS zones for common errors and
+also for processing of secondary name service requests.
diff --git a/net/sleuth/pkg-message b/net/sleuth/pkg-message
new file mode 100644
index 000000000000..0c7ea2f4147b
--- /dev/null
+++ b/net/sleuth/pkg-message
@@ -0,0 +1,2 @@
+Before you can run "sleuth" you will need to copy
+etc/sleuth.conf.sample to etc/sleuth.conf
diff --git a/net/sleuth/pkg-plist b/net/sleuth/pkg-plist
new file mode 100644
index 000000000000..bafdeaa7f05d
--- /dev/null
+++ b/net/sleuth/pkg-plist
@@ -0,0 +1,2 @@
+bin/sleuth
+etc/sleuth.conf.sample