aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/xmms-shn/Makefile3
-rw-r--r--emulators/gsnes9x/Makefile5
-rw-r--r--sysutils/gtoaster/Makefile4
-rw-r--r--x11-toolkits/libgtkeditor/Makefile11
-rw-r--r--x11-wm/icepref/Makefile2
5 files changed, 7 insertions, 18 deletions
diff --git a/audio/xmms-shn/Makefile b/audio/xmms-shn/Makefile
index 9aba0ba0d3bf..eaf99b4236a3 100644
--- a/audio/xmms-shn/Makefile
+++ b/audio/xmms-shn/Makefile
@@ -12,12 +12,11 @@ MASTER_SITES= http://sdf.lonestar.org/~jason/shn-utils/xmms-shn/source/
MAINTAINER= fenner@FreeBSD.Org
-LIB_DEPENDS= glib12.3:${PORTSDIR}/devel/glib12 \
- gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
USE_X_PREFIX= yes
+USE_GTK= yes
USE_AUTOCONF= yes
USE_GMAKE= yes
diff --git a/emulators/gsnes9x/Makefile b/emulators/gsnes9x/Makefile
index 4926b77ecf1f..f9b26206b978 100644
--- a/emulators/gsnes9x/Makefile
+++ b/emulators/gsnes9x/Makefile
@@ -13,13 +13,10 @@ DISTNAME= GSnes9x-3.0
MAINTAINER= kbyanc@posi.net
-LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
- gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- gnome.4:${PORTSDIR}/x11/gnomelibs \
- esd.2:${PORTSDIR}/audio/esound
RUN_DEPENDS= snes9x:${PORTSDIR}/emulators/snes9x
GNU_CONFIGURE= yes
+USE_GNOME= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
diff --git a/sysutils/gtoaster/Makefile b/sysutils/gtoaster/Makefile
index bb449e4d7782..ea116033b85a 100644
--- a/sysutils/gtoaster/Makefile
+++ b/sysutils/gtoaster/Makefile
@@ -14,17 +14,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= eric@osd.bsdi.com
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrecord \
mkisofs:${PORTSDIR}/sysutils/mkisofs
WRKSRC= ${WRKDIR}/gtoaster
GNU_CONFIGURE= yes
+USE_GTK= yes
USE_GMAKE= yes
-CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
-
post-install:
strip ${PREFIX}/bin/gtoaster
diff --git a/x11-toolkits/libgtkeditor/Makefile b/x11-toolkits/libgtkeditor/Makefile
index fe6d43fb9d80..7f4de9c6bf0c 100644
--- a/x11-toolkits/libgtkeditor/Makefile
+++ b/x11-toolkits/libgtkeditor/Makefile
@@ -15,20 +15,15 @@ DISTNAME= ${PORTNAME:S/lib//}-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/share/automake/install-sh:${PORTSDIR}/devel/automake
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- unicode.0:${PORTSDIR}/devel/libunicode
+LIB_DEPENDS= unicode.0:${PORTSDIR}/devel/libunicode
USE_X_PREFIX= yes
+USE_GTK= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
-CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-configure:
diff --git a/x11-wm/icepref/Makefile b/x11-wm/icepref/Makefile
index 2645fc3b59f5..7b3df03ebc25 100644
--- a/x11-wm/icepref/Makefile
+++ b/x11-wm/icepref/Makefile
@@ -12,12 +12,12 @@ MASTER_SITES= http://209.132.18.205/downloads/portfiles/
MAINTAINER= murban@tznet.com
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/GTK.py:${PORTSDIR}/x11-toolkits/py-gtk
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
USE_PYTHON= yes
+USE_GTK= yes
NO_BUILD= yes
MAN1= icepref.1
FETCH_BEFORE_ARGS= -b