aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/clang/Makefile170
-rw-r--r--devel/clang/distinfo6
-rw-r--r--devel/clang/files/patch-Makefile14
-rw-r--r--devel/clang/files/patch-tools_clang_Makefile14
-rw-r--r--devel/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h16
-rw-r--r--devel/clang/files/patch-tools_clang_lib_Analysis_PrintfFormatString.cpp26
-rw-r--r--devel/clang/files/patch-tools_clang_lib_Headers_Makefile14
-rw-r--r--devel/clang/files/patch-tools_clang_lib_Sema_SemaChecking.cpp45
-rw-r--r--devel/clang/files/patch-tools_clang_tools_scan-build_scan-build23
-rw-r--r--devel/clang/pkg-descr4
-rw-r--r--devel/clang/pkg-plist403
-rw-r--r--lang/Makefile1
-rw-r--r--lang/clang/Makefile2
15 files changed, 3 insertions, 737 deletions
diff --git a/MOVED b/MOVED
index 609bc930331f..7f6cf127c1f0 100644
--- a/MOVED
+++ b/MOVED
@@ -4633,3 +4633,4 @@ net-p2p/btpeer||2010-10-14|Has expired: Does not build with net/Sockets and is u
net-mgmt/net-snmp4||2010-10-14|Has expired: Use net-mgmt/net-snmp port instead
net/gkrellm_snmp||2010-10-14|Has expired: Depends of net-snmp4, that is deprecated also and will be removed soon.
net/Sockets-devel||2010-10-14|Has expired: Older than net/Sockets and unmaintained.
+devel/clang|lang/clang|2010-10-14|Compilers typically live in the lang category
diff --git a/devel/Makefile b/devel/Makefile
index a96f7d56aa3e..f616b212872a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -196,7 +196,6 @@
SUBDIR += cl-trivial-gray-streams-sbcl
SUBDIR += cl-uffi
SUBDIR += cl-uffi-sbcl
- SUBDIR += clang
SUBDIR += clanlib
SUBDIR += clewn
SUBDIR += clig
diff --git a/devel/clang/Makefile b/devel/clang/Makefile
deleted file mode 100644
index 8c7bcf22c614..000000000000
--- a/devel/clang/Makefile
+++ /dev/null
@@ -1,170 +0,0 @@
-# New ports collection makefile for: clang
-# Date created: 24 Oct 2009
-# Whom: Brooks Davis
-#
-# $FreeBSD$
-#
-
-PORTNAME= clang
-PORTVERSION= 2.8
-PORTREVISION= 2
-CATEGORIES= devel lang
-MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
-EXTRACT_SUFX= .tgz
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${LLVM_SOURCE}
-EXTRACT_ONLY= ${LLVM_SOURCE}
-
-MAINTAINER= brooks@FreeBSD.org
-COMMENT= C, Objective-C, and (alpha-quality) C++ compiler
-
-CONFLICTS= clang-devel-2.[0-9]* llvm-devel-2.[0-9]*
-
-CLANG_NAME= clang-${PORTVERSION}
-CLANG_SOURCE= ${CLANG_NAME}${EXTRACT_SUFX}
-LLVM_NAME= llvm-${PORTVERSION}
-LLVM_SOURCE= ${LLVM_NAME}${EXTRACT_SUFX}
-
-WRKSRC= ${WRKDIR}/${LLVM_NAME}
-BUILD_WRKSRC= ${WRKSRC}/tools/clang
-INSTALL_WRKSRC= ${WRKSRC}/tools/clang
-
-BUILD_DEPENDS+= llvm>=${PORTVERSION}:${PORTSDIR}/devel/llvm
-RUN_DEPENDS+= llvm>=${PORTVERSION}:${PORTSDIR}/devel/llvm
-.if defined(PACKAGE_BUILDING) || defined(MAINTAINER_MODE)
-BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
-.endif
-.if defined(MAINTAINER_MODE)
-BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
-.endif
-
-GNU_CONFIGURE= yes
-USE_GCC= 4.2+
-USE_GMAKE= yes
-USE_LDCONFIG= yes
-USE_PERL5= yes
-USE_PYTHON= yes
-MAKE_JOBS_SAFE= yes
-
-MAKE_ARGS= LLVMIncDir=${LOCALBASE}/include \
- LLVMToolDir=${LOCALBASE}/bin \
- LLVMLibDir=${LOCALBASE}/lib
-
-.if defined(MAINTAINER_MODE)
-CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --enable-optimized
-.endif
-
-.if defined(NOPORTDOCS)
-DOCSRCDIR=
-.else
-DOCSRCDIR= docs
-.endif
-
-MAN1= clang.1
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
-post-extract:
- cd ${WRKSRC}/tools && \
- tar xf ${DISTDIR}/${CLANG_SOURCE} && \
- ${MV} ${CLANG_NAME} clang
-
-post-patch:
- ${REINPLACE_CMD} -e 's|\(PROJ_docsdir.*:=\).*$$|\1${DOCSDIR}|g' \
- ${WRKSRC}/Makefile.config.in
- ${REINPLACE_CMD} -e 's|\(PROJ_mandir.*:=\).*$$|\1${MANPREFIX}/man|g' \
- ${WRKSRC}/Makefile.config.in
- ${REINPLACE_CMD} -e 's|%%DOCSRCDIR%%|${DOCSRCDIR}|' \
- ${WRKSRC}/Makefile ${WRKSRC}/tools/clang/Makefile
- ${REINPLACE_CMD} -e 's|/usr/bin/env perl|${PERL}|' \
- -e 's|%%DATADIR%%|${DATADIR}|' \
- ${WRKSRC}/tools/clang/tools/scan-build/ccc-analyzer \
- ${WRKSRC}/tools/clang/tools/scan-build/c++-analyzer \
- ${WRKSRC}/tools/clang/tools/scan-build/scan-build
- ${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
- ${WRKSRC}/tools/clang/tools/scan-view/scan-view
-
-pre-build:
- ${LN} -s ${LOCALBASE}/include/llvm/Intrinsics.gen ${WRKSRC}/include/llvm/
-
-.if defined(NOPORTDOCS)
-post-build:
- @cd ${WRKSRC}/tools/clang/docs/tools && ${GMAKE} clang.1
-.endif
-
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/tools/scan-build/ccc-analyzer \
- ${WRKSRC}/tools/clang/tools/scan-build/c++-analyzer \
- ${WRKSRC}/tools/clang/tools/scan-build/scan-build \
- ${WRKSRC}/tools/clang/tools/scan-view/scan-view \
- ${PREFIX}/bin
- @${MKDIR} ${PYTHONPREFIX_SITELIBDIR}
- @${MKDIR} ${PYTHONPREFIX_SITELIBDIR}/Resources
- @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/tools/scan-view/*.py \
- ${PYTHONPREFIX_SITELIBDIR}
- @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/tools/scan-view/Resources/* \
- ${PYTHONPREFIX_SITELIBDIR}/Resources
- @${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/tools/clang/tools/scan-build/scanview.css ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/tools/clang/tools/scan-build/sorttable.js ${DATADIR}
-.if defined(NOPORTDOCS)
- @${INSTALL_MAN} ${WRKSRC}/tools/clang/docs/tools/clang.1 \
- ${MANPREFIX}/man/man1/
-.else
- @${RMDIR} ${DOCSDIR}/html/img
-.endif
-
-TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check)'
-regression-test: ${BUILD_COOKIE}
- if [ `${ID} -u` = 0 ]; then \
- ${CHOWN} -R nobody ${WRKSRC}/test; \
- su -m nobody -c ${TEST_CMD}; \
- else \
- ${SH} -c ${TEST_CMD}; \
- fi
-
-PLIST_FILE_LIST= bin/ccc-analyzer \
- bin/c++-analyzer \
- bin/c-index-test \
- bin/clang \
- bin/clang++ \
- bin/scan-build \
- bin/scan-view \
- lib/libclang*
-PLIST_DIR_LIST= include/clang \
- include/clang-c \
- lib/clang
-PLIST_PYFILE_LIST= ScanView.py \
- Reporter.py \
- Resources/* \
- startfile.py
-PLIST_PYDIR_LIST= Resources
-
-build-plist:
- ${RM} -f ${PLIST}
- cd ${PREFIX} && \
- (ls ${PLIST_FILE_LIST}; ${FIND} ${PLIST_DIR_LIST} -type f) | \
- ${SORT} >> ${PLIST}
- ${FIND} ${DATADIR} ${DOCSDIR} -type f | \
- ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
- -e 's|${DOCSDIR}|%%PORTDOCS%%%%DOCSDIR%%|' | ${SORT} >> ${PLIST}
- cd ${PYTHONPREFIX_SITELIBDIR} && \
- ls ${PLIST_PYFILE_LIST} | ${SORT} | \
- ${SED} -e 's|^|%%PYTHON_SITELIBDIR%%/|' >> ${PLIST}
- cd ${PREFIX} && \
- ${FIND} ${PLIST_DIR_LIST} -type d | \
- ${SORT} -r | ${SED} -e 's|^|@dirrm |' >> ${PLIST}
- cd ${PYTHONPREFIX_SITELIBDIR} && \
- ${FIND} ${PLIST_PYDIR_LIST} -type d | ${SORT} -r | \
- ${SED} -e 's|^|@dirrm %%PYTHON_SITELIBDIR%%/|' >> ${PLIST}
- ${FIND} ${DATADIR} ${DOCSDIR} -type d | ${SORT} -r | \
- ${SED} -e 's|${DATADIR}|@dirrm %%DATADIR%%|' \
- -e 's|${DOCSDIR}|%%PORTDOCS%%@dirrm %%DOCSDIR%%|' >> ${PLIST}
-
-.include <bsd.port.post.mk>
diff --git a/devel/clang/distinfo b/devel/clang/distinfo
deleted file mode 100644
index cc5227dab937..000000000000
--- a/devel/clang/distinfo
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 (clang-2.8.tgz) = 10e14c901fc3728eecbd5b829e011b59
-SHA256 (clang-2.8.tgz) = ed83481553e6a39a8a2953e89630d881d87833506f096a90f18d93ec2bdee0c1
-SIZE (clang-2.8.tgz) = 5666777
-MD5 (llvm-2.8.tgz) = 220d361b4d17051ff4bb21c64abe05ba
-SHA256 (llvm-2.8.tgz) = 25addb742f1c6cc12877ed0ee924dda962d848368ee095be8e48342ae613d43b
-SIZE (llvm-2.8.tgz) = 9112527
diff --git a/devel/clang/files/patch-Makefile b/devel/clang/files/patch-Makefile
deleted file mode 100644
index 2c887b01275d..000000000000
--- a/devel/clang/files/patch-Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.orig
-+++ Makefile
-@@ -31,7 +31,7 @@
- OPTIONAL_DIRS :=
- else
- DIRS := lib/System lib/Support utils lib/VMCore lib tools/llvm-shlib \
-- tools/llvm-config tools runtime docs unittests
-+ tools/llvm-config tools runtime %%DOCSRCDIR%% unittests
- OPTIONAL_DIRS := projects bindings
- endif
-
diff --git a/devel/clang/files/patch-tools_clang_Makefile b/devel/clang/files/patch-tools_clang_Makefile
deleted file mode 100644
index 331b1a29c15e..000000000000
--- a/devel/clang/files/patch-tools_clang_Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- tools/clang/Makefile.orig
-+++ tools/clang/Makefile
-@@ -14,7 +14,7 @@
-
- IS_TOP_LEVEL := 1
- CLANG_LEVEL := .
--DIRS := include lib tools runtime docs
-+DIRS := include lib tools runtime %%DOCSRCDIR%%
-
- PARALLEL_DIRS :=
-
diff --git a/devel/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h b/devel/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h
deleted file mode 100644
index a460585343fe..000000000000
--- a/devel/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD: /tmp/pcvs/ports/devel/clang/files/Attic/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h,v 1.1 2010-10-08 14:00:31 brooks Exp $
-
---- tools/clang/include/clang/Analysis/Analyses/FormatString.h.orig
-+++ tools/clang/include/clang/Analysis/Analyses/FormatString.h
-@@ -139,6 +139,10 @@
- SArg,
-
- // ** Printf-specific **
-+
-+ // FreeBSD specific specifiers
-+ bArg,
-+ DArg,
-
- // Objective-C specific specifiers.
- ObjCObjArg, // '@'
diff --git a/devel/clang/files/patch-tools_clang_lib_Analysis_PrintfFormatString.cpp b/devel/clang/files/patch-tools_clang_lib_Analysis_PrintfFormatString.cpp
deleted file mode 100644
index 65308dc8da0a..000000000000
--- a/devel/clang/files/patch-tools_clang_lib_Analysis_PrintfFormatString.cpp
+++ /dev/null
@@ -1,26 +0,0 @@
-
-$FreeBSD: /tmp/pcvs/ports/devel/clang/files/Attic/patch-tools_clang_lib_Analysis_PrintfFormatString.cpp,v 1.1 2010-10-08 14:00:31 brooks Exp $
-
---- tools/clang/lib/Analysis/PrintfFormatString.cpp.orig
-+++ tools/clang/lib/Analysis/PrintfFormatString.cpp
-@@ -192,11 +192,20 @@
- case '@': k = ConversionSpecifier::ObjCObjArg; break;
- // Glibc specific.
- case 'm': k = ConversionSpecifier::PrintErrno; break;
-+ // FreeBSD format extensions
-+ case 'b': k = ConversionSpecifier::bArg; break; /* check for int and then char * */
-+ case 'r': k = ConversionSpecifier::xArg; break;
-+ case 'y': k = ConversionSpecifier::iArg; break;
-+ case 'D': k = ConversionSpecifier::DArg; break; /* check for u_char * pointer and a char * string */
-+
- }
- PrintfConversionSpecifier CS(conversionPosition, k);
- FS.setConversionSpecifier(CS);
- if (CS.consumesDataArgument() && !FS.usesPositionalArg())
- FS.setArgIndex(argIndex++);
-+ // FreeBSD extension
-+ if (k == ConversionSpecifier::bArg || k == ConversionSpecifier::DArg)
-+ argIndex++;
-
- if (k == ConversionSpecifier::InvalidSpecifier) {
- // Assume the conversion takes one argument.
diff --git a/devel/clang/files/patch-tools_clang_lib_Headers_Makefile b/devel/clang/files/patch-tools_clang_lib_Headers_Makefile
deleted file mode 100644
index 1b9dac9db5f1..000000000000
--- a/devel/clang/files/patch-tools_clang_lib_Headers_Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD: /tmp/pcvs/ports/devel/clang/files/Attic/patch-tools_clang_lib_Headers_Makefile,v 1.2 2010-10-08 14:00:31 brooks Exp $
-
---- tools/clang/lib/Headers/Makefile.orig
-+++ tools/clang/lib/Headers/Makefile
-@@ -13,7 +13,7 @@
- # FIXME: Get version from a common place.
- HeaderDir := $(PROJ_OBJ_ROOT)/$(BuildMode)/lib/clang/1.0/include
-
--HEADERS := $(notdir $(wildcard $(PROJ_SRC_DIR)/*.h))
-+HEADERS := $(notdir $(wildcard $(PROJ_SRC_DIR)/*mm*.h))
-
- OBJHEADERS := $(addprefix $(HeaderDir)/, $(HEADERS))
-
diff --git a/devel/clang/files/patch-tools_clang_lib_Sema_SemaChecking.cpp b/devel/clang/files/patch-tools_clang_lib_Sema_SemaChecking.cpp
deleted file mode 100644
index 55b6699065b6..000000000000
--- a/devel/clang/files/patch-tools_clang_lib_Sema_SemaChecking.cpp
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD: /tmp/pcvs/ports/devel/clang/files/Attic/patch-tools_clang_lib_Sema_SemaChecking.cpp,v 1.1 2010-10-08 14:00:31 brooks Exp $
-
---- tools/clang/lib/Sema/SemaChecking.cpp.orig
-+++ tools/clang/lib/Sema/SemaChecking.cpp
-@@ -1511,6 +1511,39 @@
- CoveredArgs.set(argIndex);
- }
-
-+ // FreeBSD extensions
-+ if (CS.getKind() == ConversionSpecifier::bArg || CS.getKind() == ConversionSpecifier::DArg) {
-+ // claim the second argument
-+ CoveredArgs.set(argIndex + 1);
-+
-+ // Now type check the data expression that matches the
-+ // format specifier.
-+ const Expr *Ex = getDataArg(argIndex);
-+ QualType type = (CS.getKind() == ConversionSpecifier::bArg) ? S.Context.IntTy : S.Context.getPointerType(S.Context.UnsignedCharTy);
-+ //const analyze_printf::ArgTypeResult &ATR = S.Context.IntTy;
-+ const analyze_printf::ArgTypeResult &ATR = type;
-+ if (ATR.isValid() && !ATR.matchesType(S.Context, Ex->getType()))
-+ S.Diag(getLocationOfByte(CS.getStart()),
-+ diag::warn_printf_conversion_argument_type_mismatch)
-+ << ATR.getRepresentativeType(S.Context) << Ex->getType()
-+ << getSpecifierRange(startSpecifier, specifierLen)
-+ << Ex->getSourceRange();
-+
-+ // Now type check the data expression that matches the
-+ // format specifier.
-+ Ex = getDataArg(argIndex + 1);
-+ const analyze_printf::ArgTypeResult &ATR2 = ArgTypeResult::CStrTy;
-+ if (ATR2.isValid() && !ATR2.matchesType(S.Context, Ex->getType()))
-+ S.Diag(getLocationOfByte(CS.getStart()),
-+ diag::warn_printf_conversion_argument_type_mismatch)
-+ << ATR2.getRepresentativeType(S.Context) << Ex->getType()
-+ << getSpecifierRange(startSpecifier, specifierLen)
-+ << Ex->getSourceRange();
-+
-+ return true;
-+ }
-+ // END OF FREEBSD EXTENSIONS
-+
- // Check for using an Objective-C specific conversion specifier
- // in a non-ObjC literal.
- if (!IsObjCLiteral && CS.isObjCArg()) {
diff --git a/devel/clang/files/patch-tools_clang_tools_scan-build_scan-build b/devel/clang/files/patch-tools_clang_tools_scan-build_scan-build
deleted file mode 100644
index 840571d5ec0e..000000000000
--- a/devel/clang/files/patch-tools_clang_tools_scan-build_scan-build
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD: /tmp/pcvs/ports/devel/clang/files/Attic/patch-tools_clang_tools_scan-build_scan-build,v 1.1 2010-10-08 14:00:31 brooks Exp $
-
---- tools/clang/tools/scan-build/scan-build.orig
-+++ tools/clang/tools/scan-build/scan-build
-@@ -423,7 +423,7 @@
-
- my $Dir = shift;
-
-- my $JS = Cwd::realpath("$RealBin/sorttable.js");
-+ my $JS = Cwd::realpath("%%DATADIR%%/sorttable.js");
-
- DieDiag("Cannot find 'sorttable.js'.\n")
- if (! -r $JS);
-@@ -433,7 +433,7 @@
- DieDiag("Could not copy 'sorttable.js' to '$Dir'.\n")
- if (! -r "$Dir/sorttable.js");
-
-- my $CSS = Cwd::realpath("$RealBin/scanview.css");
-+ my $CSS = Cwd::realpath("%%DATADIR%%/scanview.css");
-
- DieDiag("Cannot find 'scanview.css'.\n")
- if (! -r $CSS);
diff --git a/devel/clang/pkg-descr b/devel/clang/pkg-descr
deleted file mode 100644
index 37b1d8e486d6..000000000000
--- a/devel/clang/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-The goal of the Clang project is to create a new C, C++, Objective C and
-Objective C++ front-end for the LLVM compiler.
-
-WWW: http://clang.llvm.org/
diff --git a/devel/clang/pkg-plist b/devel/clang/pkg-plist
deleted file mode 100644
index dfc49ae6dd9e..000000000000
--- a/devel/clang/pkg-plist
+++ /dev/null
@@ -1,403 +0,0 @@
-bin/c++-analyzer
-bin/c-index-test
-bin/ccc-analyzer
-bin/clang
-bin/clang++
-bin/scan-build
-bin/scan-view
-include/clang-c/Index.h
-include/clang/AST/APValue.h
-include/clang/AST/AST.h
-include/clang/AST/ASTConsumer.h
-include/clang/AST/ASTContext.h
-include/clang/AST/ASTDiagnostic.h
-include/clang/AST/ASTImporter.h
-include/clang/AST/ASTVector.h
-include/clang/AST/Attr.h
-include/clang/AST/AttrImpl.inc
-include/clang/AST/Attrs.inc
-include/clang/AST/CXXInheritance.h
-include/clang/AST/CanonicalType.h
-include/clang/AST/CharUnits.h
-include/clang/AST/Decl.h
-include/clang/AST/DeclAccessPair.h
-include/clang/AST/DeclBase.h
-include/clang/AST/DeclCXX.h
-include/clang/AST/DeclContextInternals.h
-include/clang/AST/DeclFriend.h
-include/clang/AST/DeclGroup.h
-include/clang/AST/DeclNodes.inc
-include/clang/AST/DeclObjC.h
-include/clang/AST/DeclTemplate.h
-include/clang/AST/DeclVisitor.h
-include/clang/AST/DeclarationName.h
-include/clang/AST/DependentDiagnostic.h
-include/clang/AST/Expr.h
-include/clang/AST/ExprCXX.h
-include/clang/AST/ExprObjC.h
-include/clang/AST/ExternalASTSource.h
-include/clang/AST/FullExpr.h
-include/clang/AST/NestedNameSpecifier.h
-include/clang/AST/OperationKinds.h
-include/clang/AST/ParentMap.h
-include/clang/AST/PrettyPrinter.h
-include/clang/AST/RecordLayout.h
-include/clang/AST/RecursiveASTVisitor.h
-include/clang/AST/Redeclarable.h
-include/clang/AST/Release/AttrImpl.inc.tmp
-include/clang/AST/Release/Attrs.inc.tmp
-include/clang/AST/Release/DeclNodes.inc.tmp
-include/clang/AST/Release/StmtNodes.inc.tmp
-include/clang/AST/Stmt.h
-include/clang/AST/StmtCXX.h
-include/clang/AST/StmtGraphTraits.h
-include/clang/AST/StmtIterator.h
-include/clang/AST/StmtNodes.inc
-include/clang/AST/StmtObjC.h
-include/clang/AST/StmtVisitor.h
-include/clang/AST/TemplateBase.h
-include/clang/AST/TemplateName.h
-include/clang/AST/Type.h
-include/clang/AST/TypeLoc.h
-include/clang/AST/TypeLocBuilder.h
-include/clang/AST/TypeLocNodes.def
-include/clang/AST/TypeLocVisitor.h
-include/clang/AST/TypeNodes.def
-include/clang/AST/TypeOrdering.h
-include/clang/AST/TypeVisitor.h
-include/clang/AST/UnresolvedSet.h
-include/clang/AST/UsuallyTinyPtrVector.h
-include/clang/Analysis/Analyses/FormatString.h
-include/clang/Analysis/Analyses/LiveVariables.h
-include/clang/Analysis/Analyses/PseudoConstantAnalysis.h
-include/clang/Analysis/Analyses/ReachableCode.h
-include/clang/Analysis/Analyses/UninitializedValues.h
-include/clang/Analysis/AnalysisContext.h
-include/clang/Analysis/AnalysisDiagnostic.h
-include/clang/Analysis/CFG.h
-include/clang/Analysis/CFGStmtMap.h
-include/clang/Analysis/FlowSensitive/DataflowSolver.h
-include/clang/Analysis/FlowSensitive/DataflowValues.h
-include/clang/Analysis/ProgramPoint.h
-include/clang/Analysis/Support/BlkExprDeclBitVector.h
-include/clang/Analysis/Support/BumpVector.h
-include/clang/Analysis/Support/SaveAndRestore.h
-include/clang/Analysis/Visitors/CFGRecStmtDeclVisitor.h
-include/clang/Analysis/Visitors/CFGRecStmtVisitor.h
-include/clang/Analysis/Visitors/CFGStmtVisitor.h
-include/clang/Basic/AttrKinds.h
-include/clang/Basic/AttrList.inc
-include/clang/Basic/Builtins.def
-include/clang/Basic/Builtins.h
-include/clang/Basic/BuiltinsARM.def
-include/clang/Basic/BuiltinsPPC.def
-include/clang/Basic/BuiltinsX86.def
-include/clang/Basic/ConvertUTF.h
-include/clang/Basic/Diagnostic.h
-include/clang/Basic/DiagnosticASTKinds.inc
-include/clang/Basic/DiagnosticAnalysisKinds.inc
-include/clang/Basic/DiagnosticCommonKinds.inc
-include/clang/Basic/DiagnosticDriverKinds.inc
-include/clang/Basic/DiagnosticFrontendKinds.inc
-include/clang/Basic/DiagnosticGroups.inc
-include/clang/Basic/DiagnosticLexKinds.inc
-include/clang/Basic/DiagnosticParseKinds.inc
-include/clang/Basic/DiagnosticSemaKinds.inc
-include/clang/Basic/FileManager.h
-include/clang/Basic/IdentifierTable.h
-include/clang/Basic/LangOptions.h
-include/clang/Basic/Linkage.h
-include/clang/Basic/MacroBuilder.h
-include/clang/Basic/OnDiskHashTable.h
-include/clang/Basic/OperatorKinds.def
-include/clang/Basic/OperatorKinds.h
-include/clang/Basic/PartialDiagnostic.h
-include/clang/Basic/PrettyStackTrace.h
-include/clang/Basic/Release/AttrList.inc.tmp
-include/clang/Basic/Release/DiagnosticASTKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticAnalysisKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticCommonKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticDriverKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticFrontendKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticGroups.inc.tmp
-include/clang/Basic/Release/DiagnosticLexKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticParseKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticSemaKinds.inc.tmp
-include/clang/Basic/Release/Version.inc.tmp
-include/clang/Basic/Release/arm_neon.inc.tmp
-include/clang/Basic/SourceLocation.h
-include/clang/Basic/SourceManager.h
-include/clang/Basic/SourceManagerInternals.h
-include/clang/Basic/Specifiers.h
-include/clang/Basic/TargetBuiltins.h
-include/clang/Basic/TargetInfo.h
-include/clang/Basic/TargetOptions.h
-include/clang/Basic/TemplateKinds.h
-include/clang/Basic/TokenKinds.def
-include/clang/Basic/TokenKinds.h
-include/clang/Basic/TypeTraits.h
-include/clang/Basic/Version.h
-include/clang/Basic/Version.inc
-include/clang/Basic/arm_neon.inc
-include/clang/Checker/AnalysisConsumer.h
-include/clang/Checker/BugReporter/BugReporter.h
-include/clang/Checker/BugReporter/BugType.h
-include/clang/Checker/BugReporter/PathDiagnostic.h
-include/clang/Checker/Checkers/DereferenceChecker.h
-include/clang/Checker/Checkers/LocalCheckers.h
-include/clang/Checker/DomainSpecific/CocoaConventions.h
-include/clang/Checker/FrontendActions.h
-include/clang/Checker/ManagerRegistry.h
-include/clang/Checker/PathDiagnosticClients.h
-include/clang/Checker/PathSensitive/AnalysisManager.h
-include/clang/Checker/PathSensitive/BasicValueFactory.h
-include/clang/Checker/PathSensitive/Checker.h
-include/clang/Checker/PathSensitive/CheckerHelpers.h
-include/clang/Checker/PathSensitive/CheckerVisitor.def
-include/clang/Checker/PathSensitive/CheckerVisitor.h
-include/clang/Checker/PathSensitive/ConstraintManager.h
-include/clang/Checker/PathSensitive/Environment.h
-include/clang/Checker/PathSensitive/ExplodedGraph.h
-include/clang/Checker/PathSensitive/GRAuditor.h
-include/clang/Checker/PathSensitive/GRBlockCounter.h
-include/clang/Checker/PathSensitive/GRCoreEngine.h
-include/clang/Checker/PathSensitive/GRExprEngine.h
-include/clang/Checker/PathSensitive/GRExprEngineBuilders.h
-include/clang/Checker/PathSensitive/GRSimpleAPICheck.h
-include/clang/Checker/PathSensitive/GRState.h
-include/clang/Checker/PathSensitive/GRStateTrait.h
-include/clang/Checker/PathSensitive/GRSubEngine.h
-include/clang/Checker/PathSensitive/GRTransferFuncs.h
-include/clang/Checker/PathSensitive/GRWorkList.h
-include/clang/Checker/PathSensitive/MemRegion.h
-include/clang/Checker/PathSensitive/SVals.h
-include/clang/Checker/PathSensitive/SValuator.h
-include/clang/Checker/PathSensitive/Store.h
-include/clang/Checker/PathSensitive/SummaryManager.h
-include/clang/Checker/PathSensitive/SymbolManager.h
-include/clang/Checker/PathSensitive/ValueManager.h
-include/clang/CodeGen/BackendUtil.h
-include/clang/CodeGen/CodeGenAction.h
-include/clang/CodeGen/ModuleBuilder.h
-include/clang/Driver/Action.h
-include/clang/Driver/Arg.h
-include/clang/Driver/ArgList.h
-include/clang/Driver/CC1AsOptions.h
-include/clang/Driver/CC1AsOptions.inc
-include/clang/Driver/CC1Options.h
-include/clang/Driver/CC1Options.inc
-include/clang/Driver/Compilation.h
-include/clang/Driver/Driver.h
-include/clang/Driver/DriverDiagnostic.h
-include/clang/Driver/HostInfo.h
-include/clang/Driver/Job.h
-include/clang/Driver/OptSpecifier.h
-include/clang/Driver/OptTable.h
-include/clang/Driver/Option.h
-include/clang/Driver/Options.h
-include/clang/Driver/Options.inc
-include/clang/Driver/Phases.h
-include/clang/Driver/Release/CC1AsOptions.inc.tmp
-include/clang/Driver/Release/CC1Options.inc.tmp
-include/clang/Driver/Release/Options.inc.tmp
-include/clang/Driver/Tool.h
-include/clang/Driver/ToolChain.h
-include/clang/Driver/Types.def
-include/clang/Driver/Types.h
-include/clang/Driver/Util.h
-include/clang/Frontend/ASTConsumers.h
-include/clang/Frontend/ASTUnit.h
-include/clang/Frontend/Analyses.def
-include/clang/Frontend/AnalyzerOptions.h
-include/clang/Frontend/ChainedDiagnosticClient.h
-include/clang/Frontend/CodeGenOptions.h
-include/clang/Frontend/CommandLineSourceLoc.h
-include/clang/Frontend/CompilerInstance.h
-include/clang/Frontend/CompilerInvocation.h
-include/clang/Frontend/DeclContextXML.def
-include/clang/Frontend/DeclXML.def
-include/clang/Frontend/DependencyOutputOptions.h
-include/clang/Frontend/DiagnosticOptions.h
-include/clang/Frontend/DocumentXML.def
-include/clang/Frontend/DocumentXML.h
-include/clang/Frontend/FrontendAction.h
-include/clang/Frontend/FrontendActions.h
-include/clang/Frontend/FrontendDiagnostic.h
-include/clang/Frontend/FrontendOptions.h
-include/clang/Frontend/FrontendPluginRegistry.h
-include/clang/Frontend/HeaderSearchOptions.h
-include/clang/Frontend/LangStandard.h
-include/clang/Frontend/LangStandards.def
-include/clang/Frontend/PreprocessorOptions.h
-include/clang/Frontend/PreprocessorOutputOptions.h
-include/clang/Frontend/StmtXML.def
-include/clang/Frontend/TextDiagnosticBuffer.h
-include/clang/Frontend/TextDiagnosticPrinter.h
-include/clang/Frontend/TypeXML.def
-include/clang/Frontend/Utils.h
-include/clang/Frontend/VerifyDiagnosticsClient.h
-include/clang/FrontendTool/Utils.h
-include/clang/Index/ASTLocation.h
-include/clang/Index/Analyzer.h
-include/clang/Index/CallGraph.h
-include/clang/Index/DeclReferenceMap.h
-include/clang/Index/Entity.h
-include/clang/Index/GlobalSelector.h
-include/clang/Index/Handlers.h
-include/clang/Index/IndexProvider.h
-include/clang/Index/Indexer.h
-include/clang/Index/Program.h
-include/clang/Index/STLExtras.h
-include/clang/Index/SelectorMap.h
-include/clang/Index/TranslationUnit.h
-include/clang/Lex/CodeCompletionHandler.h
-include/clang/Lex/DirectoryLookup.h
-include/clang/Lex/ExternalPreprocessorSource.h
-include/clang/Lex/HeaderMap.h
-include/clang/Lex/HeaderSearch.h
-include/clang/Lex/LexDiagnostic.h
-include/clang/Lex/Lexer.h
-include/clang/Lex/LiteralSupport.h
-include/clang/Lex/MacroInfo.h
-include/clang/Lex/MultipleIncludeOpt.h
-include/clang/Lex/PPCallbacks.h
-include/clang/Lex/PTHLexer.h
-include/clang/Lex/PTHManager.h
-include/clang/Lex/Pragma.h
-include/clang/Lex/PreprocessingRecord.h
-include/clang/Lex/Preprocessor.h
-include/clang/Lex/PreprocessorLexer.h
-include/clang/Lex/ScratchBuffer.h
-include/clang/Lex/Token.h
-include/clang/Lex/TokenConcatenation.h
-include/clang/Lex/TokenLexer.h
-include/clang/Parse/ParseAST.h
-include/clang/Parse/ParseDiagnostic.h
-include/clang/Parse/Parser.h
-include/clang/Rewrite/ASTConsumers.h
-include/clang/Rewrite/DeltaTree.h
-include/clang/Rewrite/FixItRewriter.h
-include/clang/Rewrite/FrontendActions.h
-include/clang/Rewrite/HTMLRewrite.h
-include/clang/Rewrite/RewriteRope.h
-include/clang/Rewrite/Rewriter.h
-include/clang/Rewrite/Rewriters.h
-include/clang/Rewrite/TokenRewriter.h
-include/clang/Sema/AnalysisBasedWarnings.h
-include/clang/Sema/AttributeList.h
-include/clang/Sema/CXXFieldCollector.h
-include/clang/Sema/CodeCompleteConsumer.h
-include/clang/Sema/DeclSpec.h
-include/clang/Sema/DelayedDiagnostic.h
-include/clang/Sema/Designator.h
-include/clang/Sema/ExternalSemaSource.h
-include/clang/Sema/IdentifierResolver.h
-include/clang/Sema/Initialization.h
-include/clang/Sema/Lookup.h
-include/clang/Sema/ObjCMethodList.h
-include/clang/Sema/Overload.h
-include/clang/Sema/Ownership.h
-include/clang/Sema/ParsedTemplate.h
-include/clang/Sema/PrettyDeclStackTrace.h
-include/clang/Sema/Scope.h
-include/clang/Sema/ScopeInfo.h
-include/clang/Sema/Sema.h
-include/clang/Sema/SemaConsumer.h
-include/clang/Sema/SemaDiagnostic.h
-include/clang/Sema/SemaInternal.h
-include/clang/Sema/Template.h
-include/clang/Sema/TemplateDeduction.h
-include/clang/Serialization/ASTBitCodes.h
-include/clang/Serialization/ASTDeserializationListener.h
-include/clang/Serialization/ASTReader.h
-include/clang/Serialization/ASTWriter.h
-include/clang/Serialization/AttrPCHRead.inc
-include/clang/Serialization/AttrPCHWrite.inc
-include/clang/Serialization/Release/AttrPCHRead.inc.tmp
-include/clang/Serialization/Release/AttrPCHWrite.inc.tmp
-lib/clang/2.8/include/arm_neon.h
-lib/clang/2.8/include/emmintrin.h
-lib/clang/2.8/include/immintrin.h
-lib/clang/2.8/include/mm_malloc.h
-lib/clang/2.8/include/mmintrin.h
-lib/clang/2.8/include/nmmintrin.h
-lib/clang/2.8/include/pmmintrin.h
-lib/clang/2.8/include/smmintrin.h
-lib/clang/2.8/include/tmmintrin.h
-lib/clang/2.8/include/wmmintrin.h
-lib/clang/2.8/include/xmmintrin.h
-lib/libclang.a
-lib/libclang.so
-lib/libclangAST.a
-lib/libclangAnalysis.a
-lib/libclangBasic.a
-lib/libclangChecker.a
-lib/libclangCodeGen.a
-lib/libclangDriver.a
-lib/libclangFrontend.a
-lib/libclangFrontendTool.a
-lib/libclangIndex.a
-lib/libclangLex.a
-lib/libclangParse.a
-lib/libclangRewrite.a
-lib/libclangSema.a
-lib/libclangSerialization.a
-%%DATADIR%%/scanview.css
-%%DATADIR%%/sorttable.js
-%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
-%%PORTDOCS%%%%DOCSDIR%%/html/AnalyzerRegions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/DriverInternals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/InternalsManual.html
-%%PORTDOCS%%%%DOCSDIR%%/html/LanguageExtensions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/PCHInternals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/PTHInternals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/UsersManual.html
-%%PORTDOCS%%%%DOCSDIR%%/html/clang/clang.html
-%%PORTDOCS%%%%DOCSDIR%%/html/clang/manpage.css
-%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libIndex.html
-%%PORTDOCS%%%%DOCSDIR%%/ps/clang.ps
-%%PYTHON_SITELIBDIR%%/Reporter.py
-%%PYTHON_SITELIBDIR%%/Resources/FileRadar.scpt
-%%PYTHON_SITELIBDIR%%/Resources/GetRadarVersion.scpt
-%%PYTHON_SITELIBDIR%%/Resources/bugcatcher.ico
-%%PYTHON_SITELIBDIR%%/ScanView.py
-%%PYTHON_SITELIBDIR%%/startfile.py
-@dirrm lib/clang/2.8/include
-@dirrm lib/clang/2.8
-@dirrm lib/clang
-@dirrm include/clang/Serialization/Release
-@dirrm include/clang/Serialization
-@dirrm include/clang/Sema
-@dirrm include/clang/Rewrite
-@dirrm include/clang/Parse
-@dirrm include/clang/Lex
-@dirrm include/clang/Index
-@dirrm include/clang/FrontendTool
-@dirrm include/clang/Frontend
-@dirrm include/clang/Driver/Release
-@dirrm include/clang/Driver
-@dirrm include/clang/CodeGen
-@dirrm include/clang/Checker/PathSensitive
-@dirrm include/clang/Checker/DomainSpecific
-@dirrm include/clang/Checker/Checkers
-@dirrm include/clang/Checker/BugReporter
-@dirrm include/clang/Checker
-@dirrm include/clang/Basic/Release
-@dirrm include/clang/Basic
-@dirrm include/clang/Analysis/Visitors
-@dirrm include/clang/Analysis/Support
-@dirrm include/clang/Analysis/FlowSensitive
-@dirrm include/clang/Analysis/Analyses
-@dirrm include/clang/Analysis
-@dirrm include/clang/AST/Release
-@dirrm include/clang/AST
-@dirrm include/clang-c
-@dirrm include/clang
-@dirrm %%PYTHON_SITELIBDIR%%/Resources
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/ps
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/clang
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%
diff --git a/lang/Makefile b/lang/Makefile
index 46173feb97c6..19d2f65fef53 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -29,6 +29,7 @@
SUBDIR += chicken
SUBDIR += cim
SUBDIR += cint
+ SUBDIR += clang
SUBDIR += clips
SUBDIR += clisp
SUBDIR += clojure
diff --git a/lang/clang/Makefile b/lang/clang/Makefile
index 8c7bcf22c614..50f49b6ab3b5 100644
--- a/lang/clang/Makefile
+++ b/lang/clang/Makefile
@@ -8,7 +8,7 @@
PORTNAME= clang
PORTVERSION= 2.8
PORTREVISION= 2
-CATEGORIES= devel lang
+CATEGORIES= lang devel
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
EXTRACT_SUFX= .tgz
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \