aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/cxsc/Makefile26
-rw-r--r--math/cxsc/distinfo3
-rw-r--r--math/cxsc/files/patch-Makefile35
-rw-r--r--math/cxsc/files/patch-src::Makefile19
-rw-r--r--math/cxsc/pkg-descr18
-rw-r--r--math/cxsc/pkg-plist166
7 files changed, 0 insertions, 268 deletions
diff --git a/math/Makefile b/math/Makefile
index 52bc3549aa4d..bcbf5c9ff55d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -41,7 +41,6 @@
SUBDIR += convertall
SUBDIR += coq
SUBDIR += cvc3
- SUBDIR += cxsc
SUBDIR += dcdflib
SUBDIR += diehard
SUBDIR += dieharder
diff --git a/math/cxsc/Makefile b/math/cxsc/Makefile
deleted file mode 100644
index fffcccc3f3c9..000000000000
--- a/math/cxsc/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: cxsc
-# Date created: Aug 11, 2001
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= cxsc
-PORTVERSION= 2.0b
-PORTREVISION= 1
-CATEGORIES= math devel
-MASTER_SITES= http://www.math.uni-wuppertal.de/wrswt/xsc/cxsc/
-DISTNAME= ${PORTNAME}-2-0-beta
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= C++ class library for eXtended Scientific Computing
-
-DEPRECATED= unmaintained, does not work with current versions of GCC, needs gcc33 which fails to build
-EXPIRATION_DATE=2009-03-02
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
-USE_GCC= 3.3
-
-.include <bsd.port.mk>
diff --git a/math/cxsc/distinfo b/math/cxsc/distinfo
deleted file mode 100644
index 3ee10898dd54..000000000000
--- a/math/cxsc/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (cxsc-2-0-beta.tar.gz) = 62e425fd15d756f460b7c11b2b3bb801
-SHA256 (cxsc-2-0-beta.tar.gz) = 21a9d28539aa7848817ca5ac062e6be1fad8ba543bf3508769946712c737f6ac
-SIZE (cxsc-2-0-beta.tar.gz) = 785745
diff --git a/math/cxsc/files/patch-Makefile b/math/cxsc/files/patch-Makefile
deleted file mode 100644
index 240f1aa4d6ff..000000000000
--- a/math/cxsc/files/patch-Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
---- Makefile.orig Thu Aug 9 10:50:35 2001
-+++ Makefile Mon Mar 25 17:26:19 2002
-@@ -2,19 +2,18 @@
-
- # (un-)installation prefix
- # e.g. /usr/local/cxsc or local home directory
--export PREFIX=/home/user/cxsc
-
- #========= the following commands should work on most Unix systems ========
-
--export CC=gcc# name of the C compiler
--export CCOPTS=-Wall# optional flags to give to the C compiler
-+#export CC=gcc# name of the C compiler
-+#export CCOPTS=-Wall# optional flags to give to the C compiler
- export CCINC=-I. -I../.. -I../rts#
- # additional include path
- export CCFLAGS=$(CCINC) $(CCOPTS)#
- # extra flags to give to the C compiler
-
--export CXX=g++# name of the C++ compiler
--export CXXOPTS=-Wall -Winline# optional flags to give to the C++ compiler
-+#export CXX=g++# name of the C++ compiler
-+#export CXXOPTS=-Wall -Winline# optional flags to give to the C++ compiler
- # -O3# at the moment without optimization
- # (takes too much RAM)
- export CXXINC=-I. -I.. -Irts/ -Ifi_lib#
-@@ -29,7 +28,7 @@
- export RM=rm -f# remove files (forced)
- export RMDIR=rm -rf# remove directory
-
--export INSTALL=install -m 644# copy files
-+export INSTALL=${BSD_INSTALL_DATA}# copy files
- export STRIP=strip -g# strip executables from debug symbols
- export INSTDIR=install -d# create installation directory
-
diff --git a/math/cxsc/files/patch-src::Makefile b/math/cxsc/files/patch-src::Makefile
deleted file mode 100644
index 9f8e42258bf7..000000000000
--- a/math/cxsc/files/patch-src::Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/Makefile.orig Sat Aug 11 22:56:38 2001
-+++ src/Makefile Sat Aug 11 23:04:30 2001
-@@ -72,11 +72,11 @@
- $(INSTALL) ./libcxsc_inl.a $(PREFIX)/lib/
- # $(STRIP) $(PREFIX)/lib/libcxsc_inl.a
- # install header files
-- $(INSTDIR) $(PREFIX)/include
-- $(INSTALL) ./*.hpp ./*.inl ./*.h $(PREFIX)/include
-- $(INSTALL) rts/*.h $(PREFIX)/include
-- $(INSTALL) fi_lib/fi_lib.h $(PREFIX)/include
-- $(INSTALL) ../cxscconf.h $(PREFIX)/include
-+ $(INSTDIR) $(PREFIX)/include/cxsc
-+ $(INSTALL) ./*.hpp ./*.inl ./*.h $(PREFIX)/include/cxsc
-+ $(INSTALL) rts/*.h $(PREFIX)/include/cxsc
-+ $(INSTALL) fi_lib/fi_lib.h $(PREFIX)/include/cxsc
-+ $(INSTALL) ../cxscconf.h $(PREFIX)/include/cxsc
- # and docs
-
- uninstall:
diff --git a/math/cxsc/pkg-descr b/math/cxsc/pkg-descr
deleted file mode 100644
index eaeb5cf6533f..000000000000
--- a/math/cxsc/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-Language eXtensions for Scientific Computation provide all features
-indispensable for modern numerical software development, such as :
- - Operator concept (user-defined operators)
- - Overloading concept
- - Module concept
- - Dynamic arrays
- - Controlled rounding
- - Predefined arithmetic data types real, (extended real), complex,
- interval, complex interval, and corresponding vector and matrix types
- - Predefined arithmetic operators of highest accuracy for the arithmetic
- data types
- - Predefined elementary functions of highest accuracy for the arithmetic
- data types
- - Data type dotprecision for the exact representation of dot products
- - Library of mathematical problem-solving routines with automatic result
- verification and high accuracy
-
-WWW: http://www.math.uni-wuppertal.de/~xsc/
diff --git a/math/cxsc/pkg-plist b/math/cxsc/pkg-plist
deleted file mode 100644
index 662f5a081f08..000000000000
--- a/math/cxsc/pkg-plist
+++ /dev/null
@@ -1,166 +0,0 @@
-lib/libcxsc.a
-lib/libcxsc_inl.a
-include/cxsc/RtsFunc.h
-include/cxsc/RtsTyp.h
-include/cxsc/a_defs.h
-include/cxsc/a_fcth.h
-include/cxsc/addbody.h
-include/cxsc/b_64bt.h
-include/cxsc/b_defs.h
-include/cxsc/b_fcth.h
-include/cxsc/b_lari.h
-include/cxsc/b_lpi_.h
-include/cxsc/body.h
-include/cxsc/cdot.hpp
-include/cxsc/cdot.inl
-include/cxsc/cidot.hpp
-include/cxsc/cidot.inl
-include/cxsc/cimatrix.hpp
-include/cxsc/cimatrix.inl
-include/cxsc/cinterva.hpp
-include/cxsc/cinterva.inl
-include/cxsc/cinterval.hpp
-include/cxsc/civeccmat.hpp
-include/cxsc/civeccmat.inl
-include/cxsc/civecimat.hpp
-include/cxsc/civecimat.inl
-include/cxsc/civecrmat.hpp
-include/cxsc/civecrmat.inl
-include/cxsc/civector.hpp
-include/cxsc/civector.inl
-include/cxsc/cmatimat.hpp
-include/cxsc/cmatimat.inl
-include/cxsc/cmatrix.hpp
-include/cxsc/cmatrix.inl
-include/cxsc/compiler.h
-include/cxsc/complex.hpp
-include/cxsc/complex.inl
-include/cxsc/cvecimat.hpp
-include/cxsc/cvecimat.inl
-include/cxsc/cvecrmat.hpp
-include/cxsc/cvecrmat.inl
-include/cxsc/cvector.hpp
-include/cxsc/cvector.inl
-include/cxsc/cxscconf.h
-include/cxsc/cxscmatr.hpp
-include/cxsc/cxscvect.hpp
-include/cxsc/d_defs.h
-include/cxsc/d_fcth.h
-include/cxsc/divbody.h
-include/cxsc/divtrap.h
-include/cxsc/dot.hpp
-include/cxsc/dot_defs.hpp
-include/cxsc/e_defs.h
-include/cxsc/e_fcth.h
-include/cxsc/except.hpp
-include/cxsc/f_fcth.h
-include/cxsc/fi_lib.h
-include/cxsc/idot.hpp
-include/cxsc/idot.inl
-include/cxsc/imath.hpp
-include/cxsc/imatrix.hpp
-include/cxsc/imatrix.inl
-include/cxsc/interval.hpp
-include/cxsc/interval.inl
-include/cxsc/intmatri.hpp
-include/cxsc/intmatri.inl
-include/cxsc/intmatrix.hpp
-include/cxsc/intvecto.hpp
-include/cxsc/intvecto.inl
-include/cxsc/intvector.hpp
-include/cxsc/ioflags.hpp
-include/cxsc/iveccmat.hpp
-include/cxsc/iveccmat.inl
-include/cxsc/iveccvec.hpp
-include/cxsc/iveccvec.inl
-include/cxsc/iveclrmat.hpp
-include/cxsc/iveclrmat.inl
-include/cxsc/ivecrmat.hpp
-include/cxsc/ivecrmat.inl
-include/cxsc/ivector.hpp
-include/cxsc/ivector.inl
-include/cxsc/l_defs.h
-include/cxsc/l_fcth.h
-include/cxsc/l_imath.hpp
-include/cxsc/l_imatrix.hpp
-include/cxsc/l_interv.hpp
-include/cxsc/l_interv.inl
-include/cxsc/l_interval.hpp
-include/cxsc/l_ivector.hpp
-include/cxsc/l_real.hpp
-include/cxsc/l_rmath.hpp
-include/cxsc/l_rmath.inl
-include/cxsc/l_rmatrix.hpp
-include/cxsc/l_rvector.hpp
-include/cxsc/limatrix.hpp
-include/cxsc/limatrix.inl
-include/cxsc/livecimat.hpp
-include/cxsc/livecimat.inl
-include/cxsc/liveclrmat.hpp
-include/cxsc/liveclrmat.inl
-include/cxsc/livecrmat.hpp
-include/cxsc/livecrmat.inl
-include/cxsc/livector.hpp
-include/cxsc/livector.inl
-include/cxsc/lrmatimat.hpp
-include/cxsc/lrmatimat.inl
-include/cxsc/lrmatrix.hpp
-include/cxsc/lrmatrix.inl
-include/cxsc/lrvecimat.hpp
-include/cxsc/lrvecimat.inl
-include/cxsc/lrvecivec.hpp
-include/cxsc/lrvecivec.inl
-include/cxsc/lrvecrmat.hpp
-include/cxsc/lrvecrmat.inl
-include/cxsc/lrvector.hpp
-include/cxsc/lrvector.inl
-include/cxsc/matrix.hpp
-include/cxsc/matrix.inl
-include/cxsc/mulbody.h
-include/cxsc/o_defs.h
-include/cxsc/o_fcth.h
-include/cxsc/o_msg1.h
-include/cxsc/o_name.h
-include/cxsc/o_revs.h
-include/cxsc/o_slct.h
-include/cxsc/o_spec.h
-include/cxsc/o_syst.h
-include/cxsc/o_type.h
-include/cxsc/p88rts.h
-include/cxsc/r_defs.h
-include/cxsc/r_fcth.h
-include/cxsc/real.hpp
-include/cxsc/real.inl
-include/cxsc/rmath.hpp
-include/cxsc/rmath.inl
-include/cxsc/rmatrix.hpp
-include/cxsc/rmatrix.inl
-include/cxsc/rts_real.hpp
-include/cxsc/rtsrmath.h
-include/cxsc/rvector.hpp
-include/cxsc/rvector.inl
-include/cxsc/s_fcth.h
-include/cxsc/subbody.h
-include/cxsc/t_cnst.h
-include/cxsc/t_cond.h
-include/cxsc/t_ddev.h
-include/cxsc/t_defs.h
-include/cxsc/t_drea.h
-include/cxsc/t_exc_.h
-include/cxsc/t_fcth.h
-include/cxsc/t_ieee.h
-include/cxsc/t_mach.h
-include/cxsc/t_name.h
-include/cxsc/test.hpp
-include/cxsc/testclss.hpp
-include/cxsc/testcomp.hpp
-include/cxsc/testdot.hpp
-include/cxsc/testintv.hpp
-include/cxsc/testmatr.hpp
-include/cxsc/testsklr.hpp
-include/cxsc/testvect.hpp
-include/cxsc/vector.hpp
-include/cxsc/vector.inl
-include/cxsc/xscclass.hpp
-include/cxsc/y_fcth.h
-@dirrm include/cxsc