aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/lpe/Makefile1
-rw-r--r--editors/lpe/files/patch-src_cfg-core.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/editors/lpe/Makefile b/editors/lpe/Makefile
index a3df76961336..338057ef4b4b 100644
--- a/editors/lpe/Makefile
+++ b/editors/lpe/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lpe
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://cdsmith.twu.net/opensource/lpe/
diff --git a/editors/lpe/files/patch-src_cfg-core.c b/editors/lpe/files/patch-src_cfg-core.c
new file mode 100644
index 000000000000..f8c556701519
--- /dev/null
+++ b/editors/lpe/files/patch-src_cfg-core.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/cfg-core.c 2001/04/08 15:27:13 1.1
++++ src/cfg-core.c 2001/04/08 15:27:39
+@@ -62,7 +62,7 @@
+ /*
+ * We search for "\n[name]=" in the lookup table...
+ */
+- t_sstring = (char *) malloc (strlen (name) + 5);
++ t_sstring = (char *) alloca (strlen (name) + 5);
+ sprintf (t_sstring, "\n%s=", name);
+ if ((t_hentry = strstr (LpeOptionHash, t_sstring)) != NULL)
+ {