aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/cook/Makefile13
-rw-r--r--devel/cook/pkg-plist10
2 files changed, 15 insertions, 8 deletions
diff --git a/devel/cook/Makefile b/devel/cook/Makefile
index acec6addbb82..5d5447bdc4d8 100644
--- a/devel/cook/Makefile
+++ b/devel/cook/Makefile
@@ -18,20 +18,17 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-MAN1= c_incl.1 cook.1 cook_bom.1 cook_lic.1 cook_rsh.1 cookfp.1 cooktime.1 \
- find_libs.1 make2cook.1 roffpp.1
-MANCOMPRESSED= no
-USES= gettext
+USES= gettext perl5
+DESTDIRNAME= RPM_BUILD_ROOT
# Make sure that the whole directory tree exists.
-NO_STAGE= yes
pre-install:
- ${MKDIR} ${PREFIX}/share/cook/en/man1
- ${MKDIR} ${PREFIX}/lib/cook/en/LC_MESSAGES
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cook/en/man1
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/cook/en/LC_MESSAGES
# cook installs extra copies of the manpages in a directory that MANLANG can't
# cope with. Delete the extra copies.
post-install:
- @${RM} -rf ${PREFIX}/share/cook/en/man1
+ @${RM} -rf ${STAGEDIR}${PREFIX}/share/cook/en/man1
.include <bsd.port.mk>
diff --git a/devel/cook/pkg-plist b/devel/cook/pkg-plist
index df9688786cdf..b40ac8efa83f 100644
--- a/devel/cook/pkg-plist
+++ b/devel/cook/pkg-plist
@@ -16,6 +16,16 @@ lib/cook/en/LC_MESSAGES/file_check.mo
lib/cook/en/LC_MESSAGES/find_libs.mo
lib/cook/en/LC_MESSAGES/make2cook.mo
lib/cook/en/LC_MESSAGES/roffpp.mo
+man/man1/c_incl.1.gz
+man/man1/cook.1.gz
+man/man1/cook_bom.1.gz
+man/man1/cook_lic.1.gz
+man/man1/cook_rsh.1.gz
+man/man1/cookfp.1.gz
+man/man1/cooktime.1.gz
+man/man1/find_libs.1.gz
+man/man1/make2cook.1.gz
+man/man1/roffpp.1.gz
share/cook/as
share/cook/bison
share/cook/c