aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/lookupd/Makefile4
-rw-r--r--sysutils/runit/Makefile8
2 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/lookupd/Makefile b/sysutils/lookupd/Makefile
index b7a11b490eb8..099b669d4747 100644
--- a/sysutils/lookupd/Makefile
+++ b/sysutils/lookupd/Makefile
@@ -31,4 +31,8 @@ post-install:
CFLAGS+= -fPIC
.endif
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.include <bsd.port.post.mk>
diff --git a/sysutils/runit/Makefile b/sysutils/runit/Makefile
index 5090c7231ff8..6b56367a0f12 100644
--- a/sysutils/runit/Makefile
+++ b/sysutils/runit/Makefile
@@ -27,6 +27,12 @@ DOCS= package/CHANGES package/COPYING package/README \
CONFIG= etc/freebsd/1 etc/2 etc/freebsd/3 etc/freebsd/ctrlaltdel \
etc/freebsd/getty-ttyv4/run etc/freebsd/getty-ttyv4/finish
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
do-configure:
${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/conf-cc
@@ -52,4 +58,4 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>