aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/pear-Auth_RADIUS/Makefile10
-rw-r--r--net/pear-File_Bittorrent2/Makefile9
-rw-r--r--net/pear-Net_CDDB/Makefile7
-rw-r--r--net/pear-Net_CheckIP/Makefile9
-rw-r--r--net/pear-Net_DIME/Makefile9
-rw-r--r--net/pear-Net_DNSBL/Makefile7
-rw-r--r--net/pear-Net_Dict/Makefile6
-rw-r--r--net/pear-Net_Finger/Makefile6
-rw-r--r--net/pear-Net_Geo/Makefile12
-rw-r--r--net/pear-Net_GeoIP/Makefile12
-rw-r--r--net/pear-Net_IDNA/Makefile9
-rw-r--r--net/pear-Net_IPv4/Makefile9
-rw-r--r--net/pear-Net_IPv6/Makefile8
-rw-r--r--net/pear-Net_Ident/Makefile9
-rw-r--r--net/pear-Net_LDAP/Makefile9
-rw-r--r--net/pear-Net_LDAP2/Makefile10
-rw-r--r--net/pear-Net_MAC/Makefile9
-rw-r--r--net/pear-Net_NNTP/Makefile6
-rw-r--r--net/pear-Net_Nmap/Makefile6
-rw-r--r--net/pear-Net_POP3/Makefile8
-rw-r--r--net/pear-Net_Ping/Makefile9
-rw-r--r--net/pear-Net_SMS/Makefile6
-rw-r--r--net/pear-Net_SMTP/Makefile14
-rw-r--r--net/pear-Net_Server/Makefile10
-rw-r--r--net/pear-Net_Sieve/Makefile6
-rw-r--r--net/pear-Net_Socket/Makefile9
-rw-r--r--net/pear-Net_Traceroute/Makefile9
-rw-r--r--net/pear-Net_URL/Makefile9
-rw-r--r--net/pear-Net_URL2/Makefile9
-rw-r--r--net/pear-Net_URL_Mapper/Makefile9
-rw-r--r--net/pear-Net_UserAgent_Detect/Makefile9
-rw-r--r--net/pear-Net_UserAgent_Mobile/Makefile9
-rw-r--r--net/pear-Net_Vpopmaild/Makefile6
-rw-r--r--net/pear-Net_Whois/Makefile10
-rw-r--r--net/pear-SOAP/Makefile28
-rw-r--r--net/pear-Services_Pingback/Makefile9
-rw-r--r--net/pear-Services_Twitter/Makefile13
-rw-r--r--net/pear-URI_Template/Makefile9
-rw-r--r--net/pear-XML_RPC/Makefile9
-rw-r--r--net/pear-XML_RPC2/Makefile12
40 files changed, 99 insertions, 275 deletions
diff --git a/net/pear-Auth_RADIUS/Makefile b/net/pear-Auth_RADIUS/Makefile
index ad3f7804269c..394e5d989b20 100644
--- a/net/pear-Auth_RADIUS/Makefile
+++ b/net/pear-Auth_RADIUS/Makefile
@@ -8,13 +8,7 @@ CATEGORIES= net security pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR wrapper classes for the RADIUS PECL
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
USE_PHP= radius
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-File_Bittorrent2/Makefile b/net/pear-File_Bittorrent2/Makefile
index 8dc2300564ee..9c72b3678540 100644
--- a/net/pear-File_Bittorrent2/Makefile
+++ b/net/pear-File_Bittorrent2/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Decode and Encode data in Bittorrent format
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_CDDB/Makefile b/net/pear-Net_CDDB/Makefile
index f1d86138cef7..a4fd58fff9ef 100644
--- a/net/pear-Net_CDDB/Makefile
+++ b/net/pear-Net_CDDB/Makefile
@@ -15,9 +15,6 @@ RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request \
${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-USES= dos2unix
-PEAR_AUTOINSTALL= yes
+USES= dos2unix pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_CheckIP/Makefile b/net/pear-Net_CheckIP/Makefile
index 5d066f8002bd..1ac3b654ffeb 100644
--- a/net/pear-Net_CheckIP/Makefile
+++ b/net/pear-Net_CheckIP/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Check the syntax of IPv4 addresses
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_DIME/Makefile b/net/pear-Net_DIME/Makefile
index fde70119cc9f..9420bd6b52e6 100644
--- a/net/pear-Net_DIME/Makefile
+++ b/net/pear-Net_DIME/Makefile
@@ -9,11 +9,6 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= The PEAR::Net_DIME class implements DIME encoding
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_DNSBL/Makefile b/net/pear-Net_DNSBL/Makefile
index 5489921040ca..ae2912c91274 100644
--- a/net/pear-Net_DNSBL/Makefile
+++ b/net/pear-Net_DNSBL/Makefile
@@ -18,11 +18,8 @@ RUN_DEPENDS:= ${PEARDIR}/Cache/Lite.php:${PORTSDIR}/sysutils/pear-Cache_Lite \
${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
USE_PHP= yes
-
-PEAR_AUTOINSTALL= yes
+USES= pear
PORTSCOUT= skipv:1.3.0a1
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Dict/Makefile b/net/pear-Net_Dict/Makefile
index 5598d7505616..ac79e0c24ffb 100644
--- a/net/pear-Net_Dict/Makefile
+++ b/net/pear-Net_Dict/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Finger/Makefile b/net/pear-Net_Finger/Makefile
index c74cc1136969..a2108d8ff13b 100644
--- a/net/pear-Net_Finger/Makefile
+++ b/net/pear-Net_Finger/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR class that provides a tool for querying finger servers
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Geo/Makefile b/net/pear-Net_Geo/Makefile
index 91cd8493e276..b6dd5a26e57d 100644
--- a/net/pear-Net_Geo/Makefile
+++ b/net/pear-Net_Geo/Makefile
@@ -8,15 +8,11 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Geographical locations based on Internet address
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache \
+BUILD_DEPENDS= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache \
+RUN_DEPENDS= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_GeoIP/Makefile b/net/pear-Net_GeoIP/Makefile
index e6cf854b2d53..001fa80e44b3 100644
--- a/net/pear-Net_GeoIP/Makefile
+++ b/net/pear-Net_GeoIP/Makefile
@@ -10,15 +10,11 @@ DISTNAME= Net_GeoIP-1.0.0RC1
MAINTAINER= miwi@FreeBSD.org
COMMENT= Library to perform geo-location lookups of IP addresses
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache \
+BUILD_DEPENDS= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache \
+RUN_DEPENDS= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_IDNA/Makefile b/net/pear-Net_IDNA/Makefile
index ea4dcb11b6f2..4ae3b710b154 100644
--- a/net/pear-Net_IDNA/Makefile
+++ b/net/pear-Net_IDNA/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Pear Punycode encoding and decoding package
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_IPv4/Makefile b/net/pear-Net_IPv4/Makefile
index 3884263f8096..914e31fb9e48 100644
--- a/net/pear-Net_IPv4/Makefile
+++ b/net/pear-Net_IPv4/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= IPv4 network calculations and validation
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_IPv6/Makefile b/net/pear-Net_IPv6/Makefile
index 40d64ba2d908..93cdee0d9e83 100644
--- a/net/pear-Net_IPv6/Makefile
+++ b/net/pear-Net_IPv6/Makefile
@@ -8,12 +8,8 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Check and validate IPv6 addresses
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
PORTSCOUT= skipv:1.2.2b,1.2.2b2
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Ident/Makefile b/net/pear-Net_Ident/Makefile
index bd3c9c23ed76..edf4c71981f8 100644
--- a/net/pear-Net_Ident/Makefile
+++ b/net/pear-Net_Ident/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR identification protocol implementation
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_LDAP/Makefile b/net/pear-Net_LDAP/Makefile
index 8f72c45618b8..de61d02fad53 100644
--- a/net/pear-Net_LDAP/Makefile
+++ b/net/pear-Net_LDAP/Makefile
@@ -9,11 +9,6 @@ CATEGORIES= net pear
MAINTAINER= ports@FreeBSD.org
COMMENT= OO interface for searching and manipulating LDAP-entries
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_LDAP2/Makefile b/net/pear-Net_LDAP2/Makefile
index 98453c3ac409..d1d3b6106a25 100644
--- a/net/pear-Net_LDAP2/Makefile
+++ b/net/pear-Net_LDAP2/Makefile
@@ -9,13 +9,7 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= OO interface for searching and manipulating LDAP-entries
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
+USES= pear
USE_PHP= ldap
-PEAR_AUTOINSTALL=yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_MAC/Makefile b/net/pear-Net_MAC/Makefile
index 85ab4d607d90..72e48877d0fd 100644
--- a/net/pear-Net_MAC/Makefile
+++ b/net/pear-Net_MAC/Makefile
@@ -9,11 +9,6 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class that validates and formats MAC addresses
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_NNTP/Makefile b/net/pear-Net_NNTP/Makefile
index 3136466f7ab5..7c232c4861f7 100644
--- a/net/pear-Net_NNTP/Makefile
+++ b/net/pear-Net_NNTP/Makefile
@@ -12,8 +12,6 @@ COMMENT= PEAR implementation of the NNTP protocol
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Nmap/Makefile b/net/pear-Net_Nmap/Makefile
index e23eedf435d9..a9ae96620740 100644
--- a/net/pear-Net_Nmap/Makefile
+++ b/net/pear-Net_Nmap/Makefile
@@ -13,8 +13,6 @@ LICENSE= LGPL3
BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
RUN_DEPENDS:= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_POP3/Makefile b/net/pear-Net_POP3/Makefile
index 60b3e213f99e..02e29f08e2df 100644
--- a/net/pear-Net_POP3/Makefile
+++ b/net/pear-Net_POP3/Makefile
@@ -9,10 +9,8 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= Provides a POP3 class to access POP3 server
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Ping/Makefile b/net/pear-Net_Ping/Makefile
index ca546ce247ae..f2ee33dfed1b 100644
--- a/net/pear-Net_Ping/Makefile
+++ b/net/pear-Net_Ping/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net pear
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR class to execute ping
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_SMS/Makefile b/net/pear-Net_SMS/Makefile
index 260ede8b4744..2cef66aa0559 100644
--- a/net/pear-Net_SMS/Makefile
+++ b/net/pear-Net_SMS/Makefile
@@ -14,8 +14,6 @@ RUN_DEPENDS= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
USE_PHP= gettext
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_SMTP/Makefile b/net/pear-Net_SMTP/Makefile
index 81d4b7f93814..4f7b78684a15 100644
--- a/net/pear-Net_SMTP/Makefile
+++ b/net/pear-Net_SMTP/Makefile
@@ -9,19 +9,13 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class that provides an implementation of the SMTP protocol
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+
+USES= pear
-LATEST_LINK= pear-Net_SMTP
OPTIONS_DEFINE= PEAR_AUTH_SASL
PEAR_AUTH_SASL_DESC= PEAR::Auth_SASL support
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPEAR_AUTH_SASL}
-BUILD_DEPENDS+= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
-.endif
+PEAR_AUTH_SASL_BUILD_DEPENDS= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/net/pear-Net_Server/Makefile b/net/pear-Net_Server/Makefile
index 8e9007c826f7..ff8aa7cd2de3 100644
--- a/net/pear-Net_Server/Makefile
+++ b/net/pear-Net_Server/Makefile
@@ -8,13 +8,7 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Generic server class
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
+USES= pear
USE_PHP= sockets pcntl
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Sieve/Makefile b/net/pear-Net_Sieve/Makefile
index 137a5b3b1b7e..59531dd5b937 100644
--- a/net/pear-Net_Sieve/Makefile
+++ b/net/pear-Net_Sieve/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR class to handle talking to timsieved
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Socket/Makefile b/net/pear-Net_Socket/Makefile
index 77f6c47612e9..deb3200840c9 100644
--- a/net/pear-Net_Socket/Makefile
+++ b/net/pear-Net_Socket/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR Network Socket Interface
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Traceroute/Makefile b/net/pear-Net_Traceroute/Makefile
index da5e6c58f021..49eed70b69e4 100644
--- a/net/pear-Net_Traceroute/Makefile
+++ b/net/pear-Net_Traceroute/Makefile
@@ -8,11 +8,8 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class to execute traceroute
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-PEAR_AUTOINSTALL= yes
+USES= pear
+
+.include <bsd.port.mk>
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
diff --git a/net/pear-Net_URL/Makefile b/net/pear-Net_URL/Makefile
index 17c0716462fa..8a393b9bc03c 100644
--- a/net/pear-Net_URL/Makefile
+++ b/net/pear-Net_URL/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Easy parsing of URLs
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_URL2/Makefile b/net/pear-Net_URL2/Makefile
index ce82d53a77a0..b1b99f2e7880 100644
--- a/net/pear-Net_URL2/Makefile
+++ b/net/pear-Net_URL2/Makefile
@@ -10,11 +10,6 @@ COMMENT= PEAR Class for parsing and handling URL
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL=yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_URL_Mapper/Makefile b/net/pear-Net_URL_Mapper/Makefile
index d5fdda964d61..421ce7b96381 100644
--- a/net/pear-Net_URL_Mapper/Makefile
+++ b/net/pear-Net_URL_Mapper/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Simple and flexible way to build nice URLs for web applications
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_UserAgent_Detect/Makefile b/net/pear-Net_UserAgent_Detect/Makefile
index 837ec9e47d25..59f488242f6c 100644
--- a/net/pear-Net_UserAgent_Detect/Makefile
+++ b/net/pear-Net_UserAgent_Detect/Makefile
@@ -11,11 +11,6 @@ COMMENT= PEAR class that determines the Web browser, version, and platform
LICENSE= BSD
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_UserAgent_Mobile/Makefile b/net/pear-Net_UserAgent_Mobile/Makefile
index 85743212af94..a362c11817fd 100644
--- a/net/pear-Net_UserAgent_Mobile/Makefile
+++ b/net/pear-Net_UserAgent_Mobile/Makefile
@@ -9,12 +9,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}RC1
MAINTAINER= smatsui@karashi.org
COMMENT= PEAR class that parses HTTP mobile user agent string
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
USE_PHP= pcre
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Vpopmaild/Makefile b/net/pear-Net_Vpopmaild/Makefile
index 0034d2f26f86..f6240c2b6d6d 100644
--- a/net/pear-Net_Vpopmaild/Makefile
+++ b/net/pear-Net_Vpopmaild/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Net_Whois/Makefile b/net/pear-Net_Whois/Makefile
index dd997306bb12..6bd4797db675 100644
--- a/net/pear-Net_Whois/Makefile
+++ b/net/pear-Net_Whois/Makefile
@@ -8,12 +8,8 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Tool to query internet domain name services
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+USES= pear
-PEAR_AUTOINSTALL= yes
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
index fa99987fb872..ee068c72ac3f 100644
--- a/net/pear-SOAP/Makefile
+++ b/net/pear-SOAP/Makefile
@@ -8,32 +8,18 @@ CATEGORIES= net www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR SOAP Client/Server for PHP
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+
+USES= pear
-LATEST_LINK= pear-SOAP
OPTIONS_DEFINE= PEAR_MAIL PEAR_MAIL_MIME PEAR_NET_DIME
PEAR_MAIL_DESC= PEAR::Mail support
PEAR_MAIL_MIME_DESC= PEAR::Mail::Mime support
PEAR_NET_DIME_DESC= PEAR::Net::DIME support
-PEAR_AUTOINSTALL=yes
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPEAR_MAIL}
-BUILD_DEPENDS+= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MAIL_MIME}
-BUILD_DEPENDS+= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_NET_DIME}
-BUILD_DEPENDS+= ${PEARDIR}/Net/DIME.php:${PORTSDIR}/net/pear-Net_DIME
-.endif
+PEAR_MAIL_BUILD_DEPENDS= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail
+PEAR_MAIL_MIME_BUILD_DEPENDS= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
+PEAR_NET_DIME_BUILD_DEPENDS= ${PEARDIR}/Net/DIME.php:${PORTSDIR}/net/pear-Net_DIME
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/net/pear-Services_Pingback/Makefile b/net/pear-Services_Pingback/Makefile
index 7d46a82f454a..2156b6414052 100644
--- a/net/pear-Services_Pingback/Makefile
+++ b/net/pear-Services_Pingback/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Pingback user-agent class
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-Services_Twitter/Makefile b/net/pear-Services_Twitter/Makefile
index 624056947a04..d421af5f7bac 100644
--- a/net/pear-Services_Twitter/Makefile
+++ b/net/pear-Services_Twitter/Makefile
@@ -8,14 +8,11 @@ CATEGORIES= net www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to Twitter's API
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
USE_PHP= json simplexml mbstring
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+USES= pear
+
+.include <bsd.port.mk>
diff --git a/net/pear-URI_Template/Makefile b/net/pear-URI_Template/Makefile
index bfa7534d116b..4fef40c77bd8 100644
--- a/net/pear-URI_Template/Makefile
+++ b/net/pear-URI_Template/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= net pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Parser for URI Templates
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-XML_RPC/Makefile b/net/pear-XML_RPC/Makefile
index 7906e059af68..116f37b0b069 100644
--- a/net/pear-XML_RPC/Makefile
+++ b/net/pear-XML_RPC/Makefile
@@ -8,12 +8,7 @@ CATEGORIES= net devel pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP implementation of the XML-RPC protocol
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
USE_PHP= xml
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-XML_RPC2/Makefile b/net/pear-XML_RPC2/Makefile
index b40c23662554..27005dc546c6 100644
--- a/net/pear-XML_RPC2/Makefile
+++ b/net/pear-XML_RPC2/Makefile
@@ -10,16 +10,12 @@ COMMENT= XML-RPC client/server library
LICENSE= PHP301
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Cache/Lite.php:${PORTSDIR}/sysutils/pear-Cache_Lite \
+BUILD_DEPENDS= ${PEARDIR}/Cache/Lite.php:${PORTSDIR}/sysutils/pear-Cache_Lite \
${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Cache/Lite.php:${PORTSDIR}/sysutils/pear-Cache_Lite \
+RUN_DEPENDS= ${PEARDIR}/Cache/Lite.php:${PORTSDIR}/sysutils/pear-Cache_Lite \
${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
-PEAR_AUTOINSTALL= yes
USE_PHP= curl
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>