aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/arm-rtems-binutils/Makefile4
-rw-r--r--devel/arm-rtems-g77/Makefile2
-rw-r--r--devel/arm-rtems-gcc/Makefile3
-rw-r--r--devel/arm-rtems-objc/Makefile4
-rw-r--r--devel/i386-rtems-binutils/Makefile11
-rw-r--r--devel/i386-rtems-g77/Makefile3
-rw-r--r--devel/i386-rtems-gcc/Makefile13
-rw-r--r--devel/i386-rtems-objc/Makefile3
-rw-r--r--devel/i960-rtems-binutils/Makefile4
-rw-r--r--devel/i960-rtems-gcc/Makefile3
-rw-r--r--devel/m68k-rtems-binutils/Makefile4
-rw-r--r--devel/m68k-rtems-g77/Makefile2
-rw-r--r--devel/m68k-rtems-gcc/Makefile3
-rw-r--r--devel/m68k-rtems-objc/Makefile4
-rw-r--r--devel/mips-rtems-binutils/Makefile4
-rw-r--r--devel/mips-rtems-g77/Makefile2
-rw-r--r--devel/mips-rtems-gcc/Makefile3
-rw-r--r--devel/mips-rtems-objc/Makefile4
-rw-r--r--devel/powerpc-rtems-binutils/Makefile4
-rw-r--r--devel/powerpc-rtems-g77/Makefile2
-rw-r--r--devel/powerpc-rtems-gcc/Makefile3
-rw-r--r--devel/powerpc-rtems-objc/Makefile4
-rw-r--r--devel/sh-rtems-binutils/Makefile4
-rw-r--r--devel/sh-rtems-g77/Makefile2
-rw-r--r--devel/sh-rtems-gcc/Makefile3
-rw-r--r--devel/sh-rtems-objc/Makefile4
-rw-r--r--devel/sparc-rtems-binutils/Makefile4
-rw-r--r--devel/sparc-rtems-g77/Makefile2
-rw-r--r--devel/sparc-rtems-gcc/Makefile3
-rw-r--r--devel/sparc-rtems-objc/Makefile4
30 files changed, 78 insertions, 37 deletions
diff --git a/devel/arm-rtems-binutils/Makefile b/devel/arm-rtems-binutils/Makefile
index 665703ebfddc..c86e3b723a90 100644
--- a/devel/arm-rtems-binutils/Makefile
+++ b/devel/arm-rtems-binutils/Makefile
@@ -10,4 +10,6 @@ PORTNAME= binutils
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= arm-rtems
-.include "${.CURDIR}/../i386-rtems-binutils/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-binutils
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/arm-rtems-g77/Makefile b/devel/arm-rtems-g77/Makefile
index 4c3699361f1e..ef55edbdf5aa 100644
--- a/devel/arm-rtems-g77/Makefile
+++ b/devel/arm-rtems-g77/Makefile
@@ -10,4 +10,6 @@ PORTNAME= g77
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= arm-rtems
+
.include "${.CURDIR}/../i386-rtems-g77/Makefile"
+MASTERDIR= ${MASTERDIR}/i386-rtems-g77
diff --git a/devel/arm-rtems-gcc/Makefile b/devel/arm-rtems-gcc/Makefile
index 5f5b747bfd2d..91ba262921ee 100644
--- a/devel/arm-rtems-gcc/Makefile
+++ b/devel/arm-rtems-gcc/Makefile
@@ -11,4 +11,5 @@ MAINTAINER= jeh@FreeBSD.org
RTEMS_ARCH= arm
-.include "${.CURDIR}/../i386-rtems-gcc/Makefile"
+MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/arm-rtems-objc/Makefile b/devel/arm-rtems-objc/Makefile
index fb65c52d0792..719bd6b11013 100644
--- a/devel/arm-rtems-objc/Makefile
+++ b/devel/arm-rtems-objc/Makefile
@@ -10,4 +10,6 @@ PORTNAME= objc
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= arm-rtems
-.include "${.CURDIR}/../i386-rtems-objc/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-objc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/i386-rtems-binutils/Makefile b/devel/i386-rtems-binutils/Makefile
index 0fb5a93ad80b..f96fc326f259 100644
--- a/devel/i386-rtems-binutils/Makefile
+++ b/devel/i386-rtems-binutils/Makefile
@@ -7,7 +7,7 @@
PORTNAME= binutils
PORTVERSION= 2.13.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
@@ -21,7 +21,6 @@ COMMENT= FSF binutils-2.13.2.1 base-port for RTEMS development
LCLTARGET?= i386-rtems
BINNAME= binutils-2.13.2.1
-MASTERDIR= ${.CURDIR}/../i386-rtems-binutils
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
PKGNAMEPREFIX= ${LCLTARGET}-
@@ -51,25 +50,25 @@ INFO= ${LCLTARGET}-as ${LCLTARGET}-bfd ${LCLTARGET}-binutils \
post-patch:
@${REINPLACE_CMD} -e 's|setfilename as.info|setfilename ${LCLTARGET}-as.info|' ${WRKSRC}/gas/doc/as.texinfo
- @${REINPLACE_CMD} -e 's|(as)|(${LCLTARGET}-as)|' ${WRKSRC}/gas/doc/as.texinfo
+ @${REINPLACE_CMD} -e 's|(as)|(${LCLTARGET}-as)|' ${WRKSRC}/gas/doc/as.texinfo
@${REINPLACE_CMD} -e 's|@file{as}|@file{${LCLTARGET}-as}|' ${WRKSRC}/gas/doc/as.texinfo
@${REINPLACE_CMD} -e 's|as.info|${LCLTARGET}-as.info|' ${WRKSRC}/gas/doc/Makefile.in
@${REINPLACE_CMD} -e 's|as.texinfo|${LCLTARGET}-as.texinfo|' ${WRKSRC}/gas/doc/Makefile.in
@${MV} ${WRKSRC}/gas/doc/as.texinfo ${WRKSRC}/gas/doc/${LCLTARGET}-as.texinfo
@${REINPLACE_CMD} -e 's|setfilename bfd.info|setfilename ${LCLTARGET}-bfd.info|' ${WRKSRC}/bfd/doc/bfd.texinfo
- @${REINPLACE_CMD} -e 's|(bfd)|(${LCLTARGET}-bfd)|' ${WRKSRC}/bfd/doc/bfd.texinfo
+ @${REINPLACE_CMD} -e 's|(bfd)|(${LCLTARGET}-bfd)|' ${WRKSRC}/bfd/doc/bfd.texinfo
@${REINPLACE_CMD} -e 's|@file{bfd}|@file{${LCLTARGET}-bfd}|' ${WRKSRC}/bfd/doc/bfd.texinfo
@${REINPLACE_CMD} -e 's|bfd.info|${LCLTARGET}-bfd.info|' ${WRKSRC}/bfd/doc/Makefile.in
@${REINPLACE_CMD} -e 's|bfd.texinfo|${LCLTARGET}-bfd.texinfo|' ${WRKSRC}/bfd/doc/Makefile.in
@${MV} ${WRKSRC}/bfd/doc/bfd.texinfo ${WRKSRC}/bfd/doc/${LCLTARGET}-bfd.texinfo
@${REINPLACE_CMD} -e 's|setfilename binutils.info|setfilename ${LCLTARGET}-binutils.info|' ${WRKSRC}/binutils/doc/binutils.texi
- @${REINPLACE_CMD} -e 's|(binutils)|(${LCLTARGET}-binutils)|' ${WRKSRC}/binutils/doc/binutils.texi
+ @${REINPLACE_CMD} -e 's|(binutils)|(${LCLTARGET}-binutils)|' ${WRKSRC}/binutils/doc/binutils.texi
@${REINPLACE_CMD} -e 's|@file{binutils}|@file{${LCLTARGET}-binutils}|' ${WRKSRC}/binutils/doc/binutils.texi
@${REINPLACE_CMD} -e 's|binutils.info|${LCLTARGET}-binutils.info|' ${WRKSRC}/binutils/doc/Makefile.in
@${REINPLACE_CMD} -e 's|binutils.texi|${LCLTARGET}-binutils.texi|' ${WRKSRC}/binutils/doc/Makefile.in
@${MV} ${WRKSRC}/binutils/doc/binutils.texi ${WRKSRC}/binutils/doc/${LCLTARGET}-binutils.texi
@${REINPLACE_CMD} -e 's|setfilename ld.info|setfilename ${LCLTARGET}-ld.info|' ${WRKSRC}/ld/ld.texinfo
- @${REINPLACE_CMD} -e 's|(ld)|(${LCLTARGET}-ld)|' ${WRKSRC}/ld/ld.texinfo
+ @${REINPLACE_CMD} -e 's|(ld)|(${LCLTARGET}-ld)|' ${WRKSRC}/ld/ld.texinfo
@${REINPLACE_CMD} -e 's|@file{ld}|@file{${LCLTARGET}-ld}|' ${WRKSRC}/ld/ld.texinfo
@${REINPLACE_CMD} -e 's|ld.info|${LCLTARGET}-ld.info|' ${WRKSRC}/ld/Makefile.in
@${REINPLACE_CMD} -e 's|ld.texinfo|${LCLTARGET}-ld.texinfo|' ${WRKSRC}/ld/Makefile.in
diff --git a/devel/i386-rtems-g77/Makefile b/devel/i386-rtems-g77/Makefile
index f56f062d2953..4d90e3da3f3b 100644
--- a/devel/i386-rtems-g77/Makefile
+++ b/devel/i386-rtems-g77/Makefile
@@ -7,7 +7,7 @@
PORTNAME= g77
PORTVERSION= 3.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
${MASTER_SITE_GNU:S/$/:gcc/}
@@ -35,7 +35,6 @@ GCCVERSION= 3.2.3
G77NAME= gcc-${GCCVERSION}
PLIST_SUB+= "GCCVERSION=${GCCVERSION}"
NEWLIBNAME= newlib-1.11.0
-MASTERDIR= ${.CURDIR}/../i386-rtems-g77
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
diff --git a/devel/i386-rtems-gcc/Makefile b/devel/i386-rtems-gcc/Makefile
index 7e54ac516811..cc85b9c5398a 100644
--- a/devel/i386-rtems-gcc/Makefile
+++ b/devel/i386-rtems-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 3.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
${MASTER_SITE_GNU:S/$/:gcc/}
@@ -36,7 +36,6 @@ GCCVERSION= 3.2.3
GCCNAME= gcc-${GCCVERSION}
PLIST_SUB+= "GCCVERSION=${GCCVERSION}"
NEWLIBNAME= newlib-1.11.0
-MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
@@ -68,7 +67,7 @@ MAKE_FLAGS= LANGUAGES="c c++"
MAKE_ENV= MACHINE_ARCH=${RTEMS_ARCH}
MAN1= ${LCLTARGET}-gcc.1 ${LCLTARGET}-g++.1 \
- cpp.1 gcov.1
+ cpp.1 gcov.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
INFO= ${LCLTARGET}-cpp ${LCLTARGET}-cppinternals \
${LCLTARGET}-gcc ${LCLTARGET}-gccint
@@ -85,7 +84,7 @@ pre-configure:
post-patch:
# Change cpp.info to ${LCLTARGET}-cpp.info
@${REINPLACE_CMD} -e 's|setfilename cpp.info|setfilename ${LCLTARGET}-cpp.info|g' ${WRKSRC}/gcc/doc/*.texi
- @${REINPLACE_CMD} -e 's|(cpp)|(${LCLTARGET}-cpp)|g' ${WRKSRC}/gcc/doc/*.texi
+ @${REINPLACE_CMD} -e 's|(cpp)|(${LCLTARGET}-cpp)|g' ${WRKSRC}/gcc/doc/*.texi
@${REINPLACE_CMD} -e 's|@file{cpp}|@file{${LCLTARGET}-cpp}|g' ${WRKSRC}/gcc/doc/*.texi
@${REINPLACE_CMD} -e 's|cpp.info|${LCLTARGET}-cpp.info|g' ${WRKSRC}/gcc/Makefile.in
@${REINPLACE_CMD} -e 's|cpp.texi|${LCLTARGET}-cpp.texi|g' ${WRKSRC}/gcc/Makefile.in
@@ -94,21 +93,21 @@ post-patch:
@${REINPLACE_CMD} -e 's|,cpp.info,|,${LCLTARGET}-cpp.info,|g' ${WRKSRC}/gcc/doc/extend.texi
# Change cpp.info to ${LCLTARGET}-cpp.info
@${REINPLACE_CMD} -e 's|setfilename cppinternals.info|setfilename ${LCLTARGET}-cppinternals.info|g' ${WRKSRC}/gcc/doc/*.texi
- @${REINPLACE_CMD} -e 's|(cppinternals)|(${LCLTARGET}-cppinternals)|g' ${WRKSRC}/gcc/doc/*.texi
+ @${REINPLACE_CMD} -e 's|(cppinternals)|(${LCLTARGET}-cppinternals)|g' ${WRKSRC}/gcc/doc/*.texi
@${REINPLACE_CMD} -e 's|@file{cppinternals}|@file{${LCLTARGET}-cppinternals}|g' ${WRKSRC}/gcc/doc/*.texi
@${REINPLACE_CMD} -e 's|cppinternals.info|${LCLTARGET}-cppinternals.info|g' ${WRKSRC}/gcc/Makefile.in
@${REINPLACE_CMD} -e 's|cppinternals.texi|${LCLTARGET}-cppinternals.texi|g' ${WRKSRC}/gcc/Makefile.in
@${MV} ${WRKSRC}/gcc/doc/cppinternals.texi ${WRKSRC}/gcc/doc/${LCLTARGET}-cppinternals.texi
# Change cpp.info to ${LCLTARGET}-cpp.info
@${REINPLACE_CMD} -e 's|setfilename gcc.info|setfilename ${LCLTARGET}-gcc.info|g' ${WRKSRC}/gcc/doc/*.texi
- @${REINPLACE_CMD} -e 's|(gcc)|(${LCLTARGET}-gcc)|g' ${WRKSRC}/gcc/doc/*.texi
+ @${REINPLACE_CMD} -e 's|(gcc)|(${LCLTARGET}-gcc)|g' ${WRKSRC}/gcc/doc/*.texi
@${REINPLACE_CMD} -e 's|@file{gcc}|@file{${LCLTARGET}-gcc}|g' ${WRKSRC}/gcc/doc/*.texi
@${REINPLACE_CMD} -e 's|gcc.info|${LCLTARGET}-gcc.info|g' ${WRKSRC}/gcc/Makefile.in
@${REINPLACE_CMD} -e 's|gcc.texi|${LCLTARGET}-gcc.texi|g' ${WRKSRC}/gcc/Makefile.in
@${MV} ${WRKSRC}/gcc/doc/gcc.texi ${WRKSRC}/gcc/doc/${LCLTARGET}-gcc.texi
# Change cpp.info to ${LCLTARGET}-cpp.info
@${REINPLACE_CMD} -e 's|setfilename gccint.info|setfilename ${LCLTARGET}-gccint.info|g' ${WRKSRC}/gcc/doc/*.texi
- @${REINPLACE_CMD} -e 's|(gccint)|(${LCLTARGET}-gccint)|g' ${WRKSRC}/gcc/doc/*.texi
+ @${REINPLACE_CMD} -e 's|(gccint)|(${LCLTARGET}-gccint)|g' ${WRKSRC}/gcc/doc/*.texi
@${REINPLACE_CMD} -e 's|@file{gccint}|@file{${LCLTARGET}-gccint}|g' ${WRKSRC}/gcc/doc/*.texi
@${REINPLACE_CMD} -e 's|gccint.info|${LCLTARGET}-gccint.info|g' ${WRKSRC}/gcc/Makefile.in
@${REINPLACE_CMD} -e 's|gccint.texi|${LCLTARGET}-gccint.texi|g' ${WRKSRC}/gcc/Makefile.in
diff --git a/devel/i386-rtems-objc/Makefile b/devel/i386-rtems-objc/Makefile
index 4c310e9f608d..6292f590a098 100644
--- a/devel/i386-rtems-objc/Makefile
+++ b/devel/i386-rtems-objc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= objc
PORTVERSION= 3.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
${MASTER_SITE_GNU:S/$/:gcc/}
@@ -35,7 +35,6 @@ GCCVERSION= 3.2.3
OBJCNAME= gcc-${GCCVERSION}
PLIST_SUB+= "GCCVERSION=${GCCVERSION}"
NEWLIBNAME= newlib-1.11.0
-MASTERDIR= ${.CURDIR}/../i386-rtems-objc
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
diff --git a/devel/i960-rtems-binutils/Makefile b/devel/i960-rtems-binutils/Makefile
index 6ac9bdfa402b..3dcbdf54549f 100644
--- a/devel/i960-rtems-binutils/Makefile
+++ b/devel/i960-rtems-binutils/Makefile
@@ -10,4 +10,6 @@ PORTNAME= binutils
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= i960-rtems
-.include "${.CURDIR}/../i386-rtems-binutils/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-binutils
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/i960-rtems-gcc/Makefile b/devel/i960-rtems-gcc/Makefile
index 68baad12ec87..efdc200274b7 100644
--- a/devel/i960-rtems-gcc/Makefile
+++ b/devel/i960-rtems-gcc/Makefile
@@ -11,4 +11,5 @@ MAINTAINER= jeh@FreeBSD.org
RTEMS_ARCH= i960
-.include "${.CURDIR}/../i386-rtems-gcc/Makefile"
+MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/m68k-rtems-binutils/Makefile b/devel/m68k-rtems-binutils/Makefile
index 468f34f8648e..7c32bf51db60 100644
--- a/devel/m68k-rtems-binutils/Makefile
+++ b/devel/m68k-rtems-binutils/Makefile
@@ -10,4 +10,6 @@ PORTNAME= binutils
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= m68k-rtems
-.include "${.CURDIR}/../i386-rtems-binutils/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-binutils
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/m68k-rtems-g77/Makefile b/devel/m68k-rtems-g77/Makefile
index 45b53954c8a8..ecab5241244f 100644
--- a/devel/m68k-rtems-g77/Makefile
+++ b/devel/m68k-rtems-g77/Makefile
@@ -10,4 +10,6 @@ PORTNAME= g77
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= m68k-rtems
+
.include "${.CURDIR}/../i386-rtems-g77/Makefile"
+MASTERDIR= ${MASTERDIR}/i386-rtems-g77
diff --git a/devel/m68k-rtems-gcc/Makefile b/devel/m68k-rtems-gcc/Makefile
index 90c4fbebedf9..3ad325125bf6 100644
--- a/devel/m68k-rtems-gcc/Makefile
+++ b/devel/m68k-rtems-gcc/Makefile
@@ -11,4 +11,5 @@ MAINTAINER= jeh@FreeBSD.org
RTEMS_ARCH= m68k
-.include "${.CURDIR}/../i386-rtems-gcc/Makefile"
+MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/m68k-rtems-objc/Makefile b/devel/m68k-rtems-objc/Makefile
index afdc37466619..2fb6de80a92b 100644
--- a/devel/m68k-rtems-objc/Makefile
+++ b/devel/m68k-rtems-objc/Makefile
@@ -10,4 +10,6 @@ PORTNAME= objc
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= m68k-rtems
-.include "${.CURDIR}/../i386-rtems-objc/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-objc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/mips-rtems-binutils/Makefile b/devel/mips-rtems-binutils/Makefile
index ed5fc5bd971c..66cfb4f4295c 100644
--- a/devel/mips-rtems-binutils/Makefile
+++ b/devel/mips-rtems-binutils/Makefile
@@ -10,4 +10,6 @@ PORTNAME= binutils
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= mips-rtems
-.include "${.CURDIR}/../i386-rtems-binutils/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-binutils
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/mips-rtems-g77/Makefile b/devel/mips-rtems-g77/Makefile
index 1aa25d040dbd..e060d9734da5 100644
--- a/devel/mips-rtems-g77/Makefile
+++ b/devel/mips-rtems-g77/Makefile
@@ -10,4 +10,6 @@ PORTNAME= g77
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= mips-rtems
+
.include "${.CURDIR}/../i386-rtems-g77/Makefile"
+MASTERDIR= ${MASTERDIR}/i386-rtems-g77
diff --git a/devel/mips-rtems-gcc/Makefile b/devel/mips-rtems-gcc/Makefile
index 5a4550659130..fdc1248ea3cd 100644
--- a/devel/mips-rtems-gcc/Makefile
+++ b/devel/mips-rtems-gcc/Makefile
@@ -11,4 +11,5 @@ MAINTAINER= jeh@FreeBSD.org
RTEMS_ARCH= mips
-.include "${.CURDIR}/../i386-rtems-gcc/Makefile"
+MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/mips-rtems-objc/Makefile b/devel/mips-rtems-objc/Makefile
index f604e779cee5..b01951aaace7 100644
--- a/devel/mips-rtems-objc/Makefile
+++ b/devel/mips-rtems-objc/Makefile
@@ -10,4 +10,6 @@ PORTNAME= objc
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= mips-rtems
-.include "${.CURDIR}/../i386-rtems-objc/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-objc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/powerpc-rtems-binutils/Makefile b/devel/powerpc-rtems-binutils/Makefile
index efb76505aaed..6a713362450d 100644
--- a/devel/powerpc-rtems-binutils/Makefile
+++ b/devel/powerpc-rtems-binutils/Makefile
@@ -10,4 +10,6 @@ PORTNAME= binutils
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= powerpc-rtems
-.include "${.CURDIR}/../i386-rtems-binutils/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-binutils
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/powerpc-rtems-g77/Makefile b/devel/powerpc-rtems-g77/Makefile
index aadd26d13e3a..ef58e55a92be 100644
--- a/devel/powerpc-rtems-g77/Makefile
+++ b/devel/powerpc-rtems-g77/Makefile
@@ -10,4 +10,6 @@ PORTNAME= g77
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= powerpc-rtems
+
.include "${.CURDIR}/../i386-rtems-g77/Makefile"
+MASTERDIR= ${MASTERDIR}/i386-rtems-g77
diff --git a/devel/powerpc-rtems-gcc/Makefile b/devel/powerpc-rtems-gcc/Makefile
index 702d613a89ba..36894ffbd694 100644
--- a/devel/powerpc-rtems-gcc/Makefile
+++ b/devel/powerpc-rtems-gcc/Makefile
@@ -11,4 +11,5 @@ MAINTAINER= jeh@FreeBSD.org
RTEMS_ARCH= powerpc
-.include "${.CURDIR}/../i386-rtems-gcc/Makefile"
+MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/powerpc-rtems-objc/Makefile b/devel/powerpc-rtems-objc/Makefile
index 6c337ee55a2d..73658808859b 100644
--- a/devel/powerpc-rtems-objc/Makefile
+++ b/devel/powerpc-rtems-objc/Makefile
@@ -10,4 +10,6 @@ PORTNAME= objc
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= powerpc-rtems
-.include "${.CURDIR}/../i386-rtems-objc/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-objc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/sh-rtems-binutils/Makefile b/devel/sh-rtems-binutils/Makefile
index 5bbf265d857a..d2847ab3266b 100644
--- a/devel/sh-rtems-binutils/Makefile
+++ b/devel/sh-rtems-binutils/Makefile
@@ -10,4 +10,6 @@ PORTNAME= binutils
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= sh-rtems
-.include "${.CURDIR}/../i386-rtems-binutils/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-binutils
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/sh-rtems-g77/Makefile b/devel/sh-rtems-g77/Makefile
index 6c15b8018f56..b594683dcf36 100644
--- a/devel/sh-rtems-g77/Makefile
+++ b/devel/sh-rtems-g77/Makefile
@@ -10,4 +10,6 @@ PORTNAME= g77
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= sh-rtems
+
.include "${.CURDIR}/../i386-rtems-g77/Makefile"
+MASTERDIR= ${MASTERDIR}/i386-rtems-g77
diff --git a/devel/sh-rtems-gcc/Makefile b/devel/sh-rtems-gcc/Makefile
index c8f76bde9f91..bbff1e1f018a 100644
--- a/devel/sh-rtems-gcc/Makefile
+++ b/devel/sh-rtems-gcc/Makefile
@@ -11,4 +11,5 @@ MAINTAINER= jeh@FreeBSD.org
RTEMS_ARCH= sh
-.include "${.CURDIR}/../i386-rtems-gcc/Makefile"
+MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/sh-rtems-objc/Makefile b/devel/sh-rtems-objc/Makefile
index ce604d48ad2a..ddcc7fcf0786 100644
--- a/devel/sh-rtems-objc/Makefile
+++ b/devel/sh-rtems-objc/Makefile
@@ -10,4 +10,6 @@ PORTNAME= objc
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= sh-rtems
-.include "${.CURDIR}/../i386-rtems-objc/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-objc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/sparc-rtems-binutils/Makefile b/devel/sparc-rtems-binutils/Makefile
index 704fc3d411be..00eb715a5555 100644
--- a/devel/sparc-rtems-binutils/Makefile
+++ b/devel/sparc-rtems-binutils/Makefile
@@ -10,4 +10,6 @@ PORTNAME= binutils
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= sparc-rtems
-.include "${.CURDIR}/../i386-rtems-binutils/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-binutils
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/sparc-rtems-g77/Makefile b/devel/sparc-rtems-g77/Makefile
index bd9769fac2a8..1a65b6fbecdb 100644
--- a/devel/sparc-rtems-g77/Makefile
+++ b/devel/sparc-rtems-g77/Makefile
@@ -10,4 +10,6 @@ PORTNAME= g77
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= sparc-rtems
+
.include "${.CURDIR}/../i386-rtems-g77/Makefile"
+MASTERDIR= ${MASTERDIR}/i386-rtems-g77
diff --git a/devel/sparc-rtems-gcc/Makefile b/devel/sparc-rtems-gcc/Makefile
index 2218587fa8c0..0ecf13c110b0 100644
--- a/devel/sparc-rtems-gcc/Makefile
+++ b/devel/sparc-rtems-gcc/Makefile
@@ -11,4 +11,5 @@ MAINTAINER= jeh@FreeBSD.org
RTEMS_ARCH= sparc
-.include "${.CURDIR}/../i386-rtems-gcc/Makefile"
+MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/sparc-rtems-objc/Makefile b/devel/sparc-rtems-objc/Makefile
index fd2c1cd1f4bc..2549c7b585b6 100644
--- a/devel/sparc-rtems-objc/Makefile
+++ b/devel/sparc-rtems-objc/Makefile
@@ -10,4 +10,6 @@ PORTNAME= objc
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= sparc-rtems
-.include "${.CURDIR}/../i386-rtems-objc/Makefile"
+
+MASTERDIR= ${.CURDIR}/../i386-rtems-objc
+.include "${MASTERDIR}/Makefile"