aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/qtiplot-doc/Makefile38
-rw-r--r--math/qtiplot-doc/distinfo3
-rw-r--r--math/qtiplot-doc/pkg-descr4
4 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e45ac542d8bb..1146c0b75128 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -287,6 +287,7 @@
SUBDIR += qhull
SUBDIR += qscanplot
SUBDIR += qtiplot
+ SUBDIR += qtiplot-doc
SUBDIR += qwtplot3d
SUBDIR += rascal
SUBDIR += reed-solomon
diff --git a/math/qtiplot-doc/Makefile b/math/qtiplot-doc/Makefile
new file mode 100644
index 000000000000..7706b2b8d1c6
--- /dev/null
+++ b/math/qtiplot-doc/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: qtiplot-doc
+# Date created: 2006-09-08
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qtiplot-doc
+PORTVERSION= 0.8.7
+CATEGORIES= math
+MASTER_SITES= http://soft.proindependent.com/doc/
+DISTNAME= manual-en
+
+MAINTAINER= makc@issp.ac.ru
+COMMENT= The QtiPlot Handbook
+
+USE_ZIP= yes
+NO_BUILD= yes
+DATADIR= ${PREFIX}/share/qtiplot/manual
+
+PLIST= ${WRKDIR}/pkg-plist
+
+.include <bsd.port.pre.mk>
+
+pre-install:
+ @${ECHO_CMD} '@exec mkdir -p %D/share/qtiplot/manual' > ${PLIST}
+ @${FIND} ${WRKSRC} -type f | \
+ ${SED} -e "s:^${WRKSRC}/:share/qtiplot/manual/:g" >> ${PLIST}
+ @${FIND} -d ${WRKSRC} -type d | \
+ ${SED} -e "s:^${WRKSRC}:@dirrm share/qtiplot/manual:g" >> ${PLIST}
+ @${ECHO_CMD} "@dirrmtry share/qtiplot" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${TAR} -C ${WRKSRC} --exclude CVS -cf - . | \
+ ${TAR} -C ${DATADIR} --unlink -xf -
+
+.include <bsd.port.post.mk>
diff --git a/math/qtiplot-doc/distinfo b/math/qtiplot-doc/distinfo
new file mode 100644
index 000000000000..eebd23c8bcb4
--- /dev/null
+++ b/math/qtiplot-doc/distinfo
@@ -0,0 +1,3 @@
+MD5 (manual-en.zip) = 61bd61f42c756e388c240cb9d6d01381
+SHA256 (manual-en.zip) = cf2cbf2342530b98f6ce1a6ec0e4ac928bcbe0424264b39580171b1cb5afab0f
+SIZE (manual-en.zip) = 5148221
diff --git a/math/qtiplot-doc/pkg-descr b/math/qtiplot-doc/pkg-descr
new file mode 100644
index 000000000000..ef482ffe7489
--- /dev/null
+++ b/math/qtiplot-doc/pkg-descr
@@ -0,0 +1,4 @@
+The QtiPlot Handbook.
+
+Author: Roger Gadiou
+WWW: http://soft.proindependent.com/qtiplot.html