aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--java/jdk12/Makefile2
-rw-r--r--java/jdk13/Makefile2
-rw-r--r--java/jdk14/Makefile2
-rw-r--r--java/jdk15/Makefile2
-rw-r--r--java/jdk16/Makefile2
-rw-r--r--lang/egcs/Makefile2
-rw-r--r--lang/gcc27/Makefile2
-rw-r--r--lang/gcc28/Makefile2
-rw-r--r--lang/gcc295/Makefile2
-rw-r--r--lang/gnat/Makefile2
-rw-r--r--security/tripwire12/Makefile2
-rw-r--r--x11-fonts/cyr-rfx/Makefile2
12 files changed, 12 insertions, 12 deletions
diff --git a/java/jdk12/Makefile b/java/jdk12/Makefile
index 063573635c4a..54837c99d30c 100644
--- a/java/jdk12/Makefile
+++ b/java/jdk12/Makefile
@@ -125,7 +125,7 @@ pre-build:
${ECHO_MSG} "This is known to cause problems during bootstrapping."; \
exit 1; \
fi
- @if [ `sysctl -n compat.linux.osname` != "Linux" ]; \
+ @if [ `/sbin/sysctl -n compat.linux.osname` != "Linux" ]; \
then \
${ECHO_MSG} "Please set the value of the sysctl compat.linux.osname"; \
${ECHO_MSG} "to 'Linux' with the command:"; \
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index 3e59069ca2e1..5e37fd20c049 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -160,7 +160,7 @@ pre-build:
${ECHO_MSG} "This is known to cause problems during bootstrapping."; \
exit 1; \
fi
- @if [ `sysctl -n compat.linux.osname` != "Linux" ]; \
+ @if [ `/sbin/sysctl -n compat.linux.osname` != "Linux" ]; \
then \
${ECHO_MSG} "Please set the value of the sysctl compat.linux.osname"; \
${ECHO_MSG} "to 'Linux' with the command:"; \
diff --git a/java/jdk14/Makefile b/java/jdk14/Makefile
index 3e59069ca2e1..5e37fd20c049 100644
--- a/java/jdk14/Makefile
+++ b/java/jdk14/Makefile
@@ -160,7 +160,7 @@ pre-build:
${ECHO_MSG} "This is known to cause problems during bootstrapping."; \
exit 1; \
fi
- @if [ `sysctl -n compat.linux.osname` != "Linux" ]; \
+ @if [ `/sbin/sysctl -n compat.linux.osname` != "Linux" ]; \
then \
${ECHO_MSG} "Please set the value of the sysctl compat.linux.osname"; \
${ECHO_MSG} "to 'Linux' with the command:"; \
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index 3e59069ca2e1..5e37fd20c049 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -160,7 +160,7 @@ pre-build:
${ECHO_MSG} "This is known to cause problems during bootstrapping."; \
exit 1; \
fi
- @if [ `sysctl -n compat.linux.osname` != "Linux" ]; \
+ @if [ `/sbin/sysctl -n compat.linux.osname` != "Linux" ]; \
then \
${ECHO_MSG} "Please set the value of the sysctl compat.linux.osname"; \
${ECHO_MSG} "to 'Linux' with the command:"; \
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index 3e59069ca2e1..5e37fd20c049 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -160,7 +160,7 @@ pre-build:
${ECHO_MSG} "This is known to cause problems during bootstrapping."; \
exit 1; \
fi
- @if [ `sysctl -n compat.linux.osname` != "Linux" ]; \
+ @if [ `/sbin/sysctl -n compat.linux.osname` != "Linux" ]; \
then \
${ECHO_MSG} "Please set the value of the sysctl compat.linux.osname"; \
${ECHO_MSG} "to 'Linux' with the command:"; \
diff --git a/lang/egcs/Makefile b/lang/egcs/Makefile
index 8752def28942..1b33289e58cb 100644
--- a/lang/egcs/Makefile
+++ b/lang/egcs/Makefile
@@ -52,7 +52,7 @@ pre-configure:
@# configure.in by patching it.
@touch ${WRKSRC}/gcc/configure
@touch ${WRKSRC}/gcc/cstamp-h.in
- @(MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
+ @(MAJ=`/sbin/sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" ${FILESDIR}/freebsd.h \
>${WRKSRC}/gcc/config/freebsd.h )
diff --git a/lang/gcc27/Makefile b/lang/gcc27/Makefile
index 0c2612b4d83b..0abab062adf5 100644
--- a/lang/gcc27/Makefile
+++ b/lang/gcc27/Makefile
@@ -41,7 +41,7 @@ pre-patch:
@${MV} ${WRKSRC}/config/i386/freebsd.h ${WRKSRC}/config/i386/freebsd-aout.h
pre-configure:
- @(MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
+ @(MAJ=`/sbin/sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
${SED} -e "s:__FreeBSD__[0-9=]*:__FreeBSD__=$${MAJ}:" ${FILESDIR}/freebsd.h.${ARCH} \
>${WRKSRC}/config/${ARCH}/freebsd.h )
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index 61f1555e37dd..27a330a303db 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -51,7 +51,7 @@ pre-configure:
@${TOUCH} ${TOUCH_FLAGS} ${WRKSRC}/configure
@${TOUCH} ${TOUCH_FLAGS} ${WRKSRC}/cstamp-h.in
@(cd ${WRKSRC}/config/${ARCH}/ ; \
- MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
+ MAJ=`/sbin/sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
${MV} freebsd-aout.h freebsd-aout.h.in ; \
${SED} -e "s:__FreeBSD__=[0-9]*:__FreeBSD__=$${MAJ}:" \
freebsd-aout.h.in >freebsd-aout.h ; \
diff --git a/lang/gcc295/Makefile b/lang/gcc295/Makefile
index 03ae75ecadaa..8d07066b5801 100644
--- a/lang/gcc295/Makefile
+++ b/lang/gcc295/Makefile
@@ -58,7 +58,7 @@ pre-patch:
@${MV} ${WRKSRC}/gcc/config/i386/freebsd-elf.h ${WRKSRC}/gcc/config/i386/freebsd.h
pre-configure:
- @(MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
+ @(MAJ=`/sbin/sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
${SED} -e "s:__FreeBSD__[0-9=]*:__FreeBSD__=$${MAJ}:" ${FILESDIR}/freebsd.h \
>${WRKSRC}/gcc/config/freebsd.h )
@${CP} ${FILESDIR}/alpha-freebsd.h ${WRKSRC}/gcc/config/alpha/freebsd.h
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index fa58257c5316..372ebee1e1c7 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -162,7 +162,7 @@ post-patch:
pre-configure:
@(cd ${WRKSRC}/config/${ARCH}/ ; \
- MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
+ MAJ=`/sbin/sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
${MV} freebsd.h freebsd.h.in ; \
${SED} -e "s:__FreeBSD__=[0-9]*:__FreeBSD__=$${MAJ}:" freebsd.h.in \
>freebsd.h)
diff --git a/security/tripwire12/Makefile b/security/tripwire12/Makefile
index 04fea3c9048a..e868c6c7ceeb 100644
--- a/security/tripwire12/Makefile
+++ b/security/tripwire12/Makefile
@@ -30,7 +30,7 @@ post-patch:
pre-configure:
@ ${CP} ${FILESDIR}/conf-freebsd2.h ${WRKSRC}/configs
- @ ${SED} s%/kernel%`sysctl -bn kern.bootfile`% \
+ @ ${SED} s%/kernel%`/sbin/sysctl -bn kern.bootfile`% \
< ${TWCONFIG} \
> ${WRKSRC}/configs/tw.conf.freebsd2
diff --git a/x11-fonts/cyr-rfx/Makefile b/x11-fonts/cyr-rfx/Makefile
index d450c7fb8b1d..46ca74f61b6a 100644
--- a/x11-fonts/cyr-rfx/Makefile
+++ b/x11-fonts/cyr-rfx/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients \
CYR_RFX_ENCODING?= koi8-o
WRKSRC= ${WRKDIR}/${CYR_RFX_ENCODING}
-NCPUS!= sysctl -n hw.ncpu 2> /dev/null || echo 1
+NCPUS!= /sbin/sysctl -n hw.ncpu 2> /dev/null || echo 1
MAKE_ARGS+= -j ${NCPUS}
MAKEFILE= ${FILESDIR}/Makefile.bdf2pcf
INST_DIR= "lib/X11/fonts/${PORTNAME}"