aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/ktorrent/Makefile12
-rw-r--r--net-p2p/ktorrent/distinfo4
-rw-r--r--net-p2p/ktorrent/pkg-plist1
-rw-r--r--net-p2p/libktorrent/Makefile9
-rw-r--r--net-p2p/libktorrent/distinfo4
-rw-r--r--net-p2p/libktorrent/files/patch-src__net__address.cpp10
-rw-r--r--net-p2p/libktorrent/pkg-plist13
7 files changed, 23 insertions, 30 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index fe8996ed4469..48175f69246a 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: ktorrent
-# Date created: Wed Jul 13 11:38:46 CEST 2005
-# Whom: Markus Brueffer <markus@FreeBSD.org>
-#
+# Created by: Markus Brueffer <markus@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ktorrent
-DISTVERSION= 4.2.1
+DISTVERSION= 4.3.0
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION}/
@@ -14,7 +10,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= BitTorrent client for KDE
LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib \
- ktorrent:${PORTSDIR}/net-p2p/libktorrent
+ ktorrent.5:${PORTSDIR}/net-p2p/libktorrent
USE_BZIP2= yes
USE_KDE4= kdelibs kdehier kdeprefix automoc4 pimlibs workspace
@@ -26,7 +22,7 @@ MAKE_JOBS_SAFE= yes
CONFLICTS_BUILD= ktorrent-2*
-SHLIB_VER= 13.0.1
+SHLIB_VER= 14.0.0
PLIST_SUB+= SHLIB_VER=${SHLIB_VER} \
SHLIB_SHVER=${SHLIB_VER:R:R}
diff --git a/net-p2p/ktorrent/distinfo b/net-p2p/ktorrent/distinfo
index afe685288563..3847cfcae789 100644
--- a/net-p2p/ktorrent/distinfo
+++ b/net-p2p/ktorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ktorrent-4.2.1.tar.bz2) = ed8ff3ad627c50ffd44f2b6d8ae8cd46aa0d4359bbd3ec13a715e1bd433cdcac
-SIZE (ktorrent-4.2.1.tar.bz2) = 3082436
+SHA256 (ktorrent-4.3.0.tar.bz2) = 6e3a7d12d351cad0e40b87562556f07ce9ee1378048f99073c6bac7b971483ed
+SIZE (ktorrent-4.3.0.tar.bz2) = 2983013
diff --git a/net-p2p/ktorrent/pkg-plist b/net-p2p/ktorrent/pkg-plist
index d79a81475f9c..b5c5419aec95 100644
--- a/net-p2p/ktorrent/pkg-plist
+++ b/net-p2p/ktorrent/pkg-plist
@@ -20,7 +20,6 @@ lib/kde4/ktwebinterfaceplugin.so
lib/kde4/ktzeroconfplugin.so
lib/kde4/plasma_applet_ktorrent.so
lib/kde4/plasma_engine_ktorrent.so
-lib/libktcore.so
lib/libktcore.so.%%SHLIB_VER%%
lib/libktcore.so.%%SHLIB_SHVER%%
share/applications/kde4/ktorrent.desktop
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 700a21343283..be5a16e62095 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: libktorrent
-# Date created: 2010-05-05
-# Whom: Max Brazhnikov <makc@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= libktorrent
-DISTVERSION= 1.2.1-2
+DISTVERSION= 1.3.0
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION:C,^1,4,:C,-.*,,}/
@@ -25,7 +20,7 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-SHLIB_VER= 4.0.1
+SHLIB_VER= 5.0.0
PLIST_SUB+= SHLIB_VER=${SHLIB_VER} \
SHLIB_SHVER=${SHLIB_VER:R:R}
diff --git a/net-p2p/libktorrent/distinfo b/net-p2p/libktorrent/distinfo
index 2177a2673cbc..bd2a8df18ea0 100644
--- a/net-p2p/libktorrent/distinfo
+++ b/net-p2p/libktorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libktorrent-1.2.1-2.tar.bz2) = 8933266c01548566d2438d55439fe67bffc728ef23e902b5dc3b1ea1d65c91ac
-SIZE (libktorrent-1.2.1-2.tar.bz2) = 896558
+SHA256 (libktorrent-1.3.0.tar.bz2) = 8ac79a937dfc9f6617dc584d9b3bbe01295333f759dae8dd29db309d56d9f144
+SIZE (libktorrent-1.3.0.tar.bz2) = 884917
diff --git a/net-p2p/libktorrent/files/patch-src__net__address.cpp b/net-p2p/libktorrent/files/patch-src__net__address.cpp
deleted file mode 100644
index e379162cbed6..000000000000
--- a/net-p2p/libktorrent/files/patch-src__net__address.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/net/address.cpp.orig 2012-02-28 17:35:19.000000000 +0000
-+++ ./src/net/address.cpp 2012-03-06 13:36:25.728553394 +0000
-@@ -21,6 +21,7 @@
- #include "address.h"
- #include <arpa/inet.h>
- #include <util/log.h>
-+#include <sys/socket.h>
-
- using namespace bt;
-
diff --git a/net-p2p/libktorrent/pkg-plist b/net-p2p/libktorrent/pkg-plist
index 9f49b36948bf..af8bb6c15830 100644
--- a/net-p2p/libktorrent/pkg-plist
+++ b/net-p2p/libktorrent/pkg-plist
@@ -7,20 +7,32 @@ include/libktorrent/datachecker/datacheckerjob.h
include/libktorrent/datachecker/datacheckerthread.h
include/libktorrent/datachecker/multidatachecker.h
include/libktorrent/datachecker/singledatachecker.h
+include/libktorrent/dht/announcereq.h
+include/libktorrent/dht/announcersp.h
include/libktorrent/dht/announcetask.h
include/libktorrent/dht/database.h
include/libktorrent/dht/dht.h
include/libktorrent/dht/dhtbase.h
include/libktorrent/dht/dhtpeersource.h
+include/libktorrent/dht/findnodereq.h
+include/libktorrent/dht/findnodersp.h
+include/libktorrent/dht/getpeersreq.h
+include/libktorrent/dht/getpeersrsp.h
include/libktorrent/dht/kbucket.h
+include/libktorrent/dht/kbucketentry.h
+include/libktorrent/dht/kbuckettable.h
include/libktorrent/dht/kclosestnodessearch.h
include/libktorrent/dht/key.h
include/libktorrent/dht/node.h
include/libktorrent/dht/nodelookup.h
include/libktorrent/dht/pack.h
+include/libktorrent/dht/pingreq.h
+include/libktorrent/dht/pingrsp.h
include/libktorrent/dht/rpccall.h
include/libktorrent/dht/rpcmsg.h
+include/libktorrent/dht/rpcmsgfactory.h
include/libktorrent/dht/rpcserver.h
+include/libktorrent/dht/rpcserverinterface.h
include/libktorrent/dht/task.h
include/libktorrent/dht/taskmanager.h
include/libktorrent/diskio/cache.h
@@ -96,6 +108,7 @@ include/libktorrent/peer/authenticate.h
include/libktorrent/peer/authenticatebase.h
include/libktorrent/peer/authenticationmonitor.h
include/libktorrent/peer/chunkcounter.h
+include/libktorrent/peer/connectionlimit.h
include/libktorrent/peer/packetreader.h
include/libktorrent/peer/peer.h
include/libktorrent/peer/peerconnector.h