aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--java/jdk12/Makefile7
-rw-r--r--java/jdk13-doc/Makefile6
-rw-r--r--java/jdk13/Makefile7
-rw-r--r--java/jdk14-doc/Makefile6
-rw-r--r--java/jdk14/Makefile7
-rw-r--r--java/jdk15/Makefile7
-rw-r--r--java/jdk16/Makefile7
-rw-r--r--java/linux-ibm-jdk13/Makefile10
-rw-r--r--java/linux-sun-jdk12/Makefile6
-rw-r--r--java/linux-sun-jdk13/Makefile6
-rw-r--r--java/linux-sun-jdk14/Makefile6
11 files changed, 18 insertions, 57 deletions
diff --git a/java/jdk12/Makefile b/java/jdk12/Makefile
index e4f71dbc0d4a..30fad6e9bc52 100644
--- a/java/jdk12/Makefile
+++ b/java/jdk12/Makefile
@@ -43,7 +43,8 @@ JDK12DIR?= ${LOCALBASE}/linux-sun-jdk${JDK_VERSION}
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
-RESTRICTED= "Redistribution of pre-compiled binaries isn't permitted"
+RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
+NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"
MAKEFILE= GNUmakefile
MAKE_ENV= HAVE_DPS="no" \
ALT_BOOTDIR="${JDK12DIR}" \
@@ -71,10 +72,6 @@ PKGNAMESUFFIX= -nodebug
PLIST_SUB+= DEBUG:=""
.endif
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute pre-compiled binaries"
-.endif
-
.include <bsd.port.pre.mk>
.for file in ${DISTFILES}
diff --git a/java/jdk13-doc/Makefile b/java/jdk13-doc/Makefile
index d5eb7ed29071..501fbb2edf6e 100644
--- a/java/jdk13-doc/Makefile
+++ b/java/jdk13-doc/Makefile
@@ -14,11 +14,7 @@ DISTNAME= j2sdk-${JDK_VERSION:S/./_/g}-doc
MAINTAINER= znerd@FreeBSD.org
NO_CDROM= "License does not allow distribution with fee."
-RESTRICTED= "This software is under license and export control."
-
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You cannot legally distribute packages"
-.endif
+RESTRICTED= "This documentation is under license and export control."
PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
TARGET_DIR?= ${PREFIX}/share/doc/jdk${JDK_MAJOR_VER}
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index cdb855b22662..27b6facbd2c6 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -44,7 +44,8 @@ JDK13DIR?= ${LOCALBASE}/linux-sun-jdk${JDK_VERSION}
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
-RESTRICTED= "Redistribution of pre-compiled binaries isn't permitted"
+RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
+NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"
MAKE_ENV= ALT_BOOTDIR="${JDK13DIR}" \
ALT_MOTIF_DIR="${X11BASE}" \
OPENWINHOME="${X11BASE}" \
@@ -90,10 +91,6 @@ PLIST_SUB+= PLUGIN:="@comment "
PLIST_SUB+= PLUGIN:=""
.endif
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute pre-compiled binaries"
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500038 )
diff --git a/java/jdk14-doc/Makefile b/java/jdk14-doc/Makefile
index 45386d2767e4..54d47a38638c 100644
--- a/java/jdk14-doc/Makefile
+++ b/java/jdk14-doc/Makefile
@@ -14,11 +14,7 @@ DISTNAME= j2sdk-${JDK_VERSION:S/./_/g}-doc
MAINTAINER= znerd@FreeBSD.org
NO_CDROM= "License does not allow distribution with fee."
-RESTRICTED= "This software is under license and export control."
-
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You cannot legally distribute packages"
-.endif
+RESTRICTED= "This documentation is under license and export control."
PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
TARGET_DIR?= ${PREFIX}/share/doc/jdk${JDK_MAJOR_VER}
diff --git a/java/jdk14/Makefile b/java/jdk14/Makefile
index cdb855b22662..27b6facbd2c6 100644
--- a/java/jdk14/Makefile
+++ b/java/jdk14/Makefile
@@ -44,7 +44,8 @@ JDK13DIR?= ${LOCALBASE}/linux-sun-jdk${JDK_VERSION}
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
-RESTRICTED= "Redistribution of pre-compiled binaries isn't permitted"
+RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
+NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"
MAKE_ENV= ALT_BOOTDIR="${JDK13DIR}" \
ALT_MOTIF_DIR="${X11BASE}" \
OPENWINHOME="${X11BASE}" \
@@ -90,10 +91,6 @@ PLIST_SUB+= PLUGIN:="@comment "
PLIST_SUB+= PLUGIN:=""
.endif
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute pre-compiled binaries"
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500038 )
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index cdb855b22662..27b6facbd2c6 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -44,7 +44,8 @@ JDK13DIR?= ${LOCALBASE}/linux-sun-jdk${JDK_VERSION}
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
-RESTRICTED= "Redistribution of pre-compiled binaries isn't permitted"
+RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
+NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"
MAKE_ENV= ALT_BOOTDIR="${JDK13DIR}" \
ALT_MOTIF_DIR="${X11BASE}" \
OPENWINHOME="${X11BASE}" \
@@ -90,10 +91,6 @@ PLIST_SUB+= PLUGIN:="@comment "
PLIST_SUB+= PLUGIN:=""
.endif
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute pre-compiled binaries"
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500038 )
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index cdb855b22662..27b6facbd2c6 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -44,7 +44,8 @@ JDK13DIR?= ${LOCALBASE}/linux-sun-jdk${JDK_VERSION}
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
-RESTRICTED= "Redistribution of pre-compiled binaries isn't permitted"
+RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
+NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"
MAKE_ENV= ALT_BOOTDIR="${JDK13DIR}" \
ALT_MOTIF_DIR="${X11BASE}" \
OPENWINHOME="${X11BASE}" \
@@ -90,10 +91,6 @@ PLIST_SUB+= PLUGIN:="@comment "
PLIST_SUB+= PLUGIN:=""
.endif
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute pre-compiled binaries"
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500038 )
diff --git a/java/linux-ibm-jdk13/Makefile b/java/linux-ibm-jdk13/Makefile
index d853f57d70e0..91652c2ff24a 100644
--- a/java/linux-ibm-jdk13/Makefile
+++ b/java/linux-ibm-jdk13/Makefile
@@ -29,7 +29,7 @@ ONLY_FOR_ARCHS= i386
APP_HOME?= ${PREFIX}/${PKGBASE}${PORTVERSION}
LINUX_SH?= ${LINUXBASE}/bin/sh
-NO_CDROM= "License doesn\'t allow distribution with fee"
+NO_CDROM= "License does not allow distribution with fee"
RESTRICTED= "Redistribution of repackaged binaries not permitted"
DOWNLOAD_URL= http://www6.software.ibm.com/dl/dklx130/dklx130-i?S_PKG=ia32ww
@@ -42,16 +42,12 @@ RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/TrueType/wadalab-gothic.ttf:${PORTSDIR}/j
PLIST_SUB+= JAPANESE="@comment "
.endif
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute binaries"
-.endif
-
-.include <bsd.port.pre.mk>
-
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE=You must manually fetch the IBM Java SDK ${JDK_VERSION} for Linux archive (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again.
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
@for shfn in `${GREP} -r '^#!/bin/sh' ${WRKSRC}|${AWK} -F: '{print $$1}'`; do \
if [ ! -h $$shfn ]; then \
diff --git a/java/linux-sun-jdk12/Makefile b/java/linux-sun-jdk12/Makefile
index cede0c9f2c7b..852819b8a8c4 100644
--- a/java/linux-sun-jdk12/Makefile
+++ b/java/linux-sun-jdk12/Makefile
@@ -25,13 +25,9 @@ USE_LINUX= yes
JDK_VERSION= 1.2.2.013
ONLY_FOR_ARCHS= i386
-NO_CDROM= "License doesn\'t allow distribution with fee"
+NO_CDROM= "License does not allow distribution with fee"
RESTRICTED= "Redistribution of repackaged binaries not permitted"
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute binaries"
-.endif
-
APP_HOME= ${PREFIX}/${PKGNAMEPREFIX}jdk1.2.2
DOWNLOAD_URL= http://java.sun.com/Download5?config-file=${PORTNAME}-${JDK_VERSION:S/./_/g}.config&platform=linux-i586
diff --git a/java/linux-sun-jdk13/Makefile b/java/linux-sun-jdk13/Makefile
index e17345a5a69c..ec76dfd6d6ff 100644
--- a/java/linux-sun-jdk13/Makefile
+++ b/java/linux-sun-jdk13/Makefile
@@ -19,13 +19,9 @@ MAINTAINER= znerd@FreeBSD.org
BUILD_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
-NO_CDROM= "License doesn\'t allow distribution with fee"
+NO_CDROM= "License does not allow distribution with fee"
RESTRICTED= "Redistribution of repackaged binaries not permitted"
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute binaries"
-.endif
-
EXTRACT_CMD= # empty
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= # empty
diff --git a/java/linux-sun-jdk14/Makefile b/java/linux-sun-jdk14/Makefile
index e12573df0041..e7eab65d1100 100644
--- a/java/linux-sun-jdk14/Makefile
+++ b/java/linux-sun-jdk14/Makefile
@@ -18,13 +18,9 @@ MAINTAINER= znerd@FreeBSD.org
BUILD_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
-NO_CDROM= "License doesn\'t allow distribution with fee"
+NO_CDROM= "License does not allow distribution with fee"
RESTRICTED= "Redistribution of repackaged binaries not permitted"
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE="You can not legally distribute binaries"
-.endif
-
EXTRACT_CMD= # empty
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= # empty