aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/gwhois/Makefile3
-rw-r--r--net/p5-BBS-UserInfo-Maple3itoc/Makefile3
-rw-r--r--net/p5-IP-Country/Makefile3
-rw-r--r--net/p5-Net-Amazon-MechanicalTurk/Makefile3
-rw-r--r--net/p5-Net-Google-Analytics/Makefile3
-rw-r--r--net/p5-Net-GrowlClient/Makefile3
-rw-r--r--net/p5-Net-LDAP-AutoServer/Makefile3
-rw-r--r--net/p5-Net-OAuth-Simple/Makefile3
-rw-r--r--net/p5-Net-Packet/Makefile3
-rw-r--r--net/p5-Net-SMS-Mollie/Makefile3
-rw-r--r--net/p5-Net-STOMP-Client/Makefile3
-rw-r--r--net/p5-Net-Server-Coro/Makefile3
-rw-r--r--net/p5-Net-Trackback/Makefile3
-rw-r--r--net/p5-Net-Z3950-SimpleServer/Makefile3
-rw-r--r--net/p5-Script-isAperlScript/Makefile3
-rw-r--r--net/p5-WebService-Prowl/Makefile3
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/Makefile3
-rw-r--r--net/p5-ZConf/Makefile3
-rw-r--r--net/slirp/Makefile3
19 files changed, 38 insertions, 19 deletions
diff --git a/net/gwhois/Makefile b/net/gwhois/Makefile
index 151e5cffc64c..a07219652171 100644
--- a/net/gwhois/Makefile
+++ b/net/gwhois/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
curl:${PORTSDIR}/ftp/curl
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/pattern
PLIST_DIRS= %%DATADIR%%
diff --git a/net/p5-BBS-UserInfo-Maple3itoc/Makefile b/net/p5-BBS-UserInfo-Maple3itoc/Makefile
index 96122c813dce..a8ca49d15a53 100644
--- a/net/p5-BBS-UserInfo-Maple3itoc/Makefile
+++ b/net/p5-BBS-UserInfo-Maple3itoc/Makefile
@@ -17,7 +17,8 @@ COMMENT= Get user information of Maple3itoc-style BBS
RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BBS::UserInfo::Maple3itoc.3
diff --git a/net/p5-IP-Country/Makefile b/net/p5-IP-Country/Makefile
index cfdb588c0851..3199f9e1b09d 100644
--- a/net/p5-IP-Country/Makefile
+++ b/net/p5-IP-Country/Makefile
@@ -13,7 +13,8 @@ COMMENT= Fast lookup of country codes from IP addresses
BUILD_DEPENDS= p5-Geography-Countries>=0:${PORTSDIR}/misc/p5-Geography-Countries
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= ip2cc.1
MAN3= IP::Authority.3 \
diff --git a/net/p5-Net-Amazon-MechanicalTurk/Makefile b/net/p5-Net-Amazon-MechanicalTurk/Makefile
index f7718a8c54d0..8132d8945969 100644
--- a/net/p5-Net-Amazon-MechanicalTurk/Makefile
+++ b/net/p5-Net-Amazon-MechanicalTurk/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-Mozilla-CA>=0:${PORTSDIR}/www/p5-Mozilla-CA
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Amazon::MechanicalTurk.3 \
Net::Amazon::MechanicalTurk::BulkSupport.3 \
diff --git a/net/p5-Net-Google-Analytics/Makefile b/net/p5-Net-Google-Analytics/Makefile
index 9967a1a2581a..b660f28316c3 100644
--- a/net/p5-Net-Google-Analytics/Makefile
+++ b/net/p5-Net-Google-Analytics/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= \
p5-URI>0:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Google::Analytics.3 \
Net::Google::Analytics::OAuth2.3 \
diff --git a/net/p5-Net-GrowlClient/Makefile b/net/p5-Net-GrowlClient/Makefile
index 38e1c03879fd..ecdff080a457 100644
--- a/net/p5-Net-GrowlClient/Makefile
+++ b/net/p5-Net-GrowlClient/Makefile
@@ -16,7 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= markun@onohara.to
COMMENT= Perl implementation of Growl Network Notification Protocol
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::GrowlClient.3
diff --git a/net/p5-Net-LDAP-AutoServer/Makefile b/net/p5-Net-LDAP-AutoServer/Makefile
index ab2a1ef04863..c7efd1be644b 100644
--- a/net/p5-Net-LDAP-AutoServer/Makefile
+++ b/net/p5-Net-LDAP-AutoServer/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
p5-Net-DNS-RR-SRV-Helper>=0:${PORTSDIR}/dns/p5-Net-DNS-RR-SRV-Helper
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LDAP::AutoServer.3
diff --git a/net/p5-Net-OAuth-Simple/Makefile b/net/p5-Net-OAuth-Simple/Makefile
index cd97ac8350cd..702a73b40a67 100644
--- a/net/p5-Net-OAuth-Simple/Makefile
+++ b/net/p5-Net-OAuth-Simple/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-Crypt-SSLeay>=0.57:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-Test-Simple>=0.86:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::OAuth::Simple.3
.include <bsd.port.mk>
diff --git a/net/p5-Net-Packet/Makefile b/net/p5-Net-Packet/Makefile
index 3737ca4fa237..9b9a240952a2 100644
--- a/net/p5-Net-Packet/Makefile
+++ b/net/p5-Net-Packet/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Bit-Vector>=6.4:${PORTSDIR}/math/p5-Bit-Vector \
p5-Socket6>=0.19:${PORTSDIR}/net/p5-Socket6
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
MAN3= Net::Packet.3 Net::Packet::ARP.3 Net::Packet::CDP.3 Net::Packet::CDP::Address.3 \
diff --git a/net/p5-Net-SMS-Mollie/Makefile b/net/p5-Net-SMS-Mollie/Makefile
index fafc8e5a4b4c..1cb1ce6e787e 100644
--- a/net/p5-Net-SMS-Mollie/Makefile
+++ b/net/p5-Net-SMS-Mollie/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= b.smeelen@ose.nl
COMMENT= Send SMS messages via the mollie.nl service
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
RUN_DEPENDS+= p5-Test-Simple>=0.44:${PORTSDIR}/devel/p5-Test-Simple \
diff --git a/net/p5-Net-STOMP-Client/Makefile b/net/p5-Net-STOMP-Client/Makefile
index 6221d9c7aa6a..fcdd1db712af 100644
--- a/net/p5-Net-STOMP-Client/Makefile
+++ b/net/p5-Net-STOMP-Client/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::STOMP::Client.3 \
Net::STOMP::Client::Auth.3 \
diff --git a/net/p5-Net-Server-Coro/Makefile b/net/p5-Net-Server-Coro/Makefile
index a04d82a8e17c..d2ff1a2a73b3 100644
--- a/net/p5-Net-Server-Coro/Makefile
+++ b/net/p5-Net-Server-Coro/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= \
p5-Net-Server>=2:${PORTSDIR}/net/p5-Net-Server
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Server::Coro.3
diff --git a/net/p5-Net-Trackback/Makefile b/net/p5-Net-Trackback/Makefile
index 808fad43f31a..2dccfbda513a 100644
--- a/net/p5-Net-Trackback/Makefile
+++ b/net/p5-Net-Trackback/Makefile
@@ -26,6 +26,7 @@ MAN3= Net::Trackback.3 \
Net::Trackback::Ping.3 \
Net::Trackback::Server.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/p5-Net-Z3950-SimpleServer/Makefile b/net/p5-Net-Z3950-SimpleServer/Makefile
index 2f9d06c8e2f2..db897b8e65a0 100644
--- a/net/p5-Net-Z3950-SimpleServer/Makefile
+++ b/net/p5-Net-Z3950-SimpleServer/Makefile
@@ -16,7 +16,8 @@ COMMENT= A Perl module for developing Z39.50 servers
LIB_DEPENDS= yaz:${PORTSDIR}/net/yaz
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
MAN3= Net::Z3950::GRS1.3 Net::Z3950::SimpleServer.3
diff --git a/net/p5-Script-isAperlScript/Makefile b/net/p5-Script-isAperlScript/Makefile
index a9326531a4eb..46ad0dca29a8 100644
--- a/net/p5-Script-isAperlScript/Makefile
+++ b/net/p5-Script-isAperlScript/Makefile
@@ -13,7 +13,8 @@ COMMENT= Checks if something is a Perl script
RUN_DEPENDS= p5-Error-Helper>=1.0.0:${PORTSDIR}/devel/p5-Error-Helper
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Script::isAperlScript.3
diff --git a/net/p5-WebService-Prowl/Makefile b/net/p5-WebService-Prowl/Makefile
index b9edf8ff0c65..cf011ccdaa12 100644
--- a/net/p5-WebService-Prowl/Makefile
+++ b/net/p5-WebService-Prowl/Makefile
@@ -24,7 +24,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::Prowl.3 WebService::Prowl::AnyEventHTTP.3
diff --git a/net/p5-XML-Compile-SOAP-WSA/Makefile b/net/p5-XML-Compile-SOAP-WSA/Makefile
index edb8e7866884..746a3e18c57e 100644
--- a/net/p5-XML-Compile-SOAP-WSA/Makefile
+++ b/net/p5-XML-Compile-SOAP-WSA/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-Net-Server>=0.97:${PORTSDIR}/net/p5-Net-Server \
p5-XML-Compile-Cache>=0.91:${PORTSDIR}/textproc/p5-XML-Compile-Cache
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::Compile::SOAP::WSA.3 \
XML::Compile::SOAP::WSA::Util.3
diff --git a/net/p5-ZConf/Makefile b/net/p5-ZConf/Makefile
index a8c1cca8a0a6..f2dc752613a0 100644
--- a/net/p5-ZConf/Makefile
+++ b/net/p5-ZConf/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Chooser>=0:${PORTSDIR}/devel/p5-Chooser \
p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ZConf.3 \
ZConf::backends::file.3 \
diff --git a/net/slirp/Makefile b/net/slirp/Makefile
index 3abd7b2558aa..de1dac296c19 100644
--- a/net/slirp/Makefile
+++ b/net/slirp/Makefile
@@ -19,7 +19,8 @@ ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
MAN1= slirp.1