aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/qca-ossl/Makefile35
-rw-r--r--security/qca-ossl/distinfo3
-rw-r--r--security/qca-ossl/pkg-descr18
-rw-r--r--security/qca-ossl/pkg-plist4
5 files changed, 61 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ddbc5e8e227a..9a3b6807899f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -645,6 +645,7 @@
SUBDIR += py-twistedConch
SUBDIR += py-twofish
SUBDIR += py-xmlsec
+ SUBDIR += qca-ossl
SUBDIR += qca-tls
SUBDIR += qident
SUBDIR += qtfw
diff --git a/security/qca-ossl/Makefile b/security/qca-ossl/Makefile
new file mode 100644
index 000000000000..8b6e353329ab
--- /dev/null
+++ b/security/qca-ossl/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: qca-ossl
+# Date created: 2008-07-13
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= qca-ossl
+DISTVERSION= 2.0.0-beta3
+CATEGORIES= security
+MASTER_SITES= http://delta.affinix.com/download/qca/2.0/plugins/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Cross-platform crypto API for QT
+
+LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+USE_GNOME= pkgconfig
+HAS_CONFIGURE= yes
+QT_NONSTANDARD= yes
+QT_COMPONENTS= corelib qmake_build moc_build
+USE_OPENSSL= yes
+
+CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
+ PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
+ PTHREAD_LDFLAGS=${PTHREAD_LIBS}
+CONFIGURE_ARGS= --plugins-path=${PREFIX}/${QT_PLUGINDIR} --qtdir=${LOCALBASE} \
+ --with-qca=${LOCALBASE}
+
+QT_PLUGINDIR= lib/qt4/plugins
+
+PLIST_SUB+= QT_PLUGINDIR="${QT_PLUGINDIR}"
+
+.include <bsd.port.mk>
diff --git a/security/qca-ossl/distinfo b/security/qca-ossl/distinfo
new file mode 100644
index 000000000000..c2ce455f4801
--- /dev/null
+++ b/security/qca-ossl/distinfo
@@ -0,0 +1,3 @@
+MD5 (qca-ossl-2.0.0-beta3.tar.bz2) = bdc62c01321385c7da8d27b3902910ce
+SHA256 (qca-ossl-2.0.0-beta3.tar.bz2) = 08e09ff586b184d5fb53b88f0b48eed0a7bf0a5f210a9f97a76cf4cd5446c67b
+SIZE (qca-ossl-2.0.0-beta3.tar.bz2) = 49188
diff --git a/security/qca-ossl/pkg-descr b/security/qca-ossl/pkg-descr
new file mode 100644
index 000000000000..0b268d2f9f48
--- /dev/null
+++ b/security/qca-ossl/pkg-descr
@@ -0,0 +1,18 @@
+Taking a hint from the similarly-named Java Cryptography Architecture,
+QCA aims to provide a straightforward and cross-platform crypto
+API, using Qt datatypes and conventions. QCA separates the API from
+the implementation, using plugins known as Providers. The advantage
+of this model is to allow applications to avoid linking to or
+explicitly depending on any particular cryptographic library. This
+allows one to easily change or upgrade crypto implementations
+without even needing to recompile the application. QCA should work
+everywhere Qt does, including Windows/Unix/MacOSX.
+
+Capabilities:
+TLS, CMS, X.509, RSA, DSA, Diffie-Hellman, PKCS#7, PKCS#12, SHA0,
+SHA1, SHA224, SHA256, SHA384, SHA512, MD2, MD4, MD5, RIPEMD160,
+Blowfish, DES, 3DES, AES128, AES192, AES256, CAST5, HMAC(SHA1, MD5,
+RIPEMD160), PBKDF1(MD2, SHA1), PBKDF2(SHA1)
+
+
+WWW: http://delta.affinix.com/qca/
diff --git a/security/qca-ossl/pkg-plist b/security/qca-ossl/pkg-plist
new file mode 100644
index 000000000000..ff1b23b73135
--- /dev/null
+++ b/security/qca-ossl/pkg-plist
@@ -0,0 +1,4 @@
+lib/qt4/plugins/crypto/libqca-ossl.so
+lib/qt4/plugins/crypto/libqca-ossl.so.debug
+@dirrmtry %%QT_PLUGINDIR%%/crypto
+@dirrmtry %%QT_PLUGINDIR%%