aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/chromium/Makefile1
-rw-r--r--www/chromium/files/patch-chrome__browser__notifications__message_center_notification_manager.cc11
-rw-r--r--www/chromium/files/patch-ui__resources__ui_resources.grd11
3 files changed, 23 insertions, 0 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 8fbb6504b0bf..4f817474f235 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -3,6 +3,7 @@
PORTNAME= chromium
PORTVERSION= 38.0.2125.101
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/www/chromium/files/patch-chrome__browser__notifications__message_center_notification_manager.cc b/www/chromium/files/patch-chrome__browser__notifications__message_center_notification_manager.cc
new file mode 100644
index 000000000000..94abe02b4692
--- /dev/null
+++ b/www/chromium/files/patch-chrome__browser__notifications__message_center_notification_manager.cc
@@ -0,0 +1,11 @@
+--- chrome/browser/notifications/message_center_notification_manager.cc.orig 2014-09-10 01:47:12.000000000 +0200
++++ chrome/browser/notifications/message_center_notification_manager.cc 2014-09-18 14:21:16.000000000 +0200
+@@ -84,7 +84,7 @@
+ blockers_.push_back(new FullscreenNotificationBlocker(message_center));
+
+ #if defined(OS_WIN) || defined(OS_MACOSX) \
+- || (defined(OS_LINUX) && !defined(OS_CHROMEOS))
++ || (defined(OS_LINUX) && !defined(OS_CHROMEOS)) || defined(OS_BSD)
+ // On Windows, Linux and Mac, the notification manager owns the tray icon and
+ // views.Other platforms have global ownership and Create will return NULL.
+ tray_.reset(message_center::CreateMessageCenterTray());
diff --git a/www/chromium/files/patch-ui__resources__ui_resources.grd b/www/chromium/files/patch-ui__resources__ui_resources.grd
new file mode 100644
index 000000000000..9540badb4cac
--- /dev/null
+++ b/www/chromium/files/patch-ui__resources__ui_resources.grd
@@ -0,0 +1,11 @@
+--- ui/resources/ui_resources.grd.orig 2014-09-10 01:47:14.000000000 +0200
++++ ui/resources/ui_resources.grd 2014-09-17 13:51:43.000000000 +0200
+@@ -39,7 +39,7 @@
+ <structure type="chrome_scaled_image" name="IDR_APP_TOP_LEFT" file="app_top_left.png" />
+ <structure type="chrome_scaled_image" name="IDR_APP_TOP_RIGHT" file="app_top_right.png" />
+ </if>
+- <if expr="is_linux and use_aura">
++ <if expr="(is_linux or is_bsd) and use_aura">
+ <structure type="chrome_scaled_image" name="IDR_AURA_CURSOR_BIG_ALIAS" file="common/pointers/alias_big.png" />
+ <structure type="chrome_scaled_image" name="IDR_AURA_CURSOR_BIG_CELL" file="common/pointers/cell_big.png" />
+ <structure type="chrome_scaled_image" name="IDR_AURA_CURSOR_BIG_COL_RESIZE" file="common/pointers/sb_h_double_arrow_big.png" />