aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/junipoll/Makefile24
-rw-r--r--net-mgmt/junipoll/distinfo1
-rw-r--r--net-mgmt/junipoll/pkg-descr10
-rw-r--r--net-mgmt/junipoll/pkg-plist3
-rw-r--r--net/Makefile1
-rw-r--r--net/junipoll/Makefile24
-rw-r--r--net/junipoll/distinfo1
-rw-r--r--net/junipoll/pkg-descr10
-rw-r--r--net/junipoll/pkg-plist3
9 files changed, 77 insertions, 0 deletions
diff --git a/net-mgmt/junipoll/Makefile b/net-mgmt/junipoll/Makefile
new file mode 100644
index 000000000000..cafe2db0f37a
--- /dev/null
+++ b/net-mgmt/junipoll/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: junipoll
+# Date created: Tue Jun 17 17:28:52 PDT 2003
+# Whom: Bill Fumerola <billf@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= junipoll
+PORTVERSION= 1.015
+CATEGORIES= net perl5
+MASTER_SITES= http://dave.plonka.us/junipoll/%SUBDIR%/
+MASTER_SITE_SUBDIR= . old
+
+MAINTAINER= billf@FreeBSD.org
+COMMENT= JUNIper router snmp POLLer for firewall filter counters
+
+RUN_DEPENDS= rrdtool:${PORTSDIR}/net/rrdtool \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Altoids.pm:${PORTSDIR}/net/p5-Altoids
+
+PERL_CONFIGURE= yes
+
+MAN1= junipoll.1
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/junipoll/distinfo b/net-mgmt/junipoll/distinfo
new file mode 100644
index 000000000000..5f8766315cfb
--- /dev/null
+++ b/net-mgmt/junipoll/distinfo
@@ -0,0 +1 @@
+MD5 (junipoll-1.015.tar.gz) = 3a7ef125af50ba2b7145372da152d6e4
diff --git a/net-mgmt/junipoll/pkg-descr b/net-mgmt/junipoll/pkg-descr
new file mode 100644
index 000000000000..6c94cc0fa59e
--- /dev/null
+++ b/net-mgmt/junipoll/pkg-descr
@@ -0,0 +1,10 @@
+junipoll is an mrtg-like utility which polls the counter values from the
+firewall filters configured on Juniper routers. It creates ".rrd" files
+with names matching the router and its filter counter names, each
+containing a bytes and a pkts data source suitable for graphing using
+RRGrapher or RRDTOOL.
+
+WWW: http://dave.plonka.us/junipoll/
+
+- Bill Fumerola
+billf@FreeBSD.org
diff --git a/net-mgmt/junipoll/pkg-plist b/net-mgmt/junipoll/pkg-plist
new file mode 100644
index 000000000000..d6c2fba1ac9c
--- /dev/null
+++ b/net-mgmt/junipoll/pkg-plist
@@ -0,0 +1,3 @@
+bin/junipoll
+lib/perl5/site_perl/%%PERL_VER%%/HCInterfaceTemplate.pl
+lib/perl5/site_perl/%%PERL_VER%%/mach/auto/junipoll/.packlist
diff --git a/net/Makefile b/net/Makefile
index 3e8c53c18e15..f2abe2cd930a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -257,6 +257,7 @@
SUBDIR += java-beepcore
SUBDIR += javadc
SUBDIR += jumpgate
+ SUBDIR += junipoll
SUBDIR += jwhois
SUBDIR += kdenetwork3
SUBDIR += kmerlin
diff --git a/net/junipoll/Makefile b/net/junipoll/Makefile
new file mode 100644
index 000000000000..cafe2db0f37a
--- /dev/null
+++ b/net/junipoll/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: junipoll
+# Date created: Tue Jun 17 17:28:52 PDT 2003
+# Whom: Bill Fumerola <billf@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= junipoll
+PORTVERSION= 1.015
+CATEGORIES= net perl5
+MASTER_SITES= http://dave.plonka.us/junipoll/%SUBDIR%/
+MASTER_SITE_SUBDIR= . old
+
+MAINTAINER= billf@FreeBSD.org
+COMMENT= JUNIper router snmp POLLer for firewall filter counters
+
+RUN_DEPENDS= rrdtool:${PORTSDIR}/net/rrdtool \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Altoids.pm:${PORTSDIR}/net/p5-Altoids
+
+PERL_CONFIGURE= yes
+
+MAN1= junipoll.1
+
+.include <bsd.port.mk>
diff --git a/net/junipoll/distinfo b/net/junipoll/distinfo
new file mode 100644
index 000000000000..5f8766315cfb
--- /dev/null
+++ b/net/junipoll/distinfo
@@ -0,0 +1 @@
+MD5 (junipoll-1.015.tar.gz) = 3a7ef125af50ba2b7145372da152d6e4
diff --git a/net/junipoll/pkg-descr b/net/junipoll/pkg-descr
new file mode 100644
index 000000000000..6c94cc0fa59e
--- /dev/null
+++ b/net/junipoll/pkg-descr
@@ -0,0 +1,10 @@
+junipoll is an mrtg-like utility which polls the counter values from the
+firewall filters configured on Juniper routers. It creates ".rrd" files
+with names matching the router and its filter counter names, each
+containing a bytes and a pkts data source suitable for graphing using
+RRGrapher or RRDTOOL.
+
+WWW: http://dave.plonka.us/junipoll/
+
+- Bill Fumerola
+billf@FreeBSD.org
diff --git a/net/junipoll/pkg-plist b/net/junipoll/pkg-plist
new file mode 100644
index 000000000000..d6c2fba1ac9c
--- /dev/null
+++ b/net/junipoll/pkg-plist
@@ -0,0 +1,3 @@
+bin/junipoll
+lib/perl5/site_perl/%%PERL_VER%%/HCInterfaceTemplate.pl
+lib/perl5/site_perl/%%PERL_VER%%/mach/auto/junipoll/.packlist