aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/p5-PerlIO-via-Bzip2/Makefile2
-rw-r--r--net-im/p5-Jabber-SimpleSend/Makefile4
-rw-r--r--net-im/p5-Net-OSCAR/Makefile2
-rw-r--r--net/p5-AddressBook/Makefile4
-rw-r--r--net/p5-Net-Blogger/Makefile6
-rw-r--r--net/p5-Net-CSTA/Makefile4
-rw-r--r--net/p5-Net-Frame-Dump/Makefile4
-rw-r--r--net/p5-Net-Google/Makefile2
-rw-r--r--net/p5-POE-Component-Generic/Makefile4
-rw-r--r--net/p5-PlRPC/Makefile2
-rw-r--r--net/p5-ResourcePool-Resource-Net-LDAP/Makefile4
-rw-r--r--net/p5-Samba-LDAP/Makefile20
-rw-r--r--net/p5-Validate-Net/Makefile2
-rw-r--r--print/p5-PDFLib/Makefile2
-rw-r--r--security/p5-Authen-Simple-Passwd/Makefile2
15 files changed, 32 insertions, 32 deletions
diff --git a/archivers/p5-PerlIO-via-Bzip2/Makefile b/archivers/p5-PerlIO-via-Bzip2/Makefile
index 15830d72f46a..5437dc90fa11 100644
--- a/archivers/p5-PerlIO-via-Bzip2/Makefile
+++ b/archivers/p5-PerlIO-via-Bzip2/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension to provide a PerlIO layer to bzip2/bunzip2
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Bzip2.pm:${PORTSDIR}/archivers/p5-Compress-Bzip2
+BUILD_DEPENDS= p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net-im/p5-Jabber-SimpleSend/Makefile b/net-im/p5-Jabber-SimpleSend/Makefile
index 5e4f5ab04a9f..5280a3969cc0 100644
--- a/net-im/p5-Jabber-SimpleSend/Makefile
+++ b/net-im/p5-Jabber-SimpleSend/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Send a Jabber message simply
-RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Net/Jabber.pm:${PORTSDIR}/net-im/p5-Net-Jabber
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Net-Jabber>=0:${PORTSDIR}/net-im/p5-Net-Jabber
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net-im/p5-Net-OSCAR/Makefile b/net-im/p5-Net-OSCAR/Makefile
index e3cb46db8b61..67d47be1e2d9 100644
--- a/net-im/p5-Net-OSCAR/Makefile
+++ b/net-im/p5-Net-OSCAR/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for the AOL Instant Messenger OSCAR protocol
-BUILD_DEPENDS= ${SITE_PERL}/Net/SOCKS.pm:${PORTSDIR}/net/p5-Socks \
+BUILD_DEPENDS= p5-Socks>=0:${PORTSDIR}/net/p5-Socks \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/net/p5-AddressBook/Makefile b/net/p5-AddressBook/Makefile
index a900def1c485..15f25663498d 100644
--- a/net/p5-AddressBook/Makefile
+++ b/net/p5-AddressBook/Makefile
@@ -16,8 +16,8 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module providing an LDAP addressbook interface
USE_PERL5= yes
-RUN_DEPENDS= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
+RUN_DEPENDS= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
NO_BUILD= yes
ALL_FILES= AddressBook.pm AddressBook/Entry.pm AddressBook/Config.pm \
diff --git a/net/p5-Net-Blogger/Makefile b/net/p5-Net-Blogger/Makefile
index 68cfef37801b..22c24596ff02 100644
--- a/net/p5-Net-Blogger/Makefile
+++ b/net/p5-Net-Blogger/Makefile
@@ -16,9 +16,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= An OOP-ish interface for accessing a weblog via the XML-RPC API
-BUILD_DEPENDS= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/HTTP/Cookies.pm:${PORTSDIR}/www/p5-libwww \
+BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-SOAP-Lite>0.55:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
diff --git a/net/p5-Net-CSTA/Makefile b/net/p5-Net-CSTA/Makefile
index 381656d0654b..9e85df3153b6 100644
--- a/net/p5-Net-CSTA/Makefile
+++ b/net/p5-Net-CSTA/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for ECMA CSTA
-RUN_DEPENDS= ${SITE_PERL}/Convert/ASN1.pm:${PORTSDIR}/converters/p5-Convert-ASN1 \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS= p5-Convert-ASN1>=0:${PORTSDIR}/converters/p5-Convert-ASN1 \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Frame-Dump/Makefile b/net/p5-Net-Frame-Dump/Makefile
index b0917ece528b..ee8694e986ce 100644
--- a/net/p5-Net-Frame-Dump/Makefile
+++ b/net/p5-Net-Frame-Dump/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Tcpdump like perl implementation
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Bit/Vector.pm:${PORTSDIR}/math/p5-Bit-Vector \
- ${SITE_PERL}/Net/Frame.pm:${PORTSDIR}/net/p5-Net-Frame \
+BUILD_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
+ p5-Net-Frame>=0:${PORTSDIR}/net/p5-Net-Frame \
p5-Net-Pcap>=0.12:${PORTSDIR}/net/p5-Net-Pcap \
p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/net/p5-Net-Google/Makefile b/net/p5-Net-Google/Makefile
index 041a3694551c..9a262178c891 100644
--- a/net/p5-Net-Google/Makefile
+++ b/net/p5-Net-Google/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple OOP-ish interface to the Google SOAP API
-BUILD_DEPENDS= ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+BUILD_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/net/p5-POE-Component-Generic/Makefile b/net/p5-POE-Component-Generic/Makefile
index dc14fd81c4dd..4f2e811613a0 100644
--- a/net/p5-POE-Component-Generic/Makefile
+++ b/net/p5-POE-Component-Generic/Makefile
@@ -16,8 +16,8 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Provides non-blocking access to a blocking object
RUN_DEPENDS= p5-POE>=0.31:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
- ${SITE_PERL}/${PERL_ARCH}/Net/SSH2.pm:${PORTSDIR}/net/p5-Net-SSH2
+ p5-Devel-Symdump>=0:${PORTSDIR}/devel/p5-Devel-Symdump \
+ p5-Net-SSH2>=0:${PORTSDIR}/net/p5-Net-SSH2
PERL_CONFIGURE= yes
diff --git a/net/p5-PlRPC/Makefile b/net/p5-PlRPC/Makefile
index 92af38eb693c..afbaa883024c 100644
--- a/net/p5-PlRPC/Makefile
+++ b/net/p5-PlRPC/Makefile
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for writing RPC servers and clients
-BUILD_DEPENDS= ${SITE_PERL}/Net/Daemon.pm:${PORTSDIR}/net/p5-Net-Daemon
+BUILD_DEPENDS= p5-Net-Daemon>=0:${PORTSDIR}/net/p5-Net-Daemon
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-ResourcePool-Resource-Net-LDAP/Makefile b/net/p5-ResourcePool-Resource-Net-LDAP/Makefile
index af355a7f09e7..f1248da498ae 100644
--- a/net/p5-ResourcePool-Resource-Net-LDAP/Makefile
+++ b/net/p5-ResourcePool-Resource-Net-LDAP/Makefile
@@ -16,8 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A ResourcePool wrapper for Net::LDAP
-BUILD_DEPENDS= ${SITE_PERL}/ResourcePool.pm:${PORTSDIR}/devel/p5-ResourcePool \
- ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+BUILD_DEPENDS= p5-ResourcePool>=0:${PORTSDIR}/devel/p5-ResourcePool \
+ p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Samba-LDAP/Makefile b/net/p5-Samba-LDAP/Makefile
index 09f97661b1da..a8ac7cc035ed 100644
--- a/net/p5-Samba-LDAP/Makefile
+++ b/net/p5-Samba-LDAP/Makefile
@@ -16,16 +16,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Manage a Samba PDC with an LDAP Backend
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils \
- ${SITE_PERL}/${PERL_ARCH}/Readonly.pm:${PORTSDIR}/devel/p5-Readonly \
- ${SITE_PERL}/Class/Base.pm:${PORTSDIR}/devel/p5-Class-Base \
- ${SITE_PERL}/Config/Tiny.pm:${PORTSDIR}/devel/p5-Config-Tiny \
- ${SITE_PERL}/Crypt/SmbHash.pm:${PORTSDIR}/security/p5-Crypt-SmbHash \
- ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
- ${SITE_PERL}/Regexp/DefaultFlags.pm:${PORTSDIR}/textproc/p5-Regexp-DefaultFlags \
- ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
- ${SITE_PERL}/Unicode/MapUTF8.pm:${PORTSDIR}/converters/p5-Unicode-MapUTF8
+BUILD_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Readonly>=0:${PORTSDIR}/devel/p5-Readonly \
+ p5-Class-Base>=0:${PORTSDIR}/devel/p5-Class-Base \
+ p5-Config-Tiny>=0:${PORTSDIR}/devel/p5-Config-Tiny \
+ p5-Crypt-SmbHash>=0:${PORTSDIR}/security/p5-Crypt-SmbHash \
+ p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
+ p5-Regexp-DefaultFlags>=0:${PORTSDIR}/textproc/p5-Regexp-DefaultFlags \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ p5-Unicode-MapUTF8>=0:${PORTSDIR}/converters/p5-Unicode-MapUTF8
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Validate-Net/Makefile b/net/p5-Validate-Net/Makefile
index 6d3454c421e1..e27e02f70d0a 100644
--- a/net/p5-Validate-Net/Makefile
+++ b/net/p5-Validate-Net/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Format validation and more for Net:: related strings
-BUILD_DEPENDS= ${SITE_PERL}/Class/Default.pm:${PORTSDIR}/devel/p5-Class-Default
+BUILD_DEPENDS= p5-Class-Default>=0:${PORTSDIR}/devel/p5-Class-Default
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/print/p5-PDFLib/Makefile b/print/p5-PDFLib/Makefile
index fbb1b6009aa9..94f9fb7fafa7 100644
--- a/print/p5-PDFLib/Makefile
+++ b/print/p5-PDFLib/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= More OO interface to pdflib_pl.pm
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/pdflib_pl.pm:${PORTSDIR}/print/pdflib-perl
+BUILD_DEPENDS= pdflib-perl>=0:${PORTSDIR}/print/pdflib-perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Authen-Simple-Passwd/Makefile b/security/p5-Authen-Simple-Passwd/Makefile
index 053194663974..5e42ccf2ced4 100644
--- a/security/p5-Authen-Simple-Passwd/Makefile
+++ b/security/p5-Authen-Simple-Passwd/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple Passwd authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_SAFE= yes