aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/nip/Makefile4
-rw-r--r--graphics/nip2/Makefile4
-rw-r--r--net-im/gyach/Makefile8
-rw-r--r--net-im/meanwhile/Makefile8
-rw-r--r--net/gyach/Makefile8
-rw-r--r--net/meanwhile/Makefile8
6 files changed, 32 insertions, 8 deletions
diff --git a/graphics/nip/Makefile b/graphics/nip/Makefile
index 22b99ae76780..bc931d74984e 100644
--- a/graphics/nip/Makefile
+++ b/graphics/nip/Makefile
@@ -28,8 +28,8 @@ MAN1= nip.1
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" || ${ARCH} == "amd64"
-BROKEN= "Does not compile on alpha or amd64"
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
.endif
post-patch:
diff --git a/graphics/nip2/Makefile b/graphics/nip2/Makefile
index 22b99ae76780..bc931d74984e 100644
--- a/graphics/nip2/Makefile
+++ b/graphics/nip2/Makefile
@@ -28,8 +28,8 @@ MAN1= nip.1
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" || ${ARCH} == "amd64"
-BROKEN= "Does not compile on alpha or amd64"
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
.endif
post-patch:
diff --git a/net-im/gyach/Makefile b/net-im/gyach/Makefile
index a24b1dc67832..3961273c9120 100644
--- a/net-im/gyach/Makefile
+++ b/net-im/gyach/Makefile
@@ -20,4 +20,10 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_FLAGS}" \
USE_GNOME= gtk20
USE_X_PREFIX= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/meanwhile/Makefile b/net-im/meanwhile/Makefile
index aa7c8ed3246e..a9ef240a6519 100644
--- a/net-im/meanwhile/Makefile
+++ b/net-im/meanwhile/Makefile
@@ -20,4 +20,10 @@ USE_GNOME= gnomehack glib20
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/gyach/Makefile b/net/gyach/Makefile
index a24b1dc67832..3961273c9120 100644
--- a/net/gyach/Makefile
+++ b/net/gyach/Makefile
@@ -20,4 +20,10 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_FLAGS}" \
USE_GNOME= gtk20
USE_X_PREFIX= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/meanwhile/Makefile b/net/meanwhile/Makefile
index aa7c8ed3246e..a9ef240a6519 100644
--- a/net/meanwhile/Makefile
+++ b/net/meanwhile/Makefile
@@ -20,4 +20,10 @@ USE_GNOME= gnomehack glib20
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
+.include <bsd.port.post.mk>