aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/unace/Makefile13
-rw-r--r--audio/id3ren/Makefile11
-rw-r--r--devel/yacl/Makefile10
-rw-r--r--editors/uemacs/Makefile10
-rw-r--r--emulators/snes9x/Makefile10
-rw-r--r--games/crafty-open-large/Makefile9
-rw-r--r--games/crafty-open-medium/Makefile10
-rw-r--r--games/crafty-open-small/Makefile10
-rw-r--r--games/doom/Makefile11
-rw-r--r--games/inform/Makefile16
-rw-r--r--games/jzip/Makefile9
-rw-r--r--games/uox3/Makefile10
-rw-r--r--games/xpacman/Makefile9
-rw-r--r--graphics/pstoedit/Makefile8
-rw-r--r--japanese/pgp.language/Makefile8
-rw-r--r--japanese/qkc/Makefile9
-rw-r--r--korean/pgp.language/Makefile8
-rw-r--r--math/freefem/Makefile9
-rw-r--r--misc/estic/Makefile27
-rw-r--r--misc/estic/pkg-comment2
-rw-r--r--misc/estic/pkg-plist2
21 files changed, 61 insertions, 150 deletions
diff --git a/archivers/unace/Makefile b/archivers/unace/Makefile
index 72a31448483e..3369333474e9 100644
--- a/archivers/unace/Makefile
+++ b/archivers/unace/Makefile
@@ -4,30 +4,23 @@
# Date created: 23 February 1999
# Whom: Joao Carlos Mendes Luis <jonny@jonny.eng.br>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/04/02 04:19:20 steve Exp $
#
DISTNAME= unacepub
PKGNAME= unace-1.2b
CATEGORIES= archivers
MASTER_SITES= http://members.aol.com/mlemke6413/
-EXTRACT_SUFX= .zip
MAINTAINER= jonny@jonny.eng.br
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
FETCH_BEFORE_ARGS= -t
+USE_ZIP= yes
USE_GMAKE= yes
ALL_TARGET= unace
MAKEFILE= unix/makefile
-
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
- @${MKDIR} ${WRKSRC}
- @unzip -q -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} -d ${WRKSRC}
+NO_WRKSUBDIR= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/unace ${PREFIX}/bin
diff --git a/audio/id3ren/Makefile b/audio/id3ren/Makefile
index 1794bd6db09b..d8c14cf29bc5 100644
--- a/audio/id3ren/Makefile
+++ b/audio/id3ren/Makefile
@@ -4,24 +4,17 @@
# Date created: 28 February 1999
# Whom: Joao Carlos Mendes Luis <jonny@jonny.eng.br>
#
-# $Id: $
+# $Id: Makefile,v 1.1.1.1 1999/04/27 13:02:51 taoka Exp $
#
DISTNAME= id3ren97a
PKGNAME= id3ren-0.97a
CATEGORIES= audio
MASTER_SITES= http://tscnet.com/pages/badcrc/apps/id3ren/
-EXTRACT_SUFX= .zip
MAINTAINER= jonny@jonny.eng.br
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
+USE_ZIP= yes
WRKSRC= ${WRKDIR}/id3ren/src
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
- @unzip -q -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} -d ${WRKDIR}
-
.include <bsd.port.mk>
diff --git a/devel/yacl/Makefile b/devel/yacl/Makefile
index 767150d87031..f08e030068f8 100644
--- a/devel/yacl/Makefile
+++ b/devel/yacl/Makefile
@@ -3,21 +3,17 @@
# Date created: 6 March 1998
# Whom: Jeroen Hogeveen <albast@xs4all.nl>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/03/20 05:34:41 taoka Exp $
#
DISTNAME= yacl-0170-beta
PKGNAME= yacl-1.7b
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cs.sc.edu/pub/yacl/
-EXTRACT_SUFX= .zip
MAINTAINER= albast@xs4all.nl
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -qq -La
+USE_ZIP= yes
WRKSRC= ${WRKDIR}
MAKE_ENV= YACLPATH=${WRKDIR}
@@ -48,7 +44,7 @@ do-install:
@( cd ${PREFIX}/share/yacl; ln -s ${PREFIX}/lib/yacl lib; \
ln -s ${PREFIX}/include/yacl/io; ln -s ${PREFIX}/include/yacl/ui )
@${ECHO} "Done. Don't forget to set your YACLPATH environment "
- @${ECHO} -n "variable to "; ${ECHO} -n ${PREFIX}; ${ECHO} "/share/yacl!"
+ @${ECHO} -n "variable to ${PREFIX}/share/yacl!"
post-install:
@strip ${PREFIX}/share/yacl/apps/bmpview
diff --git a/editors/uemacs/Makefile b/editors/uemacs/Makefile
index f82c42288a60..1088fb64a8e7 100644
--- a/editors/uemacs/Makefile
+++ b/editors/uemacs/Makefile
@@ -3,25 +3,21 @@
# Date created: 16 Jan 1995
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
-# $Id: Makefile,v 1.10 1997/08/29 11:33:09 tg Exp $
+# $Id: Makefile,v 1.11 1998/03/25 14:14:53 tg Exp $
#
-DISTNAME= uemacs
+DISTNAME= ue400dev
PKGNAME= uemacs-4.0
CATEGORIES= editors
MASTER_SITES= ftp://aquest.com/pub/uemacs400/disk2/ \
ftp://informatik.hu-berlin.de/pub/pc/msdos/editors/ \
ftp://ftp.biomath.jussieu.fr/pub/editors/memacs400/disk2/
-DISTFILES= ue400dev.zip
MAINTAINER= ports@freebsd.org
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
NO_WRKSUBDIR= yes
-EXTRACT_CMD= unzip
+USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -Laq
-EXTRACT_AFTER_ARGS= -d ${WRKDIR}
FETCH_BEFORE_ARGS= -NP
.include <bsd.port.mk>
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index 1aad7d0ef3fa..40be66496de3 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -3,19 +3,17 @@
# Date created: 20 July 1997
# Whom: Yukihiro Nakai<Nakai@Mlab.t.u-tokyo.ac.jp>
#
-# $Id: Makefile,v 1.7 1999/02/03 11:11:42 asami Exp $
+# $Id: Makefile,v 1.8 1999/03/31 14:01:18 flathill Exp $
#
DISTNAME= snes118e
PKGNAME= snes9x-118e
CATEGORIES= emulators
MASTER_SITES= http://www.snes9x.com/zips/
-EXTRACT_SUFX= .zip
MAINTAINER= nacai@iname.com
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-BUILD_DEPENDS+= egcc:${PORTSDIR}/lang/pgcc
+BUILD_DEPENDS= egcc:${PORTSDIR}/lang/pgcc
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
ONLY_FOR_ARCHS= i386
@@ -25,9 +23,7 @@ USE_X_PREFIX= YES
MAKEFILE= Makefile.linux
ALL_TARGET= snes9x s9xserver
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= # empty
-EXTRACT_AFTER_ARGS= # empty
+USE_ZIP= yes
WRKSRC= ${WRKDIR}/release
diff --git a/games/crafty-open-large/Makefile b/games/crafty-open-large/Makefile
index 69d93341fff2..736814e08663 100644
--- a/games/crafty-open-large/Makefile
+++ b/games/crafty-open-large/Makefile
@@ -3,7 +3,7 @@
# Date created: 1 June 1998
# Whom: Stefan Eggers <seggers@semyam.dinoco.de>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/06/04 02:37:37 mph Exp $
#
DISTNAME= crafty-open-large-19960910
@@ -13,14 +13,11 @@ DISTFILES= large1.zip large2.zip large3.zip large4.zip
MAINTAINER= seggers@semyam.dinoco.de
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- crafty:${PORTSDIR}/games/crafty
+BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
DIST_SUBDIR= crafty
-EXTRACT_AFTER_ARGS=
-EXTRACT_BEFORE_ARGS=
-EXTRACT_CMD= unzip
+USE_ZIP= yes
NO_WRKSUBDIR= yes
post-extract:
diff --git a/games/crafty-open-medium/Makefile b/games/crafty-open-medium/Makefile
index d9d6de7d2e15..cdb8c621c48e 100644
--- a/games/crafty-open-medium/Makefile
+++ b/games/crafty-open-medium/Makefile
@@ -3,25 +3,21 @@
# Date created: 1 June 1998
# Whom: Stefan Eggers <seggers@semyam.dinoco.de>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/06/04 02:33:59 mph Exp $
#
DISTNAME= medium
PKGNAME= crafty-open-medium-19960910
CATEGORIES= games
MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/common/
-EXTRACT_SUFX= .zip
MAINTAINER= seggers@semyam.dinoco.de
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- crafty:${PORTSDIR}/games/crafty
+BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
DIST_SUBDIR= crafty
-EXTRACT_AFTER_ARGS=
-EXTRACT_BEFORE_ARGS=
-EXTRACT_CMD= unzip
+USE_ZIP= yes
NO_WRKSUBDIR= yes
do-build:
diff --git a/games/crafty-open-small/Makefile b/games/crafty-open-small/Makefile
index 8fa24333670d..b3cdc9903135 100644
--- a/games/crafty-open-small/Makefile
+++ b/games/crafty-open-small/Makefile
@@ -3,25 +3,21 @@
# Date created: 1 June 1998
# Whom: Stefan Eggers <seggers@semyam.dinoco.de>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/06/04 02:31:58 mph Exp $
#
DISTNAME= small
PKGNAME= crafty-open-small-19970301
CATEGORIES= games
MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/common/
-EXTRACT_SUFX= .zip
MAINTAINER= seggers@semyam.dinoco.de
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- crafty:${PORTSDIR}/games/crafty
+BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
DIST_SUBDIR= crafty
-EXTRACT_AFTER_ARGS=
-EXTRACT_BEFORE_ARGS=
-EXTRACT_CMD= unzip
+USE_ZIP= yes
NO_WRKSUBDIR= yes
do-build:
diff --git a/games/doom/Makefile b/games/doom/Makefile
index f8c15f6474f5..3e5f2a02cecd 100644
--- a/games/doom/Makefile
+++ b/games/doom/Makefile
@@ -3,22 +3,19 @@
# Date created: Mon Dec 14 21:03:01 MET 1998
# Whom: jmz
#
-# $Id: Makefile,v 1.11 1999/02/10 03:52:47 jmz Exp $
+# $Id: Makefile,v 1.12 1999/02/10 05:07:58 jmz Exp $
#
-DISTNAME= doomsrc-1.8
+DISTNAME= doomsrc
PKGNAME= doom-1.8
CATEGORIES= games
MASTER_SITES?= ftp://ftp.idsoftware.com/idstuff/source/ \
ftp://ftp.stomped.com/pub/idmirror/idstuff/source/ \
ftp://ftp.cdrom.com/pub/idgames/idstuff/source/ \
ftp://ftp.gamesnet.net/idsoftware/source/
-DISTFILES?= doomsrc.zip
MAINTAINER= jmz@FreeBSD.org
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
NO_CDROM= requested by IDsoftware
MASTER_SITES2= ftp://sunsite.unc.edu/pub/Linux/games/doom/ \
@@ -27,9 +24,7 @@ MASTER_SITES2= ftp://sunsite.unc.edu/pub/Linux/games/doom/ \
DISTFILES2= doom1v18.wad.gz
USE_XLIB= yes
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -q
-EXTRACT_AFTER_ARGS= # empty
+USE_ZIP= yes
NO_WRKSUBDIR= yes
USE_GMAKE= yes
diff --git a/games/inform/Makefile b/games/inform/Makefile
index fc38045fef24..93b5d85b02f3 100644
--- a/games/inform/Makefile
+++ b/games/inform/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 June 1998
# Whom: Matthew Hunt <mph@FreeBSD.org>
#
-# $Id: Makefile,v 1.2 1999/01/08 00:15:21 mph Exp $
+# $Id: Makefile,v 1.3 1999/02/03 11:11:44 asami Exp $
#
DISTNAME= inform-6.15
@@ -12,22 +12,18 @@ MASTER_SITES= ftp://ftp.gmd.de/if-archive/infocom/compilers/inform6/source/ \
ftp://ftp.gmd.de/if-archive/infocom/compilers/inform6/library/
DISTFILES= inform615_source.zip inform_library68.zip
+MAINTAINER= mph@freebsd.org
+
.if !defined(NOPORTDOCS)
MASTER_SITES+= ftp://ftp.gmd.de/if-archive/infocom/compilers/inform6/manuals/
DISTFILES+= designers_manual_html.zip
.endif
-MAINTAINER= mph@freebsd.org
-
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
DIST_SUBDIR= inform
NO_WRKSUBDIR= yes
-EXTRACT_ONLY= inform615_source.zip
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -qq
-EXTRACT_AFTER_ARGS= # empty
+EXTRACT_ONLY= inform615_source.zip
+USE_ZIP= yes
# I can hardly believe it, but the ".c" and ".h" extensions are
# not present on the source files.
@@ -35,7 +31,7 @@ post-extract:
@${MV} ${WRKSRC}/header ${WRKSRC}/header.h
.for file in arrays asm bpatch chars directs errors expressc expressp \
files inform lexer linker memory objects states symbols syntax \
- tables text veneer verbs
+ tables text veneer verbs
@${MV} ${WRKSRC}/${file} ${WRKSRC}/${file}.c
.endfor
@${CP} ${FILESDIR}/Makefile.inform ${WRKSRC}/Makefile
diff --git a/games/jzip/Makefile b/games/jzip/Makefile
index 613a5bd92602..6d3302a6941e 100644
--- a/games/jzip/Makefile
+++ b/games/jzip/Makefile
@@ -3,22 +3,17 @@
# Date created: 7 May 1998
# Whom: Matthew Hunt <mph@FreeBSD.org>
#
-# $Id: Makefile,v 1.3 1998/07/05 04:15:04 mph Exp $
+# $Id: Makefile,v 1.4 1999/02/03 11:11:44 asami Exp $
#
DISTNAME= jzip201g
PKGNAME= jzip-2.0.1g
CATEGORIES= games
MASTER_SITES= http://www.freebsd.org/~mph/distfiles/
-EXTRACT_SUFX= .zip
MAINTAINER= mph@freebsd.org
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -qq
-EXTRACT_AFTER_ARGS= # empty
+USE_ZIP= yes
NO_WRKSUBDIR= yes
diff --git a/games/uox3/Makefile b/games/uox3/Makefile
index 399caa04123a..9948d02bc21f 100644
--- a/games/uox3/Makefile
+++ b/games/uox3/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 Feb 1999
# Whom: Donald Burr <dburr@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.1.1.1 1999/02/25 06:55:49 dburr Exp $
+# $Id: Makefile,v 1.2 1999/02/28 09:30:56 dburr Exp $
#
DISTNAME= uox3v6902-linux
@@ -11,18 +11,12 @@ PKGNAME= uox3-0.69.02
CATEGORIES= games
MASTER_SITES= ftp://provolone.dynip.com/pub/ \
http://users.1st.net/magda/
-EXTRACT_SUFX= .zip
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} tqpsworld${EXTRACT_SUFX}
MAINTAINER= dburr@FreeBSD.ORG
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
DIST_SUBDIR= uox3
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -qa
-EXTRACT_AFTER_ARGS= # This space left intentionally blank.
-
+USE_ZIP= YES
NO_WRKSUBDIR= YES
USE_GMAKE= YES
diff --git a/games/xpacman/Makefile b/games/xpacman/Makefile
index 2cc69c30f10e..62e313a47e76 100644
--- a/games/xpacman/Makefile
+++ b/games/xpacman/Makefile
@@ -3,23 +3,18 @@
# Date created: 19 Aug 1995
# Whom: joerg
#
-# $Id: Makefile,v 1.5 1998/09/28 02:25:21 steve Exp $
+# $Id: Makefile,v 1.6 1999/02/03 11:11:45 asami Exp $
#
DISTNAME= pacman10
PKGNAME= xpacman-1.0
CATEGORIES= games
MASTER_SITES= ftp://ftp.nvg.unit.no/pub/pacman/
-EXTRACT_SUFX= .zip
MAINTAINER= joerg@FreeBSD.org
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
NO_WRKSUBDIR= Does not unpack into subdir.
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -x
-EXTRACT_AFTER_ARGS= # empty
+USE_ZIP= yes
USE_IMAKE= yes
MAN1= pacman.1
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index 59b3b65171b6..22cbe5a9f933 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -3,24 +3,20 @@
# Date created: 03 July 1998
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.5 1998/08/10 13:26:34 steve Exp $
+# $Id: Makefile,v 1.6 1999/04/19 18:00:07 jseger Exp $
#
DISTNAME= pstoedit_3_11
PKGNAME= pstoedit-3.11
CATEGORIES= graphics print
MASTER_SITES= http://www.geocities.com/SiliconValley/Network/1958/pstoedit/
-EXTRACT_SUFX= .zip
MAINTAINER= jseger@FreeBSD.ORG
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript5
FETCH_BEFORE_ARGS= -t
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -q
-EXTRACT_AFTER_ARGS= -d ${WRKDIR}
+USE_ZIP= yes
WRKSRC= ${WRKDIR}/pstoedit_3.11/src
MAKEFILE= makefile
ALL_TARGET=
diff --git a/japanese/pgp.language/Makefile b/japanese/pgp.language/Makefile
index 08fa183c4ab5..8a7b80be4c03 100644
--- a/japanese/pgp.language/Makefile
+++ b/japanese/pgp.language/Makefile
@@ -3,7 +3,7 @@
# Date created: 9 May 1997
# Whom: Hironori Ikura <hikura@kaisei.org>
#
-# $Id: Makefile,v 1.4 1998/10/16 03:42:28 jseger Exp $
+# $Id: Makefile,v 1.5 1999/02/03 11:11:49 asami Exp $
#
DISTNAME= pgp263i-${PGP_LANGUAGE}
@@ -11,18 +11,14 @@ PKGNAME= jp-pgp-2.6.3
CATEGORIES= japanese security
MASTER_SITES= ftp://ftp.win.or.jp/pub/network/pgp/2.x/lang/ \
ftp://ftp.ifi.uio.no/pub/pgp/2.x/lang/
-EXTRACT_SUFX= .zip
MAINTAINER= hikura@kaisei.org
RESTRICTED= "Crypto"
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -q
-EXTRACT_AFTER_ARGS= # empty
+USE_ZIP= YES
NO_BUILD= YES
# version and language specifications
diff --git a/japanese/qkc/Makefile b/japanese/qkc/Makefile
index d1b964e02b7b..c2ca23f4ce60 100644
--- a/japanese/qkc/Makefile
+++ b/japanese/qkc/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 May 1996
# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.9 1998/10/10 05:39:24 steve Exp $
+# $Id: Makefile,v 1.10 1999/02/03 11:11:51 asami Exp $
#
DISTNAME= qkcc100
@@ -11,15 +11,10 @@ PKGNAME= ja-qkc-1.0
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.lab.kdd.co.jp/Usenet/fj.sources/1995/oct/ \
ftp://ftp.iis.u-tokyo.ac.jp/pub1/unix/Kanji/
-EXTRACT_SUFX= .zip
MAINTAINER= max@FreeBSD.ORG
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -q
-EXTRACT_AFTER_ARGS= # empty
+USE_ZIP= yes
NO_WRKSUBDIR= yes
ALL_TARGET=
MAN1= qkc.1
diff --git a/korean/pgp.language/Makefile b/korean/pgp.language/Makefile
index 4565738e3556..24aae5a0e4d6 100644
--- a/korean/pgp.language/Makefile
+++ b/korean/pgp.language/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 Jul 1998
# Whom: CHOI Junho <junker@jazz.snu.ac.kr>
#
-# $Id: Makefile,v 1.2 1998/10/16 02:53:04 jseger Exp $
+# $Id: Makefile,v 1.3 1999/02/03 11:11:52 asami Exp $
#
# This is based on ja-pgp.
#
@@ -12,18 +12,14 @@ DISTNAME= pgp263i-${PGP_LANGUAGE}
PKGNAME= ko-pgp-2.6.3
CATEGORIES= korean security
MASTER_SITES= http://sparcs.kaist.ac.kr/~firiel/Works/
-EXTRACT_SUFX= .zip
MAINTAINER= junker@jazz.snu.ac.kr
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
RESTRICTED= "Crypto"
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -q
-EXTRACT_AFTER_ARGS= # empty
+USE_ZIP= yes
NO_BUILD= YES
# version and language specifications
diff --git a/math/freefem/Makefile b/math/freefem/Makefile
index 8c00bffd7214..33e3f7bdf284 100644
--- a/math/freefem/Makefile
+++ b/math/freefem/Makefile
@@ -3,25 +3,20 @@
# Date created: 20 December 1996
# Whom: Pedro Giffuni
#
-# $Id: Makefile,v 1.6 1998/08/05 09:31:29 asami Exp $
+# $Id: Makefile,v 1.7 1999/03/15 01:53:46 steve Exp $
#
DISTNAME= freefem-3.4
CATEGORIES= math cad
MASTER_SITES= http://www.asci.fr/~prudhomm/gfem-html/freefem/
-EXTRACT_SUFX= .zip
MAINTAINER= giffunip@asme.org
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-adapt --with-optimization
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= -q -o
-EXTRACT_AFTER_ARGS= -d ${WRKDIR}
+USE_ZIP= yes
post-install:
.if !defined(NOPORTDOCS)
diff --git a/misc/estic/Makefile b/misc/estic/Makefile
index 57c251cb4388..057a41db8206 100644
--- a/misc/estic/Makefile
+++ b/misc/estic/Makefile
@@ -1,9 +1,9 @@
-# FreeBSD ports collection makefile for: estic
-# Version required: 1.40
-# Date created: 21 Sep 1996
-# Whom: Julian Stacey <jhs@freebsd.org>
+# ports collection makefile for: estic
+# Version required: 1.40
+# Date created: 21 Sep 1996
+# Whom: Julian Stacey <jhs@freebsd.org>
#
-# $Id: Makefile,v 1.3 1998/11/29 12:43:11 asami Exp $
+# $Id: Makefile,v 1.4 1999/02/03 11:11:54 asami Exp $
#
DISTNAME= estic-1.40-sources
@@ -12,16 +12,11 @@ CATEGORIES= misc
MASTER_SITES= ftp://linux01.gwdg.de/pub/isdn/estic/ \
ftp://ftp.franken.de/pub/isdn4linux/estic/ \
http://www.fast.de/~uli/isdn/estic/
-EXTRACT_SUFX= .zip
MAINTAINER= jhs@FreeBSD.org
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-
USE_XLIB= yes
-EXTRACT_CMD= unzip
-EXTRACT_BEFORE_ARGS= # empty
-EXTRACT_AFTER_ARGS= # empty
+USE_ZIP= yes
NO_WRKSUBDIR= yes
# maybe one of them depends on the vga font from pcemu ?
@@ -56,7 +51,7 @@ do-install:
@# estic.doc is not nroff format, & is in German, volunteers to create
@# _and maintain_ nroff formatted English should contact ${AUTHOR}
${INSTALL_MAN} ${FILESDIR}/README ${PBX_DOC}
- @# files/README is not in nroff, but is a temporary document.
+ @# ${FILESDIR}/README is not in nroff, but is a temporary document.
@${MKDIR} ${PBX_ETC} ${PBX_VAR}
${INSTALL_DATA} ${ESTIC}/estic.ini ${PBX_ETC}/estic.ini.generic_example
${INSTALL_DATA} ${FILESDIR}/estic.ini ${PBX_ETC}/estic.ini.freebsd_example
@@ -72,18 +67,18 @@ post-install:
demo:
@echo "If you want to try this under X-Windows, do this:"
- @echo " setenv SPUNK_LANGUAGE 001"
- @echo " setenv SPUNK_XFONT 8x13"
+ @echo " ${SETENV} SPUNK_LANGUAGE 001"
+ @echo " ${SETENV} SPUNK_XFONT 8x13"
@echo " cd ${PBX_ETC}"
@echo " vi estic.ini"
@echo " chmod 666 /dev/cuaaX, or su"
@echo " ${ESTIC}/xestic -display :0"
@echo " (If you have no Istec 100[38] connected, append -n )"
- @echo " A BUGS & PROBLEMS section exists in files/README == man estic_freebsd"
+ @echo " A BUGS & PROBLEMS section exists in ${FILESDIR}/README == man estic_freebsd"
# Ref. NO_CDROM= & NO_PACKAGE=
# It is not necessary to prevent inclusion of source or binary on FreeBSD
# CDROMs, # (despite the original German phraseology) as I (<jhs@freebsd.org>)
-# have obtained a waiver. See files/README for explanation.
+# have obtained a waiver. See ${FILESDIR}/README for explanation.
.include <bsd.port.mk>
diff --git a/misc/estic/pkg-comment b/misc/estic/pkg-comment
index 3186f5f27426..bea9efd2721c 100644
--- a/misc/estic/pkg-comment
+++ b/misc/estic/pkg-comment
@@ -1 +1 @@
-Controller for ISDN TK-Anlage (PBX, Private Branch Exchange) made by Istec
+Controller for ISDN TK-Anlage (PBX) made by Istec
diff --git a/misc/estic/pkg-plist b/misc/estic/pkg-plist
index 73cb99d14cde..7e133113efd6 100644
--- a/misc/estic/pkg-plist
+++ b/misc/estic/pkg-plist
@@ -3,7 +3,7 @@ bin/estic.res
etc/pbx/estic.ini.generic_example
etc/pbx/estic.ini.freebsd_example
etc/pbx/aliases.example
-var/log/pbx/debug
+var/log/pbx/debug
etc/pbx/config
share/doc/estic/README
share/doc/estic/estic.doc