aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/zabbix-agent/Makefile4
-rw-r--r--net-mgmt/zabbix/Makefile6
-rw-r--r--net-mgmt/zabbix2-agent/Makefile4
-rw-r--r--net-mgmt/zabbix2/Makefile6
4 files changed, 18 insertions, 2 deletions
diff --git a/net-mgmt/zabbix-agent/Makefile b/net-mgmt/zabbix-agent/Makefile
index 74c982214a2f..8a1cb8c117e2 100644
--- a/net-mgmt/zabbix-agent/Makefile
+++ b/net-mgmt/zabbix-agent/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zabbix
PORTVERSION= 1.4.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -20,6 +21,9 @@ USE_RC_SUBR= zabbix_agentd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-agent --disable-server
MAKE_ARGS= ARCH=freebsd
+.ifndef WITHOUT_IPV6
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
ZABBIX_BIN= agent agentd get sender
ZABBIX_CFG= agent agentd
diff --git a/net-mgmt/zabbix/Makefile b/net-mgmt/zabbix/Makefile
index cc2ebfd54669..c5fe5533b5b8 100644
--- a/net-mgmt/zabbix/Makefile
+++ b/net-mgmt/zabbix/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zabbix
PORTVERSION= 1.4.3
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -23,6 +23,7 @@ OPTIONS= MYSQL "Use MySQL backend" on \
PGSQL "Use PostgreSQL backend" off \
SQLITE "Use SQLite backend" off \
LDAP "Support for checking LDAP servers" on \
+ IPV6 "Support for IPv6" on \
FPING "Use fping for pinging hosts" on
USE_GMAKE= yes
@@ -44,6 +45,9 @@ CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls \
sasl2.2:${PORTSDIR}/security/cyrus-sasl2
.endif
+.ifdef WITH_IPV6
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
.ifndef WITHOUT_FPING
RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
diff --git a/net-mgmt/zabbix2-agent/Makefile b/net-mgmt/zabbix2-agent/Makefile
index 74c982214a2f..8a1cb8c117e2 100644
--- a/net-mgmt/zabbix2-agent/Makefile
+++ b/net-mgmt/zabbix2-agent/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zabbix
PORTVERSION= 1.4.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -20,6 +21,9 @@ USE_RC_SUBR= zabbix_agentd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-agent --disable-server
MAKE_ARGS= ARCH=freebsd
+.ifndef WITHOUT_IPV6
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
ZABBIX_BIN= agent agentd get sender
ZABBIX_CFG= agent agentd
diff --git a/net-mgmt/zabbix2/Makefile b/net-mgmt/zabbix2/Makefile
index cc2ebfd54669..c5fe5533b5b8 100644
--- a/net-mgmt/zabbix2/Makefile
+++ b/net-mgmt/zabbix2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zabbix
PORTVERSION= 1.4.3
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -23,6 +23,7 @@ OPTIONS= MYSQL "Use MySQL backend" on \
PGSQL "Use PostgreSQL backend" off \
SQLITE "Use SQLite backend" off \
LDAP "Support for checking LDAP servers" on \
+ IPV6 "Support for IPv6" on \
FPING "Use fping for pinging hosts" on
USE_GMAKE= yes
@@ -44,6 +45,9 @@ CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls \
sasl2.2:${PORTSDIR}/security/cyrus-sasl2
.endif
+.ifdef WITH_IPV6
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
.ifndef WITHOUT_FPING
RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif