aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/rsync/Makefile2
-rw-r--r--net/rsync/files/rsyncd.in7
2 files changed, 6 insertions, 3 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 5a111d851229..c8271a8fe6c0 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rsync
PORTVERSION= 3.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= http://rsync.samba.org/ftp/%SUBDIR%/ \
ftp://ftp.samba.org/pub/%SUBDIR%/ \
diff --git a/net/rsync/files/rsyncd.in b/net/rsync/files/rsyncd.in
index 62540557eb34..d4ea0fe5b420 100644
--- a/net/rsync/files/rsyncd.in
+++ b/net/rsync/files/rsyncd.in
@@ -22,14 +22,17 @@ name="%%NAME%%"
rcvar=%%NAME%%_enable
command="%%PREFIX%%/bin/rsync"
-command_args="--daemon"
start_precmd="%%NAME%%_precmd"
pidfile="/var/run/$name.pid"
-required_files="%%ETCDIR%%/$name.conf"
# read configuration and set defaults
load_rc_config "$name"
: ${%%NAME%%_enable="NO"}
+: ${%%NAME%%_configfile:=%%ETCDIR%%/$name.conf}
+
+required_files="${%%NAME%%_configfile}"
+
+command_args="--daemon --config ${%%NAME%%_configfile}"
%%NAME%%_precmd()
{