aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/dtse/Makefile2
-rw-r--r--www/p5-CGI-Application-Plugin-Config-YAML/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-StatusMessage/Makefile3
-rw-r--r--www/p5-HTML-FillInForm-Lite/Makefile3
-rw-r--r--www/p5-HTML-TableLayout/Makefile3
-rw-r--r--www/p5-HTTP-Router/Makefile3
-rw-r--r--www/p5-HTTP-Session-State-MobileAgentID/Makefile3
-rw-r--r--www/p5-JE/Makefile3
-rw-r--r--www/p5-MediaWiki-API/Makefile3
-rw-r--r--www/p5-Mojo-Server-FastCGI/Makefile3
-rw-r--r--www/p5-Plack-Middleware-AutoRefresh/Makefile3
-rw-r--r--www/p5-Template-GD/Makefile3
-rw-r--r--www/p5-Template-Provider-Encoding/Makefile3
-rw-r--r--www/p5-VUser-Google-ProvisioningAPI/Makefile3
-rw-r--r--www/p5-WWW-Mixi-Scraper/Makefile3
-rw-r--r--www/p5-Web-oEmbed/Makefile3
-rw-r--r--www/p5-Yahoo-Lifestyle/Makefile3
-rw-r--r--www/p5-ZConf-RSS/Makefile3
19 files changed, 37 insertions, 19 deletions
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
index 77373a9770ae..aa7236572fab 100644
--- a/www/dtse/Makefile
+++ b/www/dtse/Makefile
@@ -24,7 +24,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif
-USE_PERL5= yes
+USES= perl5
USE_BZIP2= yes
USE_GMAKE= yes
USE_AUTOTOOLS= aclocal:env automake:env autoconf:env
diff --git a/www/p5-CGI-Application-Plugin-Config-YAML/Makefile b/www/p5-CGI-Application-Plugin-Config-YAML/Makefile
index efa3a796f1df..b1731eed7389 100644
--- a/www/p5-CGI-Application-Plugin-Config-YAML/Makefile
+++ b/www/p5-CGI-Application-Plugin-Config-YAML/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-CGI-Application>4.01:${PORTSDIR}/www/p5-CGI-Application \
RUN_DEPENDS= p5-CGI-Application>4.01:${PORTSDIR}/www/p5-CGI-Application \
p5-Config-YAML>=0:${PORTSDIR}/devel/p5-Config-YAML
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Application::Plugin::Config::YAML.3
diff --git a/www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile b/www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile
index a5360e254db4..95a4993f0d99 100644
--- a/www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile
+++ b/www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Net-OpenID-Consumer>=0:${PORTSDIR}/net/p5-Net-OpenID-Consumer
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::Authentication::OpenID.3
diff --git a/www/p5-Catalyst-Plugin-StatusMessage/Makefile b/www/p5-Catalyst-Plugin-StatusMessage/Makefile
index f244d9468992..26176c2898b7 100644
--- a/www/p5-Catalyst-Plugin-StatusMessage/Makefile
+++ b/www/p5-Catalyst-Plugin-StatusMessage/Makefile
@@ -12,7 +12,8 @@ COMMENT= Handle passing of status (success and error) messages
BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::StatusMessage.3
diff --git a/www/p5-HTML-FillInForm-Lite/Makefile b/www/p5-HTML-FillInForm-Lite/Makefile
index c3f3f6a81b3d..8aedf68bd045 100644
--- a/www/p5-HTML-FillInForm-Lite/Makefile
+++ b/www/p5-HTML-FillInForm-Lite/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for lightweight FillInForm module in Pure Perl
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= HTML::FillInForm::Lite.3 \
HTML::FillInForm::Lite::Compat.3 \
diff --git a/www/p5-HTML-TableLayout/Makefile b/www/p5-HTML-TableLayout/Makefile
index 1c3925110587..f79ec5324732 100644
--- a/www/p5-HTML-TableLayout/Makefile
+++ b/www/p5-HTML-TableLayout/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Layout manager for CGI-based web applications
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::TableLayout.3
diff --git a/www/p5-HTTP-Router/Makefile b/www/p5-HTTP-Router/Makefile
index 2080ae88e172..099aeb7d1ce9 100644
--- a/www/p5-HTTP-Router/Makefile
+++ b/www/p5-HTTP-Router/Makefile
@@ -28,7 +28,8 @@ BUILD_DEPENDS= \
p5-URI-Template-Restrict>=0.05:${PORTSDIR}/net/p5-URI-Template-Restrict
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::README.3 \
HTTP::Router.3 \
diff --git a/www/p5-HTTP-Session-State-MobileAgentID/Makefile b/www/p5-HTTP-Session-State-MobileAgentID/Makefile
index e4f51a3a57f7..2dda69c2d1e5 100644
--- a/www/p5-HTTP-Session-State-MobileAgentID/Makefile
+++ b/www/p5-HTTP-Session-State-MobileAgentID/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Session::State::MobileAgentID.3
diff --git a/www/p5-JE/Makefile b/www/p5-JE/Makefile
index c82762a0dc89..a4ecf410e6d1 100644
--- a/www/p5-JE/Makefile
+++ b/www/p5-JE/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= p5-TimeDate>0:${PORTSDIR}/devel/p5-TimeDate \
p5-Tie-RefHash-Weak>0:${PORTSDIR}/devel/p5-Tie-RefHash-Weak
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= JE::Object.3 JE::_FieldHash.3 JE::String.3 \
JE::Object::Boolean.3 JE::Object::Number.3 \
diff --git a/www/p5-MediaWiki-API/Makefile b/www/p5-MediaWiki-API/Makefile
index bddb41028f91..b707b7d3f23d 100644
--- a/www/p5-MediaWiki-API/Makefile
+++ b/www/p5-MediaWiki-API/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MediaWiki::API.3
diff --git a/www/p5-Mojo-Server-FastCGI/Makefile b/www/p5-Mojo-Server-FastCGI/Makefile
index cb93cc65744b..9f98d8558830 100644
--- a/www/p5-Mojo-Server-FastCGI/Makefile
+++ b/www/p5-Mojo-Server-FastCGI/Makefile
@@ -15,7 +15,8 @@ LICENSE= ART20
RUN_DEPENDS= p5-Mojolicious>=3.21:${PORTSDIR}/www/p5-Mojolicious
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mojolicious::Command::fastcgi.3 \
Mojo::Server::FastCGI.3
diff --git a/www/p5-Plack-Middleware-AutoRefresh/Makefile b/www/p5-Plack-Middleware-AutoRefresh/Makefile
index 433bc8ce4433..38862d985c50 100644
--- a/www/p5-Plack-Middleware-AutoRefresh/Makefile
+++ b/www/p5-Plack-Middleware-AutoRefresh/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-Readonly>0:${PORTSDIR}/devel/p5-Readonly
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Plack::Middleware::AutoRefresh.3
diff --git a/www/p5-Template-GD/Makefile b/www/p5-Template-GD/Makefile
index f6d30963bda6..3a8d9094df4d 100644
--- a/www/p5-Template-GD/Makefile
+++ b/www/p5-Template-GD/Makefile
@@ -17,7 +17,8 @@ COMMENT= Template Toolkit plugin to interface with GD modules
BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Plugin::GD.3 \
Template::Plugin::GD::Constants.3 \
diff --git a/www/p5-Template-Provider-Encoding/Makefile b/www/p5-Template-Provider-Encoding/Makefile
index 297bb5989a27..2c832f705cc1 100644
--- a/www/p5-Template-Provider-Encoding/Makefile
+++ b/www/p5-Template-Provider-Encoding/Makefile
@@ -18,7 +18,8 @@ COMMENT= Template plugin to specify encoding
RUN_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Provider::Encoding.3 \
Template::Stash::ForceUTF8.3 \
diff --git a/www/p5-VUser-Google-ProvisioningAPI/Makefile b/www/p5-VUser-Google-ProvisioningAPI/Makefile
index 600c34556d15..3bdfaa72c6be 100644
--- a/www/p5-VUser-Google-ProvisioningAPI/Makefile
+++ b/www/p5-VUser-Google-ProvisioningAPI/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Encode>=0:${PORTSDIR}/converters/p5-Encode \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= VUser::Google::ProvisioningAPI::V2_0::EmailListEntry.3 \
VUser::Google::ProvisioningAPI::V2_0::NicknameEntry.3 \
diff --git a/www/p5-WWW-Mixi-Scraper/Makefile b/www/p5-WWW-Mixi-Scraper/Makefile
index 10ec1f1a65d5..69c5fb46481b 100644
--- a/www/p5-WWW-Mixi-Scraper/Makefile
+++ b/www/p5-WWW-Mixi-Scraper/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= p5-Module-Find>=0:${PORTSDIR}/devel/p5-Module-Find \
p5-WWW-Mechanize>=1.50:${PORTSDIR}/www/p5-WWW-Mechanize
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_DOS2UNIX= yes
MAN3= WWW::Mixi::Scraper::Utils.3 \
diff --git a/www/p5-Web-oEmbed/Makefile b/www/p5-Web-oEmbed/Makefile
index ebf9b84d6d43..62041f4d0303 100644
--- a/www/p5-Web-oEmbed/Makefile
+++ b/www/p5-Web-oEmbed/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
p5-XML-LibXML-Simple>=0:${PORTSDIR}/textproc/p5-XML-LibXML-Simple \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Web::oEmbed.3
diff --git a/www/p5-Yahoo-Lifestyle/Makefile b/www/p5-Yahoo-Lifestyle/Makefile
index 3c239f00d6a9..9630fc4cd383 100644
--- a/www/p5-Yahoo-Lifestyle/Makefile
+++ b/www/p5-Yahoo-Lifestyle/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Yahoo-BBAuth>=0:${PORTSDIR}/security/p5-Yahoo-BBAuth \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Yahoo::Lifestyle.3
diff --git a/www/p5-ZConf-RSS/Makefile b/www/p5-ZConf-RSS/Makefile
index bcfe776b0318..46214d6b5307 100644
--- a/www/p5-ZConf-RSS/Makefile
+++ b/www/p5-ZConf-RSS/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-ZConf>=0:${PORTSDIR}/net/p5-ZConf \
p5-HTML-FormatText-WithLinks>=0:${PORTSDIR}/textproc/p5-HTML-FormatText-WithLinks
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ZConf::RSS.3 \
ZConf::RSS::GUI.3