aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/virt-viewer/Makefile25
-rw-r--r--net-mgmt/virt-viewer/distinfo2
-rw-r--r--net-mgmt/virt-viewer/pkg-descr8
-rw-r--r--net-mgmt/virt-viewer/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 3f740c5a8770..b0fb75f26b5e 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -281,6 +281,7 @@
SUBDIR += torrus
SUBDIR += trafd
SUBDIR += vidalia
+ SUBDIR += virt-viewer
SUBDIR += wdiag
SUBDIR += weathermap
SUBDIR += weplab
diff --git a/net-mgmt/virt-viewer/Makefile b/net-mgmt/virt-viewer/Makefile
new file mode 100644
index 000000000000..2f011a702c80
--- /dev/null
+++ b/net-mgmt/virt-viewer/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: virt-viewer
+# Date created: 2011-06-07
+# Whom: Jason Helfman <jhelfman@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= virt-viewer
+PORTVERSION= 0.2.0
+CATEGORIES= net-mgmt
+MASTER_SITES= http://virt-manager.org/download/sources/${PORTNAME}/
+
+MAINTAINER= jhelfman@experts-exchange.com
+COMMENT= Provides a graphical viewer for a guest OS display
+
+BUILD_DEPENDS= xml2-config:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= virt.9:${PORTSDIR}/devel/libvirt \
+ gtk-vnc-1.0.0:${PORTSDIR}/net/gtk-vnc
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= virt-viewer.1
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/virt-viewer/distinfo b/net-mgmt/virt-viewer/distinfo
new file mode 100644
index 000000000000..5a5f7363c7e9
--- /dev/null
+++ b/net-mgmt/virt-viewer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (virt-viewer-0.2.0.tar.gz) = 9772a9e2b55f7d4eeae012964c594c4f96129b130ed34004fa42033bc9ad1352
+SIZE (virt-viewer-0.2.0.tar.gz) = 329012
diff --git a/net-mgmt/virt-viewer/pkg-descr b/net-mgmt/virt-viewer/pkg-descr
new file mode 100644
index 000000000000..7f8a57eac2da
--- /dev/null
+++ b/net-mgmt/virt-viewer/pkg-descr
@@ -0,0 +1,8 @@
+Virt Viewer provides a graphical viewer for the guest OS
+display. At this time is supports guest OS using the VNC
+protocol. Further protocols may be supported in the future
+as user demand dicatates. The viewer can connect directly
+to both local and remotely hosted guest OS, optionally
+using SSL/TLS encryption.
+
+WWW: http://virt-manager.org/
diff --git a/net-mgmt/virt-viewer/pkg-plist b/net-mgmt/virt-viewer/pkg-plist
new file mode 100644
index 000000000000..45ac2fd71869
--- /dev/null
+++ b/net-mgmt/virt-viewer/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+bin/virt-viewer
+%%DATADIR%%/ui/about.glade
+%%DATADIR%%/ui/auth.glade
+%%DATADIR%%/ui/viewer.glade
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%