aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/pear-DB_QueryTool/Makefile3
-rw-r--r--databases/pear-DB_Sqlite_Tools/Makefile3
-rw-r--r--databases/pear-MDB_QueryTool/Makefile3
-rw-r--r--deskutils/egroupware/Makefile3
-rw-r--r--devel/pear-PHPUnit2/Makefile3
-rw-r--r--devel/pear-PHPUnit3/Makefile3
-rw-r--r--devel/pear-PHP_Beautifier/Makefile3
-rw-r--r--devel/pear-VFS/Makefile3
-rw-r--r--security/pear-LiveUser/Makefile3
-rw-r--r--security/pear-LiveUser_Admin/Makefile3
-rw-r--r--www/horde-base/Makefile4
-rw-r--r--www/horde4-base/Makefile4
12 files changed, 24 insertions, 14 deletions
diff --git a/databases/pear-DB_QueryTool/Makefile b/databases/pear-DB_QueryTool/Makefile
index 3e7af80f8384..b27a1d8a0039 100644
--- a/databases/pear-DB_QueryTool/Makefile
+++ b/databases/pear-DB_QueryTool/Makefile
@@ -7,13 +7,14 @@
PORTNAME= DB_QueryTool
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR OO-interface for easily retrieving and modifying data in a DB
BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
- ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+ ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
RUN_DEPENDS= ${BUILD_DEPENDS}
CATEGORY= DB
diff --git a/databases/pear-DB_Sqlite_Tools/Makefile b/databases/pear-DB_Sqlite_Tools/Makefile
index 33caeedc5a2c..10b8c51c99bf 100644
--- a/databases/pear-DB_Sqlite_Tools/Makefile
+++ b/databases/pear-DB_Sqlite_Tools/Makefile
@@ -7,13 +7,14 @@
PORTNAME= DB_Sqlite_Tools
PORTVERSION= 0.1.6
+PORTREVISION= 1
CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= an object oriented interface to backup Sqlite databases
BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
- ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+ ${PEARDIR}/Log/null.phpLog/null.php:${PORTSDIR}/sysutils/pear-Log
RUN_DEPENDS= ${BUILD_DEPENDS}
CATEGORY= DB
diff --git a/databases/pear-MDB_QueryTool/Makefile b/databases/pear-MDB_QueryTool/Makefile
index c96a9617696e..20516f0c61b6 100644
--- a/databases/pear-MDB_QueryTool/Makefile
+++ b/databases/pear-MDB_QueryTool/Makefile
@@ -7,13 +7,14 @@
PORTNAME= MDB_QueryTool
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR OO-interface for easily retrieving and modifying data in a DB
BUILD_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB \
- ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+ ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
RUN_DEPENDS= ${BUILD_DEPENDS}
CATEGORY= MDB
diff --git a/deskutils/egroupware/Makefile b/deskutils/egroupware/Makefile
index 3c994231a019..b33447f9ccfa 100644
--- a/deskutils/egroupware/Makefile
+++ b/deskutils/egroupware/Makefile
@@ -6,6 +6,7 @@
PORTNAME= eGroupWare
PORTVERSION= 1.2.106
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:C,http://nchc[^ ]+,,}
MASTER_SITE_SUBDIR= egroupware
@@ -49,7 +50,7 @@ USE_PHP+= imap
USE_PHP+= gd
.endif
.if defined(WITH_PEAR)
-RUN_DEPENDS= ${LOCALBASE}/share/pear/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS= ${LOCALBASE}/share/pear/Log/null.php:${PORTSDIR}/sysutils/pear-Log
.endif
.if defined(WITH_LDAP)
USE_PHP+= ldap
diff --git a/devel/pear-PHPUnit2/Makefile b/devel/pear-PHPUnit2/Makefile
index b0ce2817d82c..6d1f3ad02021 100644
--- a/devel/pear-PHPUnit2/Makefile
+++ b/devel/pear-PHPUnit2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PHPUnit2
PORTVERSION= 2.3.4
+PORTREVISION= 1
CATEGORIES= devel www pear
MAINTAINER= ports@FreeBSD.org
@@ -90,7 +91,7 @@ post-patch:
.include <bsd.port.pre.mk>
.if defined(WITH_PEAR_LOG)
-RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS+= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
.endif
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/devel/pear-PHPUnit3/Makefile b/devel/pear-PHPUnit3/Makefile
index a777a7380449..8e5593a0dfda 100644
--- a/devel/pear-PHPUnit3/Makefile
+++ b/devel/pear-PHPUnit3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PHPUnit
PORTVERSION= 3.0.6
+PORTREVISION= 1
CATEGORIES= devel www pear
MASTER_SITES= http://pear.phpunit.de/get/
@@ -259,7 +260,7 @@ _TESTSDIR= PHPUnit/Tests
.include <bsd.port.pre.mk>
.if defined(WITH_PEAR_LOG)
-RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS+= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
.endif
.if defined(WITH_JSON)
diff --git a/devel/pear-PHP_Beautifier/Makefile b/devel/pear-PHP_Beautifier/Makefile
index d7a057754351..584661b91553 100644
--- a/devel/pear-PHP_Beautifier/Makefile
+++ b/devel/pear-PHP_Beautifier/Makefile
@@ -7,12 +7,13 @@
PORTNAME= PHP_Beautifier
PORTVERSION= 0.1.12
+PORTREVISION= 1
CATEGORIES= devel www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR beautifier for PHP
-BUILD_DEPENDS= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+BUILD_DEPENDS= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PHP= tokenizer
diff --git a/devel/pear-VFS/Makefile b/devel/pear-VFS/Makefile
index 980e7dcda52b..f6ba8d21af52 100644
--- a/devel/pear-VFS/Makefile
+++ b/devel/pear-VFS/Makefile
@@ -7,13 +7,14 @@
PORTNAME= VFS
PORTVERSION= 0.1.0
+PORTREVISION= 1
CATEGORIES= devel pear
MAINTAINER= bg1tpt@gmail.com
COMMENT= PEAR Virtual File System API
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+ ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PHP= gettext
diff --git a/security/pear-LiveUser/Makefile b/security/pear-LiveUser/Makefile
index 9a5b2d6926fe..8684d3c138f1 100644
--- a/security/pear-LiveUser/Makefile
+++ b/security/pear-LiveUser/Makefile
@@ -7,6 +7,7 @@
PORTNAME= LiveUser
PORTVERSION= 0.15.1
+PORTREVISION= 1
CATEGORIES= security www pear
MAINTAINER= ports@FreeBSD.org
@@ -62,7 +63,7 @@ RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
.endif
.if defined(WITH_PEAR_LOG)
-RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS+= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
.endif
.if defined(WITH_PEAR_XML_TREE)
diff --git a/security/pear-LiveUser_Admin/Makefile b/security/pear-LiveUser_Admin/Makefile
index 367835547881..c14ddcbfe962 100644
--- a/security/pear-LiveUser_Admin/Makefile
+++ b/security/pear-LiveUser_Admin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= LiveUser_Admin
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= security www pear
MAINTAINER= ports@FreeBSD.org
@@ -59,7 +60,7 @@ RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
.endif
.if defined(WITH_PEAR_LOG)
-RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS+= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
.endif
.if defined(WITH_PEAR_XML_TREE)
diff --git a/www/horde-base/Makefile b/www/horde-base/Makefile
index d5693b0825a0..5f8ffa01ec60 100644
--- a/www/horde-base/Makefile
+++ b/www/horde-base/Makefile
@@ -8,7 +8,7 @@
PORTNAME= horde
DISTVERSIONPREFIX=
DISTVERSION= 3.1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
PKGNAMESUFFIX= -base
@@ -71,7 +71,7 @@ COMMENT= Common code-base used by Horde applications, written in PHP
#----------------------------------------------------------------------------
RUN_DEPENDS+= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date \
- ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
+ ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log \
${PEARDIR}/Mail/RFC822.php:${PORTSDIR}/mail/pear-Mail \
${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
diff --git a/www/horde4-base/Makefile b/www/horde4-base/Makefile
index d5693b0825a0..5f8ffa01ec60 100644
--- a/www/horde4-base/Makefile
+++ b/www/horde4-base/Makefile
@@ -8,7 +8,7 @@
PORTNAME= horde
DISTVERSIONPREFIX=
DISTVERSION= 3.1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
PKGNAMESUFFIX= -base
@@ -71,7 +71,7 @@ COMMENT= Common code-base used by Horde applications, written in PHP
#----------------------------------------------------------------------------
RUN_DEPENDS+= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date \
- ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
+ ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log \
${PEARDIR}/Mail/RFC822.php:${PORTSDIR}/mail/pear-Mail \
${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \